9 Replies Latest reply on Jul 21, 2010 7:45 AM by jorundrj

    on (release) action problem - how to fix the loading issue?

    jorundrj

      Hi,

       

      I'm making a progress with the website in Flash. I have pretty much things already done. Motion tweens that change alpha in percentage ammount are working correctly - I've used them for loading pages but I encountered a one tiny problem...

       

      Describing the website: there are buttons that - when you click - play an animation (motion tween with alpha changing) to load a proper page that is pinned with a particular button. So: home button loads the home page, bio button loads the bio page etc. All pages go with the motion tween - they fade in the website (from alpha 0% to 100%). Everything is fine and the website with everything works just perfect! But: there's one thing that doesn't keep me calm. When I open my website in a browser to test it and I click on each button to load pages - everything is ok, but when I want to click the same button few times - other things are being loaded by clicking the same button.

       

      For instance: I click the "bio" button once and it loads my biography page with the motion tween as I described before. But when I want to click it secondly or thirdly it doesn't load my biography page anymore but a page before that one (in this case: home page). When I click it again the button loads my bio page again. So - in sum - it doesn't load the same page all the time, but randomly: the proper one or the one before (in the timeline).

       

      My AC code for each button is simple, for example:

       

      on (release) {
          gotoAndPlay(173);
      }

       

      Also I've got the "actions" layer that carries stop(); command in places that are for it.

      I tried with _root.gotoAndPlay and also with frame_number +1 and always the same problem.

      I hope it isn't anything serrious and can be fixed.

      I'll be very grateful for help.

      Greets!

      J.J.