15 Replies Latest reply on Aug 5, 2014 6:38 AM by davidwhitehill

    escape key not recognized

    rebel4141 Level 1

      greetings.

       

      i just recently switched over to a new computer at work and using another designer's workstation w/ cs3.  for some reason unknown to me, the "ESC" (escape) key will not work for me when trying to deactivate a text box.

       

      i looked under the keyboard shortcuts menu and found where to input this shortcut (keybord shortcuts/product area: tools/selection tool (highlighted) ...and see the current shortcuts set at "default: v" and "text: escape" so i know it's there.

       

      however, when i try to input a new shortcut and hit the escape key, it's not being recognized at all.  same thing happens when trying to set the escape key for any other shortcut.

       

      i'm experiencing the same issue in illustrator, as well.

       

       

      any thoughts are greatly appreciated.

        • 1. Re: escape key not recognized
          Eugene Tyson Adobe Community Professional & MVP

          Are you sure the Esc key is working? Does it work in other applications? It could be your keyboard regional settings, check to make sure.

          • 2. Re: escape key not recognized
            bsb43

            I wish this issue had been resolved! I'm now experiencing the same issue.  When I have InDesign open, the escape key does NOT work. Even if I alt-tab to a different program all together, the escape just doesn't work.  Once I close InDesign, the escape key regains its normal functionality in all other programs.  In InDesign, If I hold down the windows key and hit the escape key, that DOES work. I checked my keyboard shortcuts and they currently have the default configuration, with the escape key selecting the selection tool while in text mode.  I'm using CS3 on Windows 7.  I have another machine with CS3 on Windows 7, and its works just fine.  Both computers have all windows and adobe updates installed.  Please help.

            • 3. Re: escape key not recognized
              Peter Spier Most Valuable Participant (Moderator)

              Is this a laptop? I don't have an answer, but I suspect this may be a BIOS or keyboard driver issue rather than an ID or Windows problem. We used to see reports of the Enter keys not working correctly with some laptops because the hardware manufacturers mapped them together, but Esc is a new one.

              • 4. Re: escape key not recognized
                bsb43 Level 1

                Actually, it's on my desktop computer.  The one that's working is my laptop.  It was working previously on the desktop, but I got a new wireless card and had an issue, and had to format my computer and re-install everything.  And now the escape key won't work when Adobe In Design is open.  Because of this issue with the esc key, I formatted and re-installed again.  Initially, immediately upon installing CS3, I didn't have the esc key issue.  But as I continued to re-install software and updates the esc key issue developed.

                • 5. Re: escape key not recognized
                  Eugene Tyson Adobe Community Professional & MVP

                  Did you test the ESC key with each install to track down which one was giving issue?

                  • 6. Re: escape key not recognized
                    bsb43 Level 1

                    hehe....no.  That would make things too easy.

                    • 7. Re: escape key not recognized
                      Ian Blogs Level 3

                      Check this, it is for Photoshop but who knows...http://forums.adobe.com/thread/372523

                      • 8. Re: escape key not recognized
                        bsb43 Level 1

                        I just tried formatting and re-installing again so I could track when the problem occured for me.  This time, it started from the outset.  I also had seen that photoshop esc-key problem thread before and tried the solution suggestions in that thread to no avail.  Anybody have any other ideas?

                        • 9. Re: escape key not recognized
                          bsb43 Level 1

                          Well, I just figured out what the issue was on my machine.  It is my latest Catalyst Control Center Video Driver (10.6) for an ATI 3xxx series on Windows 7.  Previously, during testing, I had just closed the catalyst control center in my system tray.  But apparently, that doesn't fully shut down the program.  I did a ctrl+alt+del to get to the task manager, and closed down CCC.exe in processes.  Now, the issue is gone.  So now I just need to figure out how to prevent ccc.exe from running ever again. Any ideas?

                          • 10. Re: escape key not recognized
                            Joel Cherney Level 5

                            Start -> the "search programs and files" field -> msconfig

                             

                            I actually haven't used it since Win98, and was blown away to find out that it still exists. But it does, and it's a very convenient method of combing through the Win7 startup process.

                            • 11. Re: escape key not recognized
                              Peter Spier Most Valuable Participant (Moderator)

                              You can probably uninstall catalyst through add/remove programs in the Windows control panel. I haven't used it since Win 98 or earlier, either as it was always a problem.

                              • 12. Re: escape key not recognized
                                FrankMazz

                                Yep, ATI was the culprit for me, too. Thanks for the tip. Odd, because my

                                escape key problem surface after I updated the ATI driver and catalyst control center.

                                You'd think the newest drivers would.... oh, never mind. grrrr

                                Thanks again.

                                • 13. Re: escape key not recognized
                                  ˉ˚°º•♪♫ Robert ♫♪•º°˚ˉ Level 1

                                  Ps CS4 11.0.2 (64-bit)

                                  Windows 7 Pro SP1

                                   

                                  Apologies for bumping this oldie. Escape key is completely dead in and outside of Ps.

                                  The weird thing is that it can only be reproduced by opening Ps (with or without a file) while CCC.exe is running (AMD VISION Engine Control Center).

                                  So one would be inclined to blame Ps.

                                   

                                  Adobe staff and users carrying a tarred and feathered ATI driver writer, out of town on a train rail :

                                  http://2.bp.blogspot.com/_3mEHv2LUGWA/ScK2RbecoxI/AAAAAAAABJA/nBrXAZBsU8w/s400/tarredandfeathered.png

                                   

                                   

                                  The problem returned with the following AMD/ATI driver :

                                   

                                  [QUOTE]Driver Packaging Version    8.872-110707b-122569C-ATI   
                                  Catalyst Version    11.7   
                                  Provider    ATI Technologies Inc.   
                                  2D Driver Version    8.01.01.1171   
                                  2D Driver File Path    /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE1031 8}/0000   
                                  Direct3D Version    7.14.10.0847   
                                  OpenGL Version    6.14.10.10907   
                                  AMD VISION Engine Control Center Version    2011.0707.2346.40825   
                                  [/QUOTE]

                                   

                                  Closing CCC.exe in the Windows task manager, then restarting Ps cured it.

                                  • 14. Re: escape key not recognized
                                    Kaz O

                                    or use Shift + Esc out side of PS for regular Esc behavior.

                                    • 15. Re: escape key not recognized
                                      davidwhitehill

                                      Disable the Hotkeys on your graphics card. (The integrated one if you have 2) This worked immediately for me.

                                      disable hotkey.jpg