1 2 3 4 Previous Next 143 Replies Latest reply on Mar 29, 2017 4:12 AM by funkpost

    Move Tool does not move layer when dragging with Wacom tablet

    hirshmon Level 1

      I am using the trial version of CS5 (probably going to upgrade at the end of the trial), and I've only found one thing about it that I don't like more than CS3. This is VERY VERY annoying, and I'm not sure if it's a glitch, or just a preference that needs to be reset:


        When using the move tool, I will move something and it will just snap back to where it originally was. When it snaps back, it might move a few pixels over in the direction I was dragging, but it is definitely not moving to where I want it to go. The only way to get things to move the way I want to is by Free Transform...but it's annoying, when you're trying to design a layout, to have to free transform every element you want to move, first.


      I'm guessing that this is a glitch because sometimes it happens and sometimes it doesn't...it's pretty random. I've tried turning Snap on and off, and nothing changes. Any idea how to fix/change this?




      Message title was edited by: Brett N

        • 1. Re: Move Tool in CS5

          This has happend to me also. I just quit out of Photoshop and restart the program and its goes away.

          Also, you can quit out of your program...then hold down the "shift, control, cmd" key to reset all your preferences to the default. This won't affect your "workspace" if you have created one.

          • 2. Re: Move Tool in CS5
            hirshmon Level 1

            Doesn't help

            • 3. Re: Move Tool in CS5
              Michael Riordan Adobe Community Professional

              This can happen if you drag and the cursor ends up over a panel or other GUI element. Make sure you're not letting go of the mouse when the cursor is over one of these areas.

              • 4. Re: Move Tool in CS5
                hirshmon Level 1

                No, this wasn't the problem either.


                I think I found the solution, though...although the solution definitely sounds like this is a glitch in CS5 that needs to be fixed.


                I have a Wacom Intuous4 tablet installed. When I try to use the move tool and drag it around with my Wacom mouse, it works fine. When I try to move something around with the trackpad (which I do frequently after I've entered in some keyboard shortcuts), it has the snapback problem.


                So I think that maybe the problem is: when you have a tablet installed, the mouse works and the trackpad stops working.

                • 5. Re: Move Tool in CS5
                  Michael Riordan Adobe Community Professional

                  That sounds like a driver problem. See if the trackpad and/or the tablet have updates on their websites.

                  • 6. Re: Move Tool in CS5
                    hirshmon Level 1

                    Updated my drivers, problem still exists.

                    • 7. Re: Move Tool in CS5
                      Jeffrey Tranberry Adobe Employee

                      Or you're leaving the pen in to close of proximity of the tablet.

                      • 8. Re: Move Tool in CS5
                        hirshmon Level 1

                        The pen is in the holder, which is on the other side of my desk. Don't think that is the problem.... also, when the pen is too close, that prevents the mouse from moving effectively. It does not affect the trackpad, which is the problem.


                        I'm using a MacBook Pro with the most recent version of SnowLeopard, if that helps.

                        • 9. Re: Move Tool in CS5
                          TheFlash12345 Level 1

                          I am having the exact same CS5 trackpad drag problem.  It seems as if there is a problem within CS5 that after a period of time it seems to have trouble with the glass touchpad on the macbook pro unibody, and doesnt recognize the difference between the button and the pad, so when you release something you drag it snaps back to it's original position because it thinks you are touching two place on the pad....  that's my best guess.   My work arounds have been quiting the program and reopening seems to fix it, or just using my tablet.   It happens for me with or without the tablet, so the tablet is just a work around.  It is a very consistent problem.


                          MBP 10.6.4 unibody

                          • 10. Re: Move Tool in CS5
                            Jeffrey Tranberry Adobe Employee

                            I think we may know what's going on here. Are there docked panels above the area you are trying to drag objects?


                            This thread describes a similar problem dragging doc to doc or doc to desktop, but the same issue affects moving layers in a document located in the same area.



                            • 11. Re: Move Tool in CS5
                              hirshmon Level 1

                              I thought that might be the problem seeing the link you posted, but unfortunately it's not. I tried doing that in CS5 and it moved into th

                              at area perfectly when I used the mouse, but same problem when I tried with the trackpad. I also tried moving the layer in the other direction (so it wasn't overlapping the area), but it did the same jerk-back problem.

                              • 12. Re: Move Tool in CS5
                                - JM - Level 3

                                >I think we may know what's going on here. Are there docked panels above the area you are trying to drag objects?


                                I found this to be true, dragging within the same restricted area below expanded panels doesn't work.

                                • 13. Re: Move Tool in CS5
                                  TheFlash12345 Level 1

                                  Would that explain why it will drag fine with the tablet but not the trackpad?


                                  Also the problem goes away after quitting and restarting?

                                  • 14. Re: Move Tool in CS5
                                    - JM - Level 3

                                    drag within a document over the "protected" area doesn't work for me with either tablet or mouse, and restarting PS has no effect.

                                    • 15. Re: Move Tool in CS5
                                      TheFlash12345 Level 1

                                      I don't believe this is the problem in my case.   Everytime I restart photoshop the problem goes away, then after a certain amount of time the problem recurs.  I don't have anything protected or docked.   I am using a tablet to draw, and I occasionally use the text tool to label something,  I can also move the layer with the tablet but not the trackpad.  So would something be locked for the trackpad and not the tablet?

                                      • 16. Re: Move Tool in CS5
                                        teschka_ Level 1

                                        I have exactly the same problem. I´m using a full version of cs5, educational, but still. Very annoying. I´m using a wacom too usually, but it´s switched off and in my bag, so can´t be the pen or whatever..

                                        • 17. Re: Move Tool in CS5
                                          sperry1975 Level 1

                                          I'm experiencing the same problem as described here and I too have a macbook pro unibody and a wacom tablet.  I don't know who's at fault but I can't help think it's Adobe seeing that before upgrading to CS5 from CS4 I didn't experience this problem but had the same computer and tablet.

                                          • 18. Re: Move Tool in CS5
                                            TheFlash12345 Level 1

                                            i also seem to be able to select transform object and then I can move the object with the trackpad when this problem occurs.

                                            • 19. Re: Move Tool in CS5
                                              Roy Murray Level 1

                                              I have found the same thing using a Mac Pro and their new trackpad. The Wacom Tablet allows movement but the trackpad doesn't. It must be a Mac interface problem.

                                              • 20. Re: Move Tool in CS5
                                                TheFlash12345 Level 1

                                                I really think it has something to do with a driver or something, over time failing to separate the area over the button as just a button when you click (since there whole pad is a trackpad) and Photoshop somehow thinks you are touching two places at the same time and snaps back to your old position. That's my theory.

                                                • 21. Re: Move Tool in CS5
                                                  [scott] Level 6

                                                  This occasionally happens to me with my MacPro and Inutos tablet. With the move tool or transforming a layer.


                                                  How I fix it... Undo. Then Command-+ (plus) followed by Command-- (minus). Then the tool will act as expected.


                                                  Something to do with the video card not getting correct signals or something when the app has been backgrounded and brought forward.

                                                  • 22. Re: Move Tool in CS5
                                                    TheFlash12345 Level 1

                                                    I also find that I can use the arrow keys as a workaround moving something into place.

                                                    • 23. Re: Move Tool in CS5
                                                      S. Dierdorf Level 1

                                                      I have an Intuos 4, and I am having the same problem. I have a Magic Trackpad and a regular trackball; the problem happens with the Magic Trackpad, but not the trackball. Weirdly, switching between the trackball and the trackpad seems to cause the problem to go away sometimes.



                                                      • 24. Re: Move Tool in CS5
                                                        Razorbolt Level 1

                                                        I am also having this exact same problem. With and without a Wacom Bambo installed. Another note is that if you use the transform tool (cmd+t), you can move the selection fine. Another thing that you may not a have noticed when this problem starts is that the Quick Select Tool stops working.


                                                        Can we have a patch or some way of solving this issue without restarting Photoshop all the time.


                                                        MBP15'' + Wacom Bambo





                                                        • 25. Re: Move Tool in CS5
                                                          visualcraft Level 1

                                                             I have the same problem. Restarting PS doesn't help (full version of CS5)

                                                          It's definitely the trackpad on the Macbook Pro, and even the external (wireless) Magic Trackpad has the same problem.

                                                          With a Wacom tablet there's no problem at all.

                                                          Sure a bug in PS that has to be corrected: please as soon as possible! Very annoying.

                                                          • 26. Re: Move Tool in CS5
                                                            MLippeth Level 1

                                                            [SW] is correct, by undoing and Command + then Command - corrects this "bug". Somehow this corrects this. Maybe it is something with the video card caching. CS4 was similar to other types of bugs that this fix also has corrected.

                                                            • 27. Re: Move Tool in CS5
                                                              TheFlash12345 Level 1

                                                              Maybe in some instances, but Command + then Command - does not correct the bug for me.   I find the bug more often happens when using certain fonts.

                                                              • 28. Re: Move Tool in CS5
                                                                visualcraft Level 1

                                                                In the meantime I found this problem solved after doing an update from Photoshop:

                                                                menu Help > Updates ...

                                                                I've installed a big update, and the issue was gone.

                                                                I hope this helps!

                                                                • 29. Re: Move Tool in CS5
                                                                  Jeffrey Tranberry Adobe Employee

                                                                  That's correct. This issue is fixed in the 12.0.2 update.

                                                                  • 30. Re: Move Tool in CS5
                                                                    hirshmon Level 1

                                                                    I upgraded to 12.0.2 when it was first released, and the problem has still occurred since. I don't know why it fixed the issue for you and not for me...

                                                                    • 31. Re: Move Tool in CS5
                                                                      TheFlash12345 Level 1

                                                                      I have upgraded, and the problem very much still exists.

                                                                      • 32. Re: Move Tool in CS5
                                                                        strubedesign Level 1

                                                                        I had the same problem with the "move tool snapping back to the original spot" with my BAMBOO Tablet. So, I consulted with our computer experts on how to resolve that problem along with some other problems I was having with my machine. Going to the extreme here, the consultants cleaned off my hard drive, installed a new operating system "snow leopard", reinstalled all my programs and now all my issues have been resolved including the CS5 move tool snapping back to it's original place.




                                                                        Since I had CS3, CS4, plus CS5 installed on my machine (in which CS3 was deinstalled at one time), the consultants thought that the deinstall on CS3 left ruminants on my hard drive and that might have been creating some of my issues including the CS5 move tool. I was also having other problems in CS5 and the consultants thought that by updating my operating system CS5 would work more efficiently. CS5 in my older operating system ran much slower and now I'm running CS5 in snow leopard and my machine is running extremely fast now.




                                                                        Since cleaning off my hard drive, updating my operating system to snow leopard, updating my wacom and intuos drivers, and reinstalling all my programs, all my issues have been resolved.  I now LOVE working in CS5 and my computer is running extremely fast!



                                                                        Good luck and hope you don't have to go to extreme measures like I had too!


                                                                        p.s. I have an Intuos Tablet at home and it behaved the same way. Then my hard drive finally blew up a couple of months ago.  I got a new computer with the latest operating system and resintalled all my programs and updated my Intuos Wacom tablet driver and haven't had any issues since. What operating system are you running for CS5...Just a thought.

                                                                        • 33. Re: Move Tool in CS5
                                                                          Jeanne Rubbo Adobe Employee

                                                                          It looks like the layer move problem in this thread might actually be two separate issues.


                                                                          The first was related to where the mouse was released when dragging the layer. This issue was fixed in the 12.0.2 update. Here's a forum thread (same one that Jeff posted above) with a more visual demonstration:





                                                                          The second issue is not related to the positioning of the panels or where the mouse is released, and that's the one that people are still running into, even after installing 12.0.2. We are trying to track down the cause of this one, so any information is appreciated.


                                                                          For those of you with 12.0.2 installed who are still encountering an issue with moving layers, are you using a tablet when this problem occurs? If not, do you have a tablet driver installed and/or the tablet plugged in at the time?

                                                                          • 34. Re: Move Tool in CS5
                                                                            TheFlash12345 Level 1

                                                                            I believe it always occurs when the tablet is plugged in, after it begins it doesn't matter if the tablet is plugged in or not.   I have noticed it often occurs when I add a unique font, like a handwriting font, or I paste in an image copied from a google search.

                                                                            • 35. Re: Move Tool in CS5
                                                                              hirshmon Level 1

                                                                              The problem only occurs when my Intuos4 tablet is plugged in. It occurs in mouse AND pen mode. When the tablet is unplugged, the trackpad works normally. It's still annoying not being able to use the trackpad when the mouse is plugged in, as many times I don't want to switch out the mouse/pen just to nudge something a little.

                                                                              • 36. Re: Move Tool in CS5
                                                                                Jeanne Rubbo Adobe Employee

                                                                                Thanks for the info! It looks like this is most likely a known issue on our side -- it happens if you start Photoshop when the stylus is in proximity of the tablet.


                                                                                Do any of you still run into the issue if you move the stylus away from the tablet before starting Photoshop?

                                                                                • 37. Re: Move Tool in CS5
                                                                                  hirshmon Level 1

                                                                                  No; when I start Photoshop, the mouse is on the tablet and the stylus is in its holder on the other side of the desk.

                                                                                  • 38. Re: Move Tool in CS5
                                                                                    Jeanne Rubbo Adobe Employee

                                                                                    Sorry for not clarifying this better -- it can happen with either the stylus or the mouse on the tablet. Does it still happen if you move the mouse away (before starting Photoshop)?

                                                                                    • 39. Re: Move Tool in CS5
                                                                                      hirshmon Level 1

                                                                                      Hi Jeanne,


                                                                                      I just tried it out with the mouse and pen off the tablet and on the other side of the desk...same result.

                                                                                      1 2 3 4 Previous Next