7 Replies Latest reply: Oct 20, 2010 11:37 AM by Diana Densmore RSS

    EmailService default connection

    RudiAcikgoz Community Member

      Hi,

       

      I used EmailService in my process and I also tried to use default settings for sending email (by checking box labeled as Use Global Settings). But I got error below, and I could not find where I should enter the appropriate values as default email connection settings?

       

      2010-10-18 14:11:19,822 WARN  [com.adobe.workflow.AWS] com.adobe.idp.dsc.email.ConnectionFailedException: Failed to connect to email server: null. Reason: Could not connect to SMTP host: localhost, port: 25
          at com.adobe.idp.dsc.email.EmailServiceImpl.sendMessage(EmailServiceImpl.java:473)
          at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithMapOfAttachments(EmailServiceImpl.java:4 33)
          at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithDocument(EmailServiceImpl.java:344)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)

      ....

        • 1. Re: EmailService default connection
          Diana Densmore techies

          Hi

          The error message you are getting is: "Could not connect to SMTP host: localhost, port: 25"

          Do you have an email server installed on the same box as your LiveCycle server?

           

          Diana

          • 2. Re: EmailService default connection
            RudiAcikgoz Community Member

            Hi Diana,

            thank you for your reply.

             

            Nope. I am using a public email account to do so.

            • 3. Re: EmailService default connection
              Diana Densmore techies

              Then you need to connect to that server/service.

              If you are using gmail for example your host will have to be: smtp.gmail.com.

               

              Diana

              • 4. Re: EmailService default connection
                RudiAcikgoz Community Member

                Hi Diana,

                 

                I achieved to run it properly by using gmail by applying connection settings manually (without clicking 'Use Global Settings' checkbox and entering each detail in Connection tab for EmailService component). But, what I want to know is configuring global outgoing email settings for all processes. At the end, it will make an email accont to be used for all process by default.

                 

                I tried to configure email server settings at adminui application, but I got the same error. Then, I added a default email endpoint and again I got the same error. So far, I need to configure each EmailService component's connection settings one by one, which is not common once considering business process development.

                • 5. Re: EmailService default connection
                  Diana Densmore techies

                  Hi

                  The Server Settings located in adminui are not the ones used for Global Settings on the Email service.

                  (The ones set in the adminui are used for notifications of Workspace Task Assignments.)

                   

                  Here's where you need to set the Global Settings:

                  1) In Workbench, choose Window->Show View->Components.

                  2) Expand the components.You will see 2 components titled Email.

                  3) Choose the second one. Expand Active Services. You should see "EmailService:1.0."

                  4) Right click on the EmailService:1.0 and choose "Edit Service Configuration".

                  5) Add your values and then Stop/Start the service.

                   

                  These values will be used in your Email Service if you select Use Global Settings.

                   

                  Hope this helps.

                  Diana

                  • 6. Re: EmailService default connection
                    RudiAcikgoz Community Member

                    Hi Diana,

                     

                    I am really appreciated it. it works fine now.

                     

                    I could not find the same explanation nowhere in Internet. If you give relevant URL then it may help others, who get stuck with the same.

                    • 7. Re: EmailService default connection
                      Diana Densmore techies

                      Glad to hear that it's now working for you.

                       

                      I will be adding this to my blog post.

                      I will also request that this information be added to the documentation.

                       

                      Diana