3 Replies Latest reply on Oct 27, 2010 6:52 AM by msarry

    Flash Player debugger dead - reinstall fails

    PeakDigital Level 1

      Without any obvious cause, I suddenly cannot debug anything from Flex.


      My development computer is a quad G5 PowerPC Mac running OS X.5.8


      When I try to debug I get this message in a popup:


      /Library/Internet Plug-Ins/Flash Player.plugin


      Flex Builder cannot locate the required debugger version of Flash Player. You might need to install the debugger version of Flash Player 9 or reinstall Flex Builder.


      Do you want to try to debug with the current version?



      I downloaded and ran the Adobe Flash Player Uninstaller app, which said it was successful. However, when I tried to run a Flex app, it still worked even though the Flash Player had supposedly been removed. I ran it again and restarted the system, this time it appeared to remove it successfully.


      After that I tried to reinstall the debugging version of FP again. The file was downloaded from http://www.adobe.com/support/flashplayer/downloads.html and is titled "Download the Macintosh Flash Player 9 Plugin content debugger (PowerPC-based Macs) (DMG, 3.39 MB)"


      The disk image file is named "flashplayer_9_plugin_debug.dmg" so I'm sure I have the right version. If I run a Flex app, right-click on it and choose "about Flash Player", it says: You have version 9,0,246,0 installed

      Unfortunately, after installing and restarting, I still get the same message as above when I try to debug.


      edit: The app seems to run normally, except that none of my trace() commands appear in the Flex console. After quite a while, this message pops up:


      Failed to connect; session timed out.
      Ensure that:
        1. You compiled your Flash application with debugging on.
        2. You are running the debugger version of Flash Player.


      Any suggestions before I end up reinstalling Flex Builder?