7 Replies Latest reply: Nov 18, 2010 2:10 PM by Jeff_Coatsworth RSS

    FrameMaker demo problem


      I am attempting to load a demo of FrameMaker 9 on my laptop to see if it will work for my company. The specs on this computer are more than adequate, and I am running Windows 7, 64 bit. I installed the Technical Suite 2.5 demo as I could not get the FrameMaker standalone demo to download correctly. It installs fine, or seems to. After installation I click on the FrameMaker icon, the splash screen comes up. It loads about halfway, then an error message comes up that tells me that the LangaugeDir is missing or corrupted. My harddrive has two partitions. I have attempted to install it on both partitions, with uninstalls and reboots every step of the way. I deleted off everything and downloaded it a second time, with the same results. I can get the other components, RoboHelp and Acrobat Extended to load just fine, but FrameMaker refuses. The only help I've found on this suggested checking the maker.ini file to see if LanguageDir was pointing at the right folder. It said "LanguageDir=dict" and I confirmed there is a folder called "dict" in the FrameMaker directory and it is nonempty. Not sure what else to try at this point. Does this program even work on a 64 bit machine? I guess its not much use to me at work if it won't run on my machine, no matter what the features are.

        • 1. Re: FrameMaker demo problem
          Art Campbell Community Member

          It runs fine on W7, although it was developed before 7 was released, so it's not officially supported.


          From from what you mentioned, it sounds as if your download may have been corrupted, given that you also had problems with the FM stand alone download.

          Or possibly, that your AV program is interfering with the install.


          However, if you think that's not the case:

          * Did you install, and are you running the program as an Administrator?

          * Did you run the compatibility troubleshooter?

          (Both of these are available if you right-click).


          You may also try updating FM -- the downloads are sometimes not the latest builds, and there was a patch released not too long ago.



          • 2. Re: FrameMaker demo problem
            Sheila Carlisle Community Member

            A solution for the LanguageDir / dictionary problem has been discussed fairly recently on the forum, if you look at the top right of the window you'll see a "Search FrameMaker Forum" entry where you can type in the term "languageDir" (without quotes) to find the specific threads.




            Please let us know whether the suggestions on the threads fix the problem for you --



            • 3. Re: FrameMaker demo problem
              joshuallen1 Community Member

              When I tried that, I had three hits, one for this threat, one for a similar question with no answers, and one for someone running FM9 on Win 2003

              server. The suggestion there said to ensure that LanguageDir=dict in maker.ini pointed to the correct folder and that I have permissions for those folders. I checked that and the folder is there, and as far as I can tell, I have permissions. The folder is in the main Technical Suite 2.5 folder where I would expect it to be. There are a bunch of files in there, but I have no master list to check it against or anything. I can only assume its complete. I've downloaded it twice, but perhaps I should try again. I did try running compatability in Vista and XP and forcing it to run as administrator--same results. I'm using and admin-level account. I'll try turning off AV and rerunning/reinstalling and see if that does the trick.

              • 4. Re: FrameMaker demo problem
                Sheila Carlisle Community Member

                I think you'll need to be sure that the Language files are removed (manually) after uninstall and before reinstall.


                You might also try searching the Framers list archives:



                Just use Google and follow your search term with "site:lists.frameusers.com".

                . For example, type "LanguageDir site:lists.frameusers.com" (without quotes) into the Google search box.




                If your search term has spaces, put quotation marks around the search term, e.g.


                "master page" site:lists.frameusers.com




                • 5. Re: FrameMaker demo problem
                  joshuallen1 Community Member

                  I tried disabling my virus scan, re-downloading, uninstalling, deleting the old dict files, reinstalling, applying all four patches I could find for FrameMaker 9. I still can't download just FM from Adobe. When I click on the download, it saves only the .exe file, not the zip file. If i run that .exe, it tells me I need the other part. I tried it on two different computers, with two different operating systems. Same results. On the only other thread mentioning this, the guy solved the poblem by disabling his virusscan. He was also rooting through his registry, which I don't really like to do without specific instructions. If anyone knows anything else worth trying, I'll definitely give it a go.


                  Otherwise, I'm open to other suggestions for software that's good at handling long documents with lots of figures, because I was really hoping FM was going to help me.

                  • 6. Re: FrameMaker demo problem
                    Art Campbell Community Member

                    You're not mentioning downloading the download manager (which I hate, but that's a different issue).


                    At this point, I'd try using a different browser, and/or downloading on a different system.

                    • 7. Re: FrameMaker demo problem
                      Jeff_Coatsworth MVP

                      You should be getting the Akamai Download Manger installed first, which then pulls the .exe and .7z file down from what I remember. Then you run the .exe and it unpacks the .7z file and installs.


                      Have you tried contacting Adobe Support? - installation & download support is free.