32 Replies Latest reply on Mar 29, 2011 1:58 PM by standers

    Code navigator stuck on

    Rocco Charamella Level 1

      Hi all,

       

      I hope you can help. I'm on a Mac using CS5. Somehow my code navigator (the little popup that shows html, css, etc) thinks it's always on and I can't turn it off or get it back to normal funtion. Every time I click in a page I am editing a warning message comes up that says "There is no destination for Code Navigator to show for the selection". In code view, the code navigator button can not be selected. In Live Code view very time I click in the page, Code Navigator opens.

       

      How can I reset Code Navigator back to it's original function?

       

      Thanks in advance for your help

        • 1. Re: Code navigator stuck on
          Piet Nutbey Level 1

          Hi,

           

          The same problem here.

           

          Removed Configuration files, not helping, moved preferences, not helping.

           

          Completely uninstalling and removing related Adobe files and re-installing helps, but the problem returns after a while.

           

          Mac OS X 10.6.5

           

          Hopefully someone has an answer to this pesky problem as coding in Dreamweaver becomes near to impossible this way when the Code Navigator keeps popping up.

          • 2. Re: Code navigator stuck on
            Rocco Charamella Level 1

            Have you contacted Adobe Support about the problem?

             

            I can't as it's in a classroom that I teach in and I don't have the credentials needed to contact support.

            • 3. Re: Code navigator stuck on
              Rocco Charamella Level 1

              I logged in as a different user on my system and started Dreamweaver. The Code Navigator worked fine as this other user. I then logged in as myself and copied the Other User > Library > Application Support > Adobe > Dreamweaver CS5 folder to my Library, same location. It worked, Code Navigator function as it should.

               

              Maybe deleting the ~user > Library > Application Support > Adobe > Dreamweaver CS5 and restarting Dreamweaver so that folder gets recreated would fix the problem too.

               

              Hope this helps someone else who is having this anoying problem.

              • 4. Re: Code navigator stuck on
                Rocco Charamella Level 1

                After 4 days working fine, the issue has returned. Anyone have a solution to this pesky problem?

                • 5. Re: Code navigator stuck on
                  tdweb24 Level 1

                  I'm having the same problem. Tow days ago I update lepard to leopard snow, and now I have that problem.

                   

                  I delete the dreamwaver cs4 folder from library, but after some time the problem apear again.

                  • 6. Re: Code navigator stuck on
                    David_Powers Adobe Community Professional (Moderator)

                    If three people, all working on Macs, are experiencing this problem, it sounds as though it might be a bug. I have a Mac, but it's not my main machine, so I haven't experienced this problem.

                     

                    I suggest that all three of you file bug reports through the official bug report form at http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform. Give full details of your configuration (OS version, type of Mac, etc) to help the engineers identify if there's a common factor.

                     

                    Sometimes, updates to operating systems trigger bugs that didn't exist when the program was originally released.

                    • 7. Re: Code navigator stuck on
                      Rocco Charamella Level 1

                      Thanks David. I've submitted a bug report. I hope others will do the same.

                      • 8. Re: Code navigator stuck on
                        @ndy24 Level 1

                        Make that a fourth person David! Having exactly the same problem here again on Mac, and just about to file a bug report. It seems you might be right David about the OS update, as having not updated for a few weeks and working on my current website fine, and then updating just a few days ago and now this  - it's almost certain!

                         

                        This is making Dreamweaver coding almost totally unusable and with a client expecting a completed website in a matter of days, it's seriously not what I could be doing with right now! Come on Adobe! Get it sorted!!!! Quick

                         

                        Whilst I'm on, can anyone recommend any temporary fixes for the moment? I'm not sure, but is there a way of downgrading the Mac OS X latest update to a previous release?

                         

                        Thanks,

                         

                        Andrew

                        • 9. Re: Code navigator stuck on
                          Piet Nutbey Level 1

                          It turns out Photoshop was "hit" by the Snow Leopard 10.6.5 OS Update bug as well. The solution there is to turn off assistive devices in the Universal Access System Preferences.

                           

                          You may want to try the same for Dreamweaver weirdness.

                           

                          Universal Access1.png

                          Let me know if it works for you.

                          • 10. Re: Code navigator stuck on
                            @ndy24 Level 1

                            Fixed guys!! Quick browse over to the specific support section of Adobe.com for Dreamweaver and a highlighted 'important' update is available 'especially applying to Mac OS X Users'. I've downloaded this, rebooted and there we have it!! All sorted, with no Code navigator stuck!! Based on previous reports in this thread though I'm just wondering how long it will last!

                             

                            If it does return back to this problem I'll definitely try out your method Piet, it seems to make sense actually as to why maybe it started in the first place - as as well as downloading a new update for OS X, I was fiddling about strangely enough with my accessibility settings (Universal Access) the other day to check VoiceOver on the Mac could correctly read my webpages in order to cater for the elderly! Maybe I accidentally changed a setting or triggered an awaiting bug?

                             

                            Thanks again,

                             

                            I'll report back if things go wrong again - but anyone having the same issue head on over to the support page http://www.adobe.com/support/dreamweaver/, and click the relevant link - you can't miss it.

                             

                            Andrew

                            • 11. Re: Code navigator stuck on
                              janericster Level 1

                              OMG!  I have been wrestling with this bug for over a week and it was driving me insane clicking the OK button every 5 seconds!

                               

                              The updater fixed mine as well (after a reboot).  Keeping my fingers crossed that it doesn't resurface again.

                               

                              My only question at this point is that I have been good at keeping all my CS5 apps up to date by running the updater whenever it pops up. This 11.0.3 updater is dated over 3 months ago (8/31/10) so why wasn't it automatically included in any of the recent updater alerts?

                               

                              In any case, thanks again @ndy!

                              • 12. Re: Code navigator stuck on
                                Piet Nutbey Level 1

                                The Dreamweaver updater is not the full proof solution.

                                (Which makes sense to me, because the DW updater is 3 months old - and is older than the Snow Leopard 10.6.5 update - so in no way can this DW updater fix an issue that was caused by a later OS update)

                                 

                                In short... the bug returned. I had also turned on my Universal Access + assistive devices again (IMO the culprit after the 10.6.5 update).

                                 

                                IMHO it is the 10.6.5 Snow Leopard update and a bug in the Universal Access System Pref and the assitive devices.

                                 

                                Turn it off as shown in my previous post works for me.

                                • 13. Re: Code navigator stuck on
                                  MacUser78 Level 1

                                  I'm new here and wasn't sure if I need to start a new thread, but I have the same problem (Mac) except I'm using CS4. However, this update is only for CS5. Any suggestions? (besides upgrading to CS5...) Thanks!

                                   

                                   

                                  UPDATE:

                                  Nevermind....noob here....Just did a simple restart of my mac and everything works in Dreamweaver, no annoying code navigator. Sorry for the inconvenience!

                                  • 14. Re: Code navigator stuck on
                                    Rocco Charamella Level 1

                                    It seems that, at least on my system, the code navigator error pops up at random times even after implementing the solutions offered here. What I have discovered is that a system reboot does seem to clear up the problem. It's a hassle, but it does seem to work. Come on Adobe, give us a solution to this problem.

                                    • 15. Re: Code navigator stuck on
                                      Piet Nutbey Level 1

                                      My experience is now, Universal Access and assitive devices is not a 100% fix.

                                       

                                      I do use "Things" http://culturedcode.com/things/

                                       

                                      That has some shortcut key combos: - control-alt-space

                                       

                                      It appears to me, that often triggers Dreamweaver to go wonkers with the code navigator.

                                       

                                      try to trace your shortcut key combos and find out if your code navigator starts going crazy after certain combos

                                       

                                      ----

                                       

                                      100% confirmed, it is that keyboard shortcut for me in combination with a recent Snow Leopard 10.6.5 upgrade.

                                      • 16. Re: Code navigator stuck on
                                        Rocco Charamella Level 1

                                        I use Things as well. Thanks for the heads up. I never use Code Navigator, I wish I could just turn the bloody thing off.

                                        • 17. Re: Code navigator stuck on
                                          MacUser78 Level 1

                                          Thanks Piet! That was it on my end also. Things has the "Show and autofill" keyboard shortcut in the preferences, and mine was set to "ctrl-alt-cmd-space." This combo affects the Code navigator in DW and also makes Photoshop act goofy as well.

                                           

                                          UPDATE

                                          It seems that using ANY "show and autofill" shortcut in Things is the cuplrit.

                                          • 18. Re: Code navigator stuck on
                                            vanguardiamm Level 1

                                            Seems to me like you hit the nail on the head! I am a things user and have just tested your trigger. Indeed that is what is causing the problem. Have filed a bug report as well.

                                             

                                            Fingers crossed for a relatively quick solution. Turning off code navigator would be good, don't use it anyway!

                                             

                                            At least I now know what to avoid!

                                             

                                            Cheers,

                                             

                                            Marc

                                            • 19. Re: Code navigator stuck on
                                              Rocco Charamella Level 1

                                              I reversed my Things keyboard shortcuts as I mostly use "Show and Autofill" keyboard shortcut and that's the one that seems to cause a problem. No Code Navigator problem so far. Keeping my fingers crossed.

                                              • 20. Re: Code navigator stuck on
                                                vanguardiamm Level 1

                                                Cracking idea! Will give it a go.

                                                 

                                                Thanks

                                                 

                                                Marc

                                                • 21. Re: Code navigator stuck on
                                                  @ndy24 Level 1

                                                  Amazing, I use Things also! After that update and a reboot or two the bug seems to be keeping itself away from my system and Dreamweaver at the minute, with no noticeable effect on Photoshop - but if this bug returns which no doubt it will at some point I'll most definitely get Universal Access changed as suggested, and change them keyboard shortcut commands in Things!

                                                   

                                                  Surely an official fix from Adobe is needed soon!?

                                                   

                                                  @ndy

                                                  • 22. Re: Code navigator stuck on
                                                    David_Powers Adobe Community Professional (Moderator)

                                                    @ndy24 wrote:

                                                     

                                                    Surely an official fix from Adobe is needed soon!?

                                                    This sounds like a conflict between two programs, rather than a bug. However, to bring the issue to Adobe's attention, you need to file a formal bug report through the form at http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform. When there are conflicts between programs, software vendors frequently cooperate with each other to resolve the issue, but Adobe is unlikely to take any action unless it knows about it. Even if you have filed an earlier report, now that you have identified what you believe to be the cause, you should follow up with the details.

                                                    • 23. Re: Code navigator stuck on
                                                      janericster Level 1

                                                      I agree about the conflict -- and I logged it on Adobe's bug page as well.

                                                       

                                                      However, I do not have Things loaded on my iMac, so it can't be Things alone causing this problem. But I do agree with others that some type of keyboard mapping (whether it is from Things or another app) maybe be a cause.

                                                       

                                                      Hopefully everyone else on this forum thread has posted the issue on Adobe's bug report page and maybe an Adobe developer can look into this further.

                                                      • 24. Re: Code navigator stuck on
                                                        Piet Nutbey Level 1

                                                        Hi,

                                                         

                                                        Just a little addition.

                                                         

                                                        Adobe is very well aware of the problem. Not only Dreamweaver is affected, also Photoshop.

                                                         

                                                        The official page: http://kb2.adobe.com/cps/881/cpsid_88159.html

                                                         

                                                        Let's hope for a solution soon.. In the meantime... it's simple.. don't use your keyboard!!!

                                                        • 25. Re: Code navigator stuck on
                                                          Jeremy Helm Level 1

                                                          needless to say I've just found & am posting on this thread because - all of a sudden - I'm suffering from this as well.  And i mean suffering.

                                                          • 26. Re: Code navigator stuck on
                                                            tdweb24 Level 1

                                                            I have things (task manager) instaled on my mac. And since I stop using the short key to open a new task this problem  on dreamwaver desapear

                                                            • 27. Re: Code navigator stuck on
                                                              Jeremy Helm Level 1

                                                              I'm please to report back that later that evening i rolled back the contents of my Library/Application Support/Adobe/Dreamweaver CS5 folder via time machine and all has been well since…

                                                              or course it would have been best not to have happened in the first place

                                                              • 28. Re: Code navigator stuck on
                                                                Sahli Goumri Level 1

                                                                - issue was solved, because the issue was being caused by 3rd party software

                                                                 

                                                                -  Application : Things Cultered Code

                                                                 

                                                                - Error : "There is no destination for Code Navigator to show for the selection"

                                                                 

                                                                The error was caused by using a shortkey '' which i forgot to note down'' I am sorry for that.

                                                                 

                                                                 

                                                                Hope this can help you.

                                                                • 29. Re: Code navigator stuck on
                                                                  thedge1 Level 1

                                                                  Wow, it is great to finally find a thread on this issue I have been struggling with for months!  Thank You!

                                                                   

                                                                  I am a little confused by the solution though at this point.  Right now for me it seems adding a new Things task creates the problem in DW CS5 with the code navigator.  I then have to reboot to get it to go away.

                                                                   

                                                                  So is the solution to quit using Things shortcuts?  Certain shortcuts?  Things all together?

                                                                   

                                                                  Also, has Things and Adobe been contacted and working on a solution at this point?

                                                                   

                                                                  On a side note, if Things doesn't come up with a cloud solution I might be looking for a new task manager anyways.  This issue just pushes me further in that direction.

                                                                   

                                                                  Thanks again for the topic and folks posting their experiences!

                                                                   

                                                                   

                                                                  EDIT:  I did file a bug report with Adobe as suggested and received a timely response - "You need to open the Code Navigator to disable it. Click on the icon, then a window will display with a "disable" checkbox."  Unfortunately when I check this box, when the bug occurs, it doesn't go away. 

                                                                  • 30. Re: Code navigator stuck on
                                                                    Fantastic Fish Level 1

                                                                    Worked for me, Piet! Thanks!


                                                                    • 31. Re: Code navigator stuck on
                                                                      endymion1818 Level 1

                                                                      Hey, just developed same problem running Dreamweaver CS5 in Mac OS 10.6.6.

                                                                       

                                                                      It may have occurred after I used "Air Mouse Server" to use my iPhone as a trackpad... this is only an idea, however the problem developed at the same time I used it.

                                                                       

                                                                      It's very annoying, isn't it?

                                                                      • 32. Re: Code navigator stuck on
                                                                        standers Level 1

                                                                        OK, I just started using DWCS5 on two PCs.  One has the problem and one does not (so far).  I do not use Things (don't even know what that is).  On the other PC I find code navigator to be quite useful but I can't even access it on the 2nd PC.  So, I'm a bit frustrated as the problem keeps happening on the second PC and I can't use the Mac fix.