7 Replies Latest reply on Apr 24, 2012 3:14 AM by BKBK

    Installing Coldfusion 9 and Apache 2.2 on Windows Server 2008 R2 Standard


      I'm having issues getting ColdFusion 9 working with Apache 2.2 on Windows Server 2008 R2 Standard.


      The server is brand new and it's a fresh install of Apache and ColdFusion 9.


      Having installed Apache, I tested the web server and it was working fine, so I proceeded to install ColdFusion 9. I attempted to restart the Apache server through the Apache Service monitor, only to get the error dialog box 'The requested operation has failed'.


      On closer examination of the Windows error log, I saw the following error:


      The Apache service named  reported the following error: >>>
      httpd.exe: Syntax error on line 488 of C:/Program Files (x86)/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/ColdFusion9/runtime/lib/wsconfig/1/mod_jrun22.so into server: The Apache service named is not a valid Win32 application.


      I updated the ColdFusion installation to 9.0.1 in case there was an issue with version 9.0 and Apache. Still no joy.


      After a bit of research, I thought perhaps there was an issue with the mod_jrun22.so file (since when I commented out the reference to that file from the Apache config file, the Apache HTTP server started without any problem). I tried replacing the mod_jrun22.so with the 32 bit version (extracted from the wsconfig.jar file), but that made no difference either.


      I have tried a number of things. I have run wsconfig and uninstalled all web server connectors and then re-created them.


      I have to use Apache and IIS is not an option (I use rewrite rules extensively in an existing live installation and have many sites set up in a vhosts file), so please - no suggestions to use IIS instead.


      The system requirements on http://www.adobe.com/sea/products/coldfusion/systemreqs/ state that Coldfusion 9 will work with Apache 2.2.17 and later on Windows 64 bit, so why am I having issues with a brand-new installation on a 'virgin' server?


      Any help would be much appreciated. I have spent hours trawling the Web for solutions.