4 Replies Latest reply on Feb 24, 2011 9:35 AM by suhettak12

    Trace() not working?

    suhettak12

      Hello there.

      I've been searching around on google for the better of 8 hours now, without finding an answer.

      I'm sorry if it's been answered, but it seems I couldn't find it.

       

      So, my problem:

      After having played around with AIR for about a week or so without problem, I am suddenly unable to trace() things - I'm using external as (that is, *.as files). The application works fine (doing what it should do), but it's not tracing anything.


      The "Omit trace" box is not ticked, and I don't have the debug player installed, so a mm.cfg file wouldn't do much (I also tried making the mm.cfg, and this traced to a logfile) - I want it to "live-trace", and not have to look at a log file every time I test my application.

       

      It was working, but suddenly stopped working - from one test to the other. I tried opening some of my backups, but still nothing.

      I've even tried making a new .fla with an accompanying .as file, with trace("Working") as the only thing written in the constructor, and the movie loads fine, but it doesn't trace anything.

      Then I tried making a new .fla with internal actionscript, and again, it doesn't trace.

       

      This problem doesn't occur if I, under Publish Settings, use Flash Player 10 as the "player". But as I'm using some AIR-only things, I have to use Adobe Air 2.

       

      Thanks in advance.

       

      Edit:

      Some more information (and tl:dr):

      Application/Movie is working, but trace is not();

      Wishing to "livetrace" (having flash IDE trace), and not be forced to log to a file.

      Using Adobe Flash Pro CS5, don't wish to change.

      Not using Flex

      Windows 7 32Bit

      Latest Adobe AIR SDK (from get.adobe...)

      Not using cmd to compile, using Flash IDE.

      Don't want to use third party program to trace, I know the Flash IDE is capable of tracing.

      Have tried both Ctrl+Enter as well as Ctrl+Shift+Enter (Although the debug mode, when closing the app, tells me that "Debugger launch failed")

      Output Filter level set to Verbose.

        • 1. Re: Trace() not working?
          neh@adobe Level 3

          Hi,

           

          You could try 2 things for the same:

           

          1) Goto the Task Manager and kill the process idl.exe and try debugging your application again.

          2) Also, you may try downloading the latest FP content debugger from:

          http://www.adobe.com/support/flashplayer/downloads.html

           

          Hope this helps!

           

          -Neha

          1 person found this helpful
          • 2. Re: Trace() not working?
            suhettak12 Level 1

            Hi, and thanks for taking the time to reply.

             

            I don't see an idl.exe process in my taskmanager, even when I show processes from all users.

            The FP debuggers don't seem to work either, at least it's still not tracing - and then either gives me a "Class could not be found"-error, whenever my application uses AIR-only components (such as File).

             

            If I use the ADL (from commandline) it traces fine (and did so before as well), but I'd like this information to come from the Flash IDE as it does when running non-AIR applications (so I don't have to "compile" from Flash IDE, and then debug, and then go back and forth - it disrupts the workflow).

            • 3. Re: Trace() not working?
              chris.campbell Adobe Employee

              Hi,

              It sounds like something is blocking ADL from communicating with the Flash CS5 debugger.  Could you try a few things?

               

              • Turn off any firewall you have running
              • Open up a command prompt and see if you can ping 127.0.0.1, maybe something is causing issues talking with localhost?
              • Download and install Microsoft's TCPView (or use netstat from the command line) and see if you find Adobe Flash and ADL listed when attempting to debug.  The Flash debugger listens on port 7935.
              • If nothing appears incorrect with networking, it might be worth while to reset your Flash CS5 preferences.
              • Finally, you might also want to post this issue over on the Flash forums to see if any of the experts over there have any advice.

               

              Thanks,

              Chris

              1 person found this helpful
              • 4. Re: Trace() not working?
                suhettak12 Level 1

                Hi Chris,

                 

                I tried pinging 127.0.0.1, with reply.

                And then I read "issues talking with localhost", which lead me to ping "localhost"... And my request timed out.

                So I looked in my hosts file and found that my localhost was assigned to 0.0.0.0 (no idea why), so I edited it to 127.0.0.1, saved and closed the file, and restarted the IDE.

                And then it worked.

                 

                Thanks a lot for helping!