7 Replies Latest reply on Apr 22, 2015 5:19 AM by yavstr

    Flash Builder 4.0.1 with SDK 4.5?

    hidarikani Level 2

      Is this possible?

      How do I do this?

        • 1. Re: Flash Builder 4.0.1 with SDK 4.5?
          cynicaljoy

          You should be able to without issue, find the 'Installed Flex SDKs' settings in the Preferences window and add the 4.5 SDK there. After adding your new SDK either check the box next to 4.5 to make it the default or to change it per project you need to go to the project settings and change the 'ActionScript Compiler' settings to 'Use a specific SDK' and select the new SDK.

          • 2. Re: Flash Builder 4.0.1 with SDK 4.5?
            2lazy

            Hi,

             

            I also recently tried switching from SDK 4.1 to 4.5, the issue I have is when running the debugger it prompts an error saying "Required Adobe Flash Player version not installed" .  Is there a way to set the path to the FlashPlayerDebugger.exe in FlashBuilder? Or are we forced to run the installer each time we want to debug against a specific version?

            • 3. Re: Flash Builder 4.0.1 with SDK 4.5?
              Webmaster1379

              Okay guys i'm sorry but is there a free upgrade to Flash Builder. My Flash Builder says version 4.0.1 (build 277662) Is there a way to upgrade this without a cost to me?

               

              I just purchased the Master Collection and shortly after they released 4.0.1.

              • 4. Re: Flash Builder 4.0.1 with SDK 4.5?
                Level 2

                fb4.5 should come along with master collection 5.5 call sales.

                • 5. Re: Flash Builder 4.0.1 with SDK 4.5?
                  yavstr Level 1

                  I'm having issues using 4.5 in FB 4.0

                   

                  Every time I create a new project and target 4.5 I get the following errors:

                   

                   

                  DescriptionResourcePathLocationType
                  1084: Syntax error: expecting rightbrace before csstesting
                  Line 24Flex Problem
                  1084: Syntax error: expecting rightbrace before end of programtesting
                  Line 447Flex Problem
                  1084: Syntax error: expecting rightbrace before stesting
                  Line 24Flex Problem
                  1093: Syntax error.testing
                  Line 24Flex Problem
                  1093: Syntax error: A string literal must be terminated before the line breaktesting
                  Line 24

                  Flex Problem

                   

                  keep in mind the is a new project targeting the 4.5 SDK in Flash Builder 4.0. I have done nothing but create the project.

                  If I create the project with 4.1 SDK in Flash Builder 4.0, there are no issues.

                   

                  Can someone confirm this is an issue with using 4.5 in FB 4.0 or share a solution to resolving the issues?

                   

                  Thank you.

                  • 6. Re: Flash Builder 4.0.1 with SDK 4.5?
                    sid985

                    Hi,

                     

                    I know this is after a long time...but can anyone confirm if we can use the 4.5 SDK or 4.5.1 SDK with Flash Builder 4 ? without any problems ?

                     

                    Will the Flash Builder 4.0.1 update help ? Or if there 'is' some problem with using FB4 with SDK 4.5 then is there some kind of update patch for this ?

                     

                    Thanks

                    • 7. Re: Flash Builder 4.0.1 with SDK 4.5?
                      yavstr Level 1

                      I actually switched to IntelliJ and haven't looked back.