11 Replies Latest reply on May 18, 2011 9:15 AM by waniwani2

    Compiling/Debugging AIR App. on Samsung Galaxy Tab


      Hey guys,


      I'm currently testing/making a mobile app with Burrito/Hero SDK.  I am successfully compiling and debugging on my Droid 2 - there are certain settings on the phone that allows USB Debugging mode and also allows "unknown sources" (non-market applications) to be installed.


      I want to be able to run/install the application on a Samsung Galaxy Tab - I want to see how it looks on a bigger resolution.  I am not able to turn on USB debugging on this device, therefore, cannot debug or install on the device.


      Has anybody tried this?  Or does anybody know how to root the install so I can test my application?


      Thanks! Cheers!


        • 1. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab



          I tried this, but no good results either.


          When I did a number of google searches I came into conclusion that there's no Galaxy Tab drivers yet bundled with the Burrito. Then I tried to google the tab drivers for MacOS but couldn't find them either. So I guess that's the basic reason that Burrito team chose include just a subset of devices for the beta - or then Samsung has been postponing the mac driver implementation?


          I assume you could tweak even FB4 to build to Android if you manually edit settings and configs and hunt the drivers and deploy AndroidSDK. But didn't want to go there...


          I hope to have the galaxytab working asap since from my point of view that's the most interesting target environment (at the moment) because of the larger touch screen size and presumeably better CPU.



          PS. Has Adobe guesstimated about FB4.5 release date yet?



          • 2. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
            Dan Zen Level 1

            I am trying on a Galaxy Tab too and no luck yet.


            Adobe said to update the adroid_winusb.inf file in the burrito install folder / utilities/drivers/android and I did to:



            ; Samsung Galaxy Tab
            %CompositeAdbInterface%     = USB_Install, USB\VID_04E8&PID_681C&REV_0400
            ; Samsung Galaxy Tab
            %CompositeAdbInterface%     = USB_Install, USB\VID_04E8&PID_681C


            Which came from the failed Device install Properties > Properties > Details > Hardware Ids.


            But then they direct us to a /drivers folder in the android folder and I do not have a drivers folder.  I have an i386 and in there are three dll files but I can't seem to install them.  So... no luck.


            Anyone know what to do?





            • 3. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
              Sedat Akkus Adobe Employee

              Hi Dan,


              Have you tried to browse into the android folder that has the android_winusb.inf file during driver installation? Windows Driver Manager should find the driver there if you added the Hardware id correctly in the .inf file.


              PS: Drivers are not needed for Mac OSX.



              • 4. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                Dan Zen Level 1

                Part way there!   I had tried pointing to that directory before.  The problem was my original edit did not get saved for some reason.  Maybe I missed the confirm step for the administrator when saving. So now the install worked and the SAMSUNG_Android appears as a device.


                But.. even with restarts, etc. when I go to my Android SDK tools directory and run adb devices it does not show up.  There is a blank list of devices attached.  I have been successful in getting the ViewSonic going this way - but the ViewSonic has the old version the AIR Runtime and my Burrito App only seems to work with the version currently available on the Android Market. The ViewSonic does not let me find that due to the stock operating system.


                Anyway - back on the Galaxy Tab device under Applications > Development the USB Debugging is checked on (it is also greyed out so I can' uncheck it).  When I check my little pulldown status it says USB connected.


                Any advice?




                • 5. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                  Dan Zen Level 1

                  I forgot - I should now be able to connect to the Galaxy Tab through Burrito.  Unfortunately, I still can't seem to connect.  I followed the instructions at:


                  http://help.adobe.com/en_US/flex/preview_release/mobileapps/WSa8161994b114d624-33657d5912b 7ab2d73b-7fdf.html


                  but I do not see USB Debugging as an entry in the Pull Down Notification on the Galaxy Tab.  I see USB Connected.  If I double tap this it shows that my USB Storage is not turned on.  I turned it on and off just to make sure.  My Application > Development > USB Debugging is checked.  As mentioned, it is also greyed out so I can't uncheck it if I wanted to. The Android Composite ADB Interface device is working properly in the Windows Devices.


                  Thanks in advance for any ideas.

                  • 6. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                    Sedat Akkus Adobe Employee

                    When you tap on USB Connected, do you see "Charge Only Mode" as an option? If yes, please select that option and turn off the mass storage as well and try again.


                    Please let me know how it goes.



                    • 7. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                      Dan Zen Level 1

                      Hi Seddat,


                      On the Tablet, when I pull the USB Connected message down from the top and tap on it I do not see a charge mode only option. I only see a message saying I am connected and then a button that says Mount.  And I have not pressed that. (although I have tried pressing it and then turning it off a few tries ago.)


                      The Samsung Galaxy Tab is running 2.2.


                      In my Windows Device Manager I see Android Phone > Android Composite ADB Interface show up.  It goes away if I unplug the USB and shows up again when I plug it back in.  I do not see a drive or anything under my Computer though.


                      When I Run in Burrito and specify "Google Android" and "On device" then it waits a while and a Choose Device box comes up with no devices in it.  I refresh and still no devices.  I clicked the help link and I think I have done all that is says to do.





                      • 8. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab

                        Hi Dan,


                        I'm having the exact same problem as you.


                        Were you able to get it resolved and hook the Galaxy Tab up for debugging?  I don't get the USB Debugging Mode to show up on the device either, and I can't use it in Flash Builder even though I'm able to use my Droid Pro.


                        One thing I did notice is that the Hardware ID for the Galaxy Tab when I plug it in does not have &MI_01 like all the other devices.




                        • 9. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                          Dan Zen Level 1

                          Not yet Amit - I am still hopeful an idea or answer will come.

                          • 10. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                            BrijeshP Level 1

                            If you are using Samsung Mobile/Tabs, then you will have to install “Samsung USB drivers for Mobile phones”   (Ref: http://forum.xda-developers.com/showthread.php?t=728929)


                            For windows, after installing the drivers, connect the device and update its driver (from Update Driver Wizard or from Device Manager) with the drivers you just installed.

                            • 11. Re: Compiling/Debugging AIR App. on Samsung Galaxy Tab
                              waniwani2 Level 1


                              These worked for me - thanks!  For reference, on Windows, I had to uninstall the existing drivers and make sure to delete them and restart before installing.


                              Also, even when in Debugging Mode, by default, the tab doesn't seem to show me the little bug-guy in the notifications bar - perhaps that has to be set separately.