3 Replies Latest reply: Mar 12, 2012 2:02 AM by davy zhang RSS

    Errors Compiling - OSX Lion

    Nate Burr Community Member

      Has anyone had success running alchemy under lion?

       

      when i execute gcc in alchemy/achacks/ i get the following error.

       

      Array @ARGV missing the @ in argument 1 of shift() at /Library/alchemy/achacks/gcc line 218.

        • 1. Re: Errors Compiling - OSX Lion
          Dario Pelella

          Hi Nate,

           

          I had the same problem .

          I'm a relative young mac user... and an absolutely lion nooob

          but googling around i found this solution:

           

          open the file  /Library/alchemy/achacks/gcc with a text editor

          go to the line 218  and add the '@' near the ARGV like this:

            { $path = shift(@ARGV) }

           

          i think it's only a warning message, nothing more.

           

          after that i had also another problem:

           

          dyld: Library not loaded: /usr/lib/libltdl.3.dylib

            Referenced from: /Users/pellicus/Tools/alchemy_osx/bin/llvm-g++

            Reason: image not found

           

           

          In fact I installed the xcode lion version that do not install the library libltdl.3.dylib ...

          ... at least that's what I understand reading here and there ...

           

          then.. i have not found any solution about installing the old lib ver 3... but I see that I have the libltdl.7.dylib..

          so... armed with courage I tried this:

          cd /usr/lib/

          sudo ln -s libltdl.7.dylib libltdl.3.dylib

           

          ... and it works like a charm ...

           

           

           

          I hope this helps,

           

          Dario

          • 2. Re: Errors Compiling - OSX Lion
            Nate Burr Community Member

            That solution worked great. Thanks!

            • 3. Re: Errors Compiling - OSX Lion
              davy zhang Community Member

              thanks so much !!! save me a lot of time!