10 Replies Latest reply on Sep 20, 2011 10:30 AM by Chris Cox

    Trouble editing smart objects


      If I paste a vector element from illustrator into PS as a smart object, and then wish to edit that content later, the smart object is opened in Preview rather than illustrator. Is there some way to specify the editor or just force it to open in Illustrator?



        • 1. Re: Trouble editing smart objects
          Paul Cutler Level 1

          It's probably due to preferences in Illustrator. Make sure (in CS4) that under Preferences-File Handling and Clipboard that COPY AS PDF is checked and also AICB is checked - might as well check Preserve Appearance and Overprints as well.


          These won't take effect until you quit and restart Illustrator.


          I hope that is the solution.


          Best of Luck!



          • 2. Re: Trouble editing smart objects
            Level 7

            There was also a problem with MacOS 10.6 that caused files to open in the wrong applications.

            (someone at Apple thought it was a "feature" to ignore the file creator codes)


            Apple tried to fix that in 10.6.2, but I haven't had time to test that one myself.



            • 3. Re: Trouble editing smart objects

              I had the same problem... but I did some tests and seems like the problem was not with my computer or preferences....

              Seems to be the problem is getting files from a Leopard mac to a Snow Leopard Mac.


              We have an I mac and the new mac pro both running CS4.


              From the Imac (running 10.5.8)  file was sent to my Mac pro (running 10.6.2) via Bonjour... Opened the file in PS and clicked on the smart object and it opens in Preview.


              But when I click on the smart object on the Imac it works fine and opens AI.


              When I create a vector from my Mac Pro (running 10.6.2) paste the file in PS then click on the smart object it opens AI.



              So it seems like there is a problem with file transfers form 10.5.8 to 10.6.2.  Not sure if there is a problem if the PS file came form a PC. If anyone has access to a PC with CS4 and a mac running 10.6.2.  Be nice to see if there is a similar problem.



              • 4. Re: Trouble editing smart objects
                n.puertollano Level 1

                OK maybe there is no issues with the transferring of files form 10.5.8 to 10.6.2.


                After doing some test I decided to re-boot my mac running 10.6.2. and for some reason it fixed the problem.


                But the older files before I re-booted still have the problem but only with certain layers other layers open in AI.



                Murphy's Law...

                • 5. Re: Trouble editing smart objects



                  Recently upgraded to Mac OS X 10.6.8 and Photoshop CS5.1. What is this new obsession with Preview? I've gotten over the fact that double clicking an Illustrator EPS in Quark > Edit Original, no longer opens it in Illustrator but Preview - nigh on useless for editing. But now my vector smart objects in Photoshop are also opening in Preview as well.


                  Is there some setting or box I need to tick somewhere to stop Preview hogging my vector artwork. I realise I can change settings so that ALL EPSs open in Illustrator but that's not workable for me as we use a lot of rasterized Photoshop EPSs too and this 'all or nothing' solution doesn't discriminate between the two. This is probably more of a Mac OS problem than an Adobe one, but any advice would be greatly appreciated. Upgrading seems to have made my work flow dissappointingly LESS efficient.


                  Is there a new way to get a vector smart object to open or even export or something to Illustrator? I've a logo currently trapped in a PSD and it needs to get to Illustrator.





                  • 6. Re: Trouble editing smart objects
                    MTSTUNER Level 6

                    If you open the file into photoshop with the vector smart object layer active, go to

                    Layer>Smart Obects>Export Contents. At least that will get you the vector file

                    that you can manually open in illustrator.




                    • 7. Re: Trouble editing smart objects
                      Vaunnie Level 1

                      Thanks MTSTUNNER for getting back so quickly.


                      I must be doing something wrong because all I'm getting is a blank file.


                      Original smart object was an Illustrator EPS not AI would this make a difference?

                      • 8. Re: Trouble editing smart objects
                        Vaunnie Level 1

                        Hi MTSTUNER,


                        Ooops my bad! I posted too soon. Quit Photoshop and opened again and it worked a charm. Thanks so much for your help. Vector EPS at liberty once more.

                        • 9. Re: Trouble editing smart objects

                          Thanks for this. Although the question appears not to be answered, it is still the most useful thread I've found. This morning I wanted to edit a smart object within an image originally created in CS4. I'm now using CS5.5 on a Snow Leopard imac. Trouble is, I recently acquired Strata 3D, the cheapo version, off the App store. So now I have the problem that the edit Smart Object button opens Srata and not the original creator, Illustrator. Worse than that, it doesn't even open the image, it just goes to the introductory options screen.


                          Now just in the process of quitting and restarting as advised above to see if that makes a difference. Apart from uninstalling Strata, I don't know what else to do. Any help appreciated.



                          • 10. Re: Trouble editing smart objects
                            Level 7

                            Sounds like Strata hijacked the system preference for opening Illustrator artwork files.

                            Photoshop tries to be very specific about the file type and creator that should open the file, but MacOS has recently gotten sloppy in the way it handles file owners.