21 Replies Latest reply on Dec 17, 2014 12:31 PM by turbidwater


    nurba Level 1

      Hi All,


      I am recording live stream on a server side (using FMIS 3.5.3)

      while recording video I am getting NetStream.Record.NoAccess message and recording stops

      I checked recorded video length, it is always different,

      sometimes only 2 minites, sometimes 10 minutes, sometimes 20 minutes


      Anyone faced this problem?

      Will be glad if you can help me to solve this




        • 1. Re: NetStream.Record.NoAccess
          AbhishekSinha Level 3

          This status message generally indicates that you don't have write permissions to the stream. Check the permissions of your streams dir to see if it is read only.


          If that is not the issue, check which application are you trying to publish to, does not SSAS that has code to deny write access to stream



          • 2. Re: NetStream.Record.NoAccess
            nurba Level 1

            It is recording 10-20 minutes sometimes, sometimes 2 minutes only,

            If that folder doesnt have write permission, it should not record video


            my problem is recording stops after a few minutes later

            • 3. Re: NetStream.Record.NoAccess
              AbhishekSinha Level 3

              Oh Sorry,


              I think I did not get your questions clearly the first time. What format are you publishing and recording in? Also have you checked FMS logs to see if there is something that indicates such action




              • 4. Re: NetStream.Record.NoAccess
                nurba Level 1

                I tried publishing as h264 and sorenson codec, recording as f4v


                live stream is working fine, I can watch the live stream,

                but only recording stops after a few minutes later,

                in the logs I am getting NetStream.Record.NoAccess error and says recording stopped

                • 5. Re: NetStream.Record.NoAccess
                  Robert Mc Dowell Level 3

                  I have almost the same problem, unless I really can't record with FMIS or FMDS.

                  it says NetStream.Record.NoAccess instantly.

                  all permissions of my linux box are ok (nobody.nobody) no SSAS code that unauthorize write access.

                  but, on this subject, is there any example of SSAS code script on this matter ?

                  • 6. Re: NetStream.Record.NoAccess

                    I have a almost problem.


                    fms version:fms3.5.3
                    fms is working on nobody.nobody


                    I check the record directory, is seem no problem.
                    fms src:


                    RECORDING.DIR = vc_live;/var/www/myproject


                    directory permission:
                    [nobody@fmsvm myproject]$ ll
                    drwxrwxrwx 6 webapp 4.0K Sep  5 16:04 upload/
                    [nobody@fmsvm upload]$ ll
                    drwxrwsrwx 3 webapp  12K Sep  8 13:27 recorded/


                    file is exist but filesize always stoped on 21K.
                    [nobody@fmsvm recorded]$ ll fc148c16bf1232058e0bfdd3b7e806ac6deca4b8*
                    -rw-r--r-- 1 webapp   8 Sep  8 14:46 fc148c16bf1232058e0bfdd3b7e806ac6deca4b8.log
                    -rw-rw---- 1 nobody 21K Sep  8 14:46 fc148c16bf1232058e0bfdd3b7e806ac6deca4b8.mp4
                    [nobody@fmsvm recorded]$ ll 1df76f66e882ee5036ea4f5a734ce9c1cae50254*
                    -rw-r--r-- 1 webapp   8 Sep  8 15:23 1df76f66e882ee5036ea4f5a734ce9c1cae50254.log
                    -rw-rw---- 1 nobody 21K Sep  8 15:23 1df76f66e882ee5036ea4f5a734ce9c1cae50254.mp4
                    (webapp is web server user ,recordfile.log is chatlog)

                    • 7. Re: NetStream.Record.NoAccess
                      calmchessplayer Level 3

                      You know I had a person with not quite this problem but a very similar problem. I suggested he chmod -R 777 /whatever/dir  but he didn't listen to me instead he  reinstalled FMS on Linux as root or some other power user depends on your Linux distro but by not useing nobody.nobody he fixed the problem. Please forgive me if the syntax of chmod is incorrect or not secure enough for you I haven't used chmod in months but 777 will give you permissions that you need. I've used it before. out of curiosity what Linux Distro are you guys using? You might also be able to use chown and change the owner of the applications/app directory with success.

                      • 8. Re: NetStream.Record.NoAccess
                        Nikhil Pavan Kalyan Level 4

                        Hi all,


                        Is this problem resolved or is it still hurting you guys ? Please let us know. Thank you

                        • 9. Re: NetStream.Record.NoAccess
                          juwang Level 1

                          thanks for your replay > calmchessplayer


                          I try to

                          1. change record directory to /tmp . problem is still..

                          2. upgrade fms version to fms3.5.5 . problem is still..


                          more information:

                          publish format:h264 mp3

                          linux version:Linux fmsvm.example.com 2.6.32-71.el6.x86_64 #1 SMP Fri May 20 03:51:51 BST 2011 x86_64 x86_64 x86_64 GNU/Linux


                          Please help me > Nikhil Pavan Kalyan

                          • 10. Re: NetStream.Record.NoAccess
                            Nikhil Pavan Kalyan Level 4



                            You previously mentioned that you are seeing a 21kb file being created, is that still correct ?

                            If that's the case, the problem is with the wrong type of content going into the recording and hence the server is not copying the data into the file and just discarding it.


                            Your publish format h264 and mp3 are both supported, but what is the file format you mentioned for recording ? Is it FLV or F4V? You mentioned using mp4: in the ns.play command, but are you using the mp4: in the publish command as well?


                            Please also check your FMS log files to see if there are any errors in recording.

                            • 11. Re: NetStream.Record.NoAccess
                              juwang Level 1

                              thanks for your help


                              I check the FMS core.00.log and get the following message:

                              2011-09-21  11:27:59    726 (e)2611178  Error from libmp4.so:   No Space left in the stsd box.  -
                              2011-09-21  11:27:59    726 (e)2611423  Failed to record vc_live/upload/recorded/ab91a04be0d3669bdf80d645b6413362db69a09f.mp4 (Unknown Error).   -


                              and search the message 'libmp4.so:   No Space left in the stsd box.' .

                              I find the url:http://forums.adobe.com/thread/451911 get some hint.


                              I use FMLE with Auto Adjust option on ,when the error came.

                              I try to turn off Auto Ajust option then error has disappeared.


                              Please excuse my poor English.

                              • 12. Re: NetStream.Record.NoAccess
                                Christofer L



                                I'm experiencing a similar problem, the recoring stops after different durations each time but the files are being written correctly to disk.


                                We are seeing the error messages "Error from libf4f.so: F4V error: 1280" and "NetStream.Record.NoAccess"

                                • 13. Re: NetStream.Record.NoAccess
                                  G-Software Level 1



                                  after some tests maybe it seems to be a too weak buffer problem. but no sure

                                  • 14. Re: NetStream.Record.NoAccess
                                    Christofer L Level 1

                                    Which settings do you suggest we tweak to see if it makes a difference?

                                    • 15. Re: NetStream.Record.NoAccess
                                      G-Software Level 1

                                      buffer depends of the a/v quality you broadcast.

                                      so for example 720p 30fps quality (if you use H.264) requires at least

                                      14000Kb/s, so if you broadcas with a 1mb up bandwidth so it needs at least

                                      14s of bffer...

                                      • 16. Re: NetStream.Record.NoAccess
                                        Christofer L Level 1

                                        This seemed to help at first, I don't see the error messages anymore but the recording still stops after a few minutes.


                                        The setup looks like this: we have our live application which re-streams to a recording application on the same FMS.

                                        Now when the recording stops the recording application receives a NetStream.Play.UnpublishNotify event but there is no indication in the live application that the stream have been unpublished, the stream is still published just fine. During the last test it just stopped without even receiving the event, the only way to see this was the drop in bandwidth usage for the recording application in the FMS Administration Console.


                                        bw usage.png

                                        • 17. Re: NetStream.Record.NoAccess
                                          G-Software Level 1

                                          I solved my "noAccess" problem after a recording by simply a Stream.cleart() t prior to record

                                          first as the live stream is readonly.

                                          • 18. Re: NetStream.Record.NoAccess
                                            Dmitrii Nikolaev

                                            Problem is still exist. I can explain detailed with log file how that happens. Anyone can help us?

                                            • 19. Re: NetStream.Record.NoAccess
                                              vijay.das Adobe Employee

                                              if you are seeing the error related to stsd entries, i posted a reply on this thread Stream records for sometime and then gives Stream.Record.NoAccess

                                              • 20. Re: NetStream.Record.NoAccess
                                                Nicolas Dion-Bouchard

                                                There clearly seems to be a problem with mp4/f4v recording using h264 codec. Can it be a week buffer problem as G-Software mentioned? We have the same problem, publishing live stream with h264 and sorenson and recording the stream on server-side. So the stream is published in "live" mode from the client then the server creates another Stream object and attaches the live stream to it in order to record the new one. We use this strategy because we are not always recording as the client can freely activate/deactivate the recording feature as the meeting goes on. Randomly, we get the same NoAccess message and the record stops. Any idea anyone? I think that's a bug, especially because we don't get any more specific error in the logs...

                                                • 21. Re: NetStream.Record.NoAccess
                                                  turbidwater Level 1

                                                  I seem to be having the same problem, though I am curious if you all see the following symptom as well. When I receive NetStream.Record.NoAccess in the application log, its timecode matches exactly with the following error in the core log:

                                                  2014-12-17 13:03:24 22272 (e)2581279 Assert failed in .\core\FcLiveStream.cpp line 4303 -

                                                  The process ID matches the process ID of the application in the application log.


                                                  Searching on that error only yields a few unanswered questions. We are recording MP4 files in the same way Nicolas describes.


                                                  Does that get anyone closer to an answer?