6 Replies Latest reply on Oct 24, 2012 6:25 AM by defiraid

    flash builder 4.5 launch failed


      I have a project I built using most of the code from the employee directory tutorial and when i made the changes to run it using DAO and the sqllite database it does not launch and sends me a lauch failed error


      Process terminated unexpectedly

      initial content not found


      Any help to get this so I can atleast run it and debug it would be great

        • 1. Re: flash builder 4.5 launch failed
          Anirudh Sasikumar Adobe Employee

          Is Project -> Build automatically turned on? Are the errors in your "Problems" view?


          This happens because the SWF that AIR is looking for is not present. The SWF usually has the same name as main application and is referenced in the appname-app.xml file in bin-debug via the content XML tag.



          • 2. Re: flash builder 4.5 launch failed
            Anirudh Sasikumar Adobe Employee

            Also, is your output folder set to bin-debug? (In Project Properties -> Build Path)



            • 3. Re: flash builder 4.5 launch failed
              ReelMania1 Level 1

              thanks for the help,

              yes there are 2 errors but as I was coding I kept running the application thinking it was proceeding with the errors. from your comment, i assume the following can you tell me if this is correct.


              as i was changing code it wasnt actially rebuilding the swf file because of the errors, and when i would click to proceed it was actually running in the last known good code that was complied in the swf file so even thought I was changing many of the files, it wasnt effecting the way the application ran since it wasnt recompiling the swf file.  This makes sense to me because I was changing data in the xml file it was pulling from and the changes were showing up  in the application, even thought the code was changes and there was no longer a refereance to that xml file. 


              I then ran the clean ulitity under project since it wasnt behaving the was I expected, i assume this wiped out the swf file and then when it tried to recompile the new on it failed because of the errors.


              If this is all correct could you please let me know. I will assume for now i really need to focus on the two errors in my dao code.



              • 5. Re: flash builder 4.5 launch failed

                On a related note that might be the cause of some people's problem:


                I just had a similar problem (how/why I found this post) and I was getting a similar error.  The problem started when I deleted the .swf from the bin-release folder.  I kept getting:

                Process terminated unexpectedly.


                initial content not found


                Launch command details:  "C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\bin\adl.exe" -runtime "C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\sdks\4.6.0\runtimes\air\win" C:\wamp\www\Imaginus.org\projects\xxx\xxx\xxx-app.xml C:\wamp\www\Imaginus.org\projects\xxx\xxx


                (xxx is/was the name of my project)

                I fixed the problem when I was looking at the properties and under "Properties>Builders" there is a checkbox for "Missing Builder (com.powerflasher.fdt.core.FlashBuilder)" that I'm guessing was added when I installed FDT PowerFlasher to play with a few days ago.  I unchecked the box and approved the "This is an advanced operation..." warning.  The compiler reconfigured itself and I tried to launch again.  This time FB DID rebuild the .swf and launched as expected.


                Thought I'd add this comment just in case other people find this thread and just happen to have the same problem.




                • 6. Re: flash builder 4.5 launch failed



                  i've got exactly the same problem but i don't find this checkbox for "missing builder"


                  Thanks for your help