32 Replies Latest reply on Aug 27, 2014 8:36 AM by Stephen D. [Adobe]

    Flash access support on linux (ubuntu)

    Jonas Hagberg



      since the release of ubuntu 11.04 I've been unable to watch DRM-protected videos. Trying the test player at http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html with video

      http://drmtest2.adobe.com:8080/Content/anonymous.f4v the last message displayed is: "Updating CP module...." and then nothing happens.


      I've tried deleting the NativeCache folder and a new libadobecp-xxx.so is downloaded and saved but still no progress.


      I've tested with both the latest 11.1 player and the latest 11.2 beta player on Ubuntu 11.04 and 11.10.


      Any plans on making this work again for newer linux systems since it works fine on ubuntu 10.10?



      Jonas Hagberg

        • 1. Re: Flash access support on linux (ubuntu)
          Eric.H-ONoDaT Adobe Employee

          Hi Jonas,


          Can you tell me the exact version #'s of the Flash Players that aren't working?

          This should actually be 4 decimal sections (i.e.


          You can get this information by going to this page:


          Also, I believe that the release notes for the latest 11.2 prerelease should indicate that FAXS is not currently enabled for that build.






          • 2. Re: Flash access support on linux (ubuntu)
            Jonas Hagberg Level 1



            I have version now.

            • 3. Re: Flash access support on linux (ubuntu)
              Stephen D. [Adobe] Adobe Employee

              Hi Jonas,


              Eric and I looked into this.   We see this behavior too (works on  Ubuntu 10.04, doesn't work on 11.04) with the same build you have.  


              This is an offshoot of bug 2927987.  


              Once the "Hardware Abstraction Layer" (HAL) module is installed (using Synaptic), the video played fine in Ubuntu 11.04 (and probably 11.10).    Thought we had release noted it somewhere, but I can't find the reference at the moment.





              • 4. Re: Flash access support on linux (ubuntu)
                Jonas Hagberg Level 1

                Hi Stephen,


                I just tried this in Ubuntu 11.10 and installing the HAL module doesn't help. Don't have a machine running 11.04 available to test on right now.

                Any other modules needed? I have these installed now: hal, hal-info, libhal-storage1 amd libhal1.


                Jonas Hagberg

                • 5. Re: Flash access support on linux (ubuntu)
                  Stephen D. [Adobe] Adobe Employee

                  Hi Jonas,


                  I used Ubuntu 11.04.   I can test 11.10 but I have to build an instance.     Should be able to do this by tomorrow.


                  All I chose from Synaptic is “hal” -0.5.14.  The protected video immediately played after installation.


                  Were you installing manually from command line (dpkg, etc) or through Synaptic?



                  • 6. Re: Flash access support on linux (ubuntu)
                    Jonas Hagberg Level 1

                    I used command-line (apt-get). hal and hal-info was installed. The others were already installed. I also have version 0.5.14.

                    • 7. Re: Flash access support on linux (ubuntu)
                      Jonas Hagberg Level 1

                      We've tested on both 32 and 64-bit versions of 11.10 after installing HAL. None of them worked unfortunately.

                      • 8. Re: Flash access support on linux (ubuntu)
                        Hiroshi@Adobe Adobe Employee



                        After installing HAL (including hal, libhal1 and etc), SampleVideoPlayer still have exact same behavior that you mentioned in first post? If 'Show DRM Events' window displayed more info please let us know.


                        I've tried same thing on Ubuntu 11.04 (32bit) vmware image. I could watch a video successfully after installing hal.

                        Tested with same version of flash player (



                        -- Hiroshi

                        • 9. Re: Flash access support on linux (ubuntu)
                          Jonas Hagberg Level 1

                          Yes, same behaviour.


                          DRM Events:

                          Starts to get video metadata at Wed Nov

                          23 21:44:56 GMT+0100 2011

                          Error: #3344

                          [MissingAdobeCPModule] dispatched

                          Updating AdobeCP module...


                          The "Downloading the Flash Access library" dialog loads completely and then nothing else happens.


                          I also tested on 11.04 today, also 32bit and it worked like a charm. Too bad it doesn't work as good on 11.10...

                          • 10. Re: Flash access support on linux (ubuntu)
                            Jonas Hagberg Level 1

                            Any news? Have you had time to test this on 11.10 yet?

                            • 11. Re: Flash access support on linux (ubuntu)
                              Jonas Hagberg Level 1

                              Ok, I finally have it working on all versions of Ubuntu (32 and 64bits). Here are my findings for future reference.


                              for 10.04-11.10 32-bit just install flashplugin-installer, hal and libhal1 packages. If flash is already installed you might need to reinstall it after installing hal with "apt-get --reinstall install flashplugin-installer" to make it work.


                              for 10.04-11.04 64-bit follow the instructions for 32-bit


                              for 11.10 64-bit I couldn't get the flashplugin-installer package to work, but installing the adobe-flashplugin package from the partner repo worked.


                              Too bad this was such a hassle to figure out and not mentioned in any release notes...

                              • 12. Re: Flash access support on linux (ubuntu)

                                I am running Ubuntu 32-bit Lucid (10.04 / Kernel Linux 2.6.32-39-generic-pae / GNOME 2.30.2) with Firefox 11.0 (Mozilla/5.0 Gecko/20100101 Firefox/11.0) and Flash I am experiencing the same problem, even with flashplugin-installer, hal & libhal1 installed. After initially running into an issue with Amazon Instant Videos, and troubleshooting the problem via the document http://helpx.adobe.com/x-productkb/multi/flash-player-11-problems-playing.html (including the drmtest2 site mentioned above), I checked the packages installed on my system and found that I had the package adobe-flashplugin ( installed. The aforementioned hal-related packages were already installed. After reading this thread I removed the adobe-flashplugin package and installed the flashplugin-installer ( package and retested. When I received the same error message (#3344), I reinstalled the hal-related packages and the flashplugin-installer package, but still no dice. Perhaps there is a way to manually install the Flash Access library that appears to be downloaded from the drmtest2 site.

                                • 13. Re: Flash access support on linux (ubuntu)
                                  Stephen D. [Adobe] Adobe Employee



                                  Try deleting the <home>/.adobe/ directory entirely, and let the Flash Player plugin re-install the DRM module.  It looks like you have everything right on the system (hal, player, etc) otherwise.



                                  • 14. Re: Flash access support on linux (ubuntu)
                                    mccseanp Level 1

                                    Hello, Stephen. Thanks for the suggestion. Unfortunately, removing the $HOME/.adobe directory did not correct the problem. I even shut down all instances of my browser, removed the directory, restarted & tried the test site again, to no avail. Same results as before.

                                    • 15. Re: Flash access support on linux (ubuntu)
                                      Stephen D. [Adobe] Adobe Employee

                                      Error 3344 is pretty specific.  


                                      When you run the drmtest2.adobe.com URLs at the top of this message (SampleVideoPlayer) and you use the "Show all events" checkbox, is 3344 the only error you get?   I might have to try this again.


                                      If you can use wireshark or tcpdump (with just HTTP), you should see a request to '/drm/plug/lnx/x86' to an Adobe server to pull down the module which eventually gets expanded in:


                                      ~/.adobe/Flash Player/NativeCache/.... 


                                      3344 says the module for DRM isn't on the server which is strange because I see it there.  



                                      • 16. Re: Flash access support on linux (ubuntu)
                                        mccseanp Level 1

                                        Hello, Stephen. Sorry for the delay in my response.


                                        As for the error, 3344 is the only error I get and then the site freezes while attempting to "Download the Flash Access Library"


                                        Since the site scales down images significantly, here is the detail on the DRM messages:


                                        Wireshark does record a request to /drm/plug/lnx/x86


                                        Here is the conversation detail for that TCP Stream:


                                        GET /drm/plug/lnx/x86/ HTTP/1.1

                                        Host: xsdownload.adobe.com

                                        User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0

                                        Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

                                        Accept-Language: en-us,en;q=0.7,es;q=0.3

                                        Accept-Encoding: gzip, deflate

                                        Connection: keep-alive

                                        Cookie: s_vi=[CS]v1|27B5031C851D018D-6000014AC00E3757[CE]; storeregion=; UID=2A5829DD-92B6-A2DA-7F5F4ECC695D4A5B; SCREENNAME=mccseanp; RMID=9hIi9mwrLWIrEfehMiDQkaHg7271jp5ROPhzFx%2FkUyw%3D; ach-locale=en_US; s_cc=true; s_sq=%5B%5BB%5D%5D; fsr.s={"v":1,"rid":"1334286320469_167036","pv":1,"to":3,"c":"http://forums.adobe.com/message/4281572#4281572","lc":{"d0":{"v":1,"s":true}},"cd":0,"sd":0}

                                        If-Modified-Since: Tue, 27 Mar 2012 12:25:43 GMT

                                        If-None-Match: "ac86bb7d3c5dd331ddc5d4876a62cf31:1332851143"


                                        HTTP/1.1 304 Not Modified

                                        Last-Modified: Tue, 27 Mar 2012 12:25:42 GMT

                                        ETag: "6dce1c7053bc95f2c242f16e963f2454:1332851142"

                                        Expires: Fri, 13 Apr 2012 03:16:07 GMT

                                        Cache-Control: max-age=0, no-cache, no-store

                                        Pragma: no-cache

                                        Date: Fri, 13 Apr 2012 03:16:07 GMT

                                        Connection: keep-alive

                                        Accept-Ranges: none

                                        Content-Type: application/octet-stream

                                        X-Error-Code: 0

                                        • 17. Re: Flash access support on linux (ubuntu)
                                          Stephen D. [Adobe] Adobe Employee

                                          Let me take a look at Linux again this morning.



                                          • 18. Re: Flash access support on linux (ubuntu)

                                            Is there any update on what's going on here?  I have exactly the same issue as mccseanp --- using Ubuntu 10.04 with HAL and libhal1 already installed, the demo player attempts to download "Flash Access" library, gets all the way through the download, then hangs, doing absolutely nothing. 


                                            Of course, the main reason I'm trying is that purchased videos at Amazon stopped playing on Linux  thanks to this issue. 

                                            • 19. Re: Flash access support on linux (ubuntu)
                                              Hiroshi@Adobe Adobe Employee

                                              Hi tvrusso,


                                              Could you try again with latest flash player

                                              I didn't see the problem on Ubuntu 11.04 32bit with this latest version of flash player / firefox.


                                              And, you might need to contact to Amazon to solve Amazon video playback issue.





                                              • 20. Re: Flash access support on linux (ubuntu)
                                                mccseanp Level 1

                                                Hello Hiroshi,

                                                Thanks for chiming in. I tried again with the latest version of Flash (, but I experience the same error that I had documented above on 2012/04/12.

                                                • 21. Re: Flash access support on linux (ubuntu)
                                                  Hiroshi@Adobe Adobe Employee

                                                  Hi mccseanp,


                                                  I tried again with 32bit linux flash player plugin ( + Firefox 13.0.1 on Ubuntu 10.04.

                                                  And, it worked okay.


                                                  I'm wondering why browser got HTTP 304 code for drm module downloading.

                                                  Could you do the following step again?


                                                  1. Close firefox. (please make sure no firefox process is running)

                                                  2. cd ~

                                                  3. rm -rf .adobe

                                                  4. Launch firefox

                                                  5. Open http://drmtest2.adobe.com/AccessPlayer/plyaer.html  (AccessPlayer)

                                                  6. Press 'TVP' button at top-right corner

                                                  7. Press 'Update DRM Module' button to download DRM module

                                                  If you can't see 'AdobeCP update Complete.' message in Log info area. Please tell me what error message you got.

                                                  8. cd ~/.adobe/Flash_Player/NativeCache

                                                  9. ls -LR .

                                                  subdirectory should contain libadobecp-######-#.so file

                                                  10. Try to play http://drmtest2.adobe.com:8080/Content/anonymous.f4v


                                                  If you still get HTTP 304 code, please try to clear browser cache before that.





                                                  • 22. Re: Flash access support on linux (ubuntu)

                                                    Hi Hiroshi,


                                                    I have had the same exact problem as mccseanp. I am running Ubuntu 10.04 (lucid), Linux kernel 2.6.32-41-generic, GNOME 2.30.2, Firefox 13.0.1, Flash plugin I have tried everything in this thread and nothing works.


                                                    After step 7 in your list above, I get the following under "Log Info:"

                                                    DRM Module update error [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2203"]

                                                    Start to download DRM Module Fri Jul 13 17:49:35 GMT-0400 2012

                                                    Player mode changed to  TVP

                                                    Player Initialized!

                                                    Player mode changed to  SVP


                                                    After step 9, there is a libadobecp-301806-2.so file.


                                                    I still get the same 3344 error.


                                                    Thanks a lot,

                                                    Ali Baba

                                                    • 23. Re: Flash access support on linux (ubuntu)
                                                      Hiroshi@Adobe Adobe Employee

                                                      Hi Ali Baba,


                                                      You got Error #2203 when trying to update DRM module, but you could get libadobecp-301806-2.so file?

                                                      Can you make sure that 'rm -rf .adobe' command remove all files from the directory. And, libadobecp-301806-#.so file size would be about 5,244,142~5,244,922 ?





                                                      • 24. Re: Flash access support on linux (ubuntu)
                                                        the40thieves Level 1

                                                        Hi Hiroshi,


                                                        I tried it again. Oddly enough, the entire directory is removed but a new libadobecp-301806-1.so file is created. Its size is 6,470,400 bytes. Please let me know if you have any ideas.


                                                        Thanks again,

                                                        Ali Baba

                                                        • 25. Re: Flash access support on linux (ubuntu)
                                                          Hiroshi@Adobe Adobe Employee

                                                          Oops, I looked compressed file sizes. Correct libadobecp-301806-1.so filesize is 6,470,400. So, you've got correct one.


                                                          Do you still see Error 2203 when uploading DRM module and error 3344 when trying to play an encrypted content?



                                                          -- Hiroshi

                                                          • 26. Re: Flash access support on linux (ubuntu)
                                                            the40thieves Level 1

                                                            Yes, the same 2203 and 3344 errors.



                                                            Ali Baba

                                                            • 27. Re: Flash access support on linux (ubuntu)
                                                              Hiroshi@Adobe Adobe Employee


                                                              Right now, I don't have much idea why you guys are encountering the issue.

                                                              So, I just want to ask some basic things.


                                                              - What kind of user account are you using? normal user account? root ?

                                                              - How did you install flash player ?  Did you use .tar.gz or apt ?

                                                              - How did you install firefox?

                                                              - Can you execute the following command?

                                                              $ sudo find / -name libflashplayer*

                                                              If you found multiple libflashplayer.so files, please cleanup them. And, please make sure the browser uses correct libflashplayer.so file.

                                                              - Can use execute the following command?

                                                              $ sudo find / -name libadobe*

                                                              If you found multiple files, please cleanup them.

                                                              - Please check attributes on libadobecp-*.so file





                                                              • 28. Re: Flash access support on linux (ubuntu)

                                                                I just started seeing this behavior last night with Flash on my Arch Linux system.


                                                                I was watching videos on Amazon's VOD service. One video worked fine, then a few minutes later when I went to the next it attempted to update Flash and failed. When I went to Adobe's sample video player http://drmtest2.adobe.com:8080/SVP/SampleVideoPlayer_FP.html# and attempted to play the video at http://drmtest2.adobe.com:8080/Content/anonymous.f4v I see exactly the same thing as mccseanp's screen capture.


                                                                I have removed .adobe/ in my home directory and retried without success.

                                                                • 29. Re: Flash access support on linux (ubuntu)
                                                                  Stephen D. [Adobe] Adobe Employee

                                                                  What errors were you getting using the SampleVideoPlayer.html container?


                                                                  We published a technote some time back regarding this - especially if you're getting errors.



                                                                  Most (if not all now) Linux distros don't have the 'Hardware Abstraction Layer' installed.    It's possible the videos that played were unencrypted (free or using RTMP streaming) and the ones that didn't play needed Adobe Access validation - and the client (in this case Flash) needs to uniquely identify itself.  The mechanism used is the Hardware Abstraction Layer.


                                                                  Can you see if you have that installed?   And is the system 64-bit or 32-bit?    11.2.202 build 243 should work either way.





                                                                  • 30. Re: Flash access support on linux (ubuntu)
                                                                    zytsef Level 1

                                                                    It was precisely the same as the screen caps mccseanp posted. Error 3344. Turns out you were right. I didn't have hal installed. Found it on Arch's AUR and now everything is good.


                                                                    It confused me so much because videos I had watched earlier yesterday evening suddenly were not working. Something had definitely changed in what Amazon was serving me from one minute to the next.


                                                                    Thanks for the tip.

                                                                    • 31. Re: Flash access support on linux (ubuntu)

                                                                      I have pretty much the same issues on openSUSE:


                                                                      - Error 3344 when loading the access library

                                                                      - Freeze after loading.


                                                                      After installing HAL the only improvement was that flash now crashes completely instead of freezing after loading the library.

                                                                      Any logs i can check perhaps?

                                                                      • 32. Re: Flash access support on linux (ubuntu)
                                                                        Stephen D. [Adobe] Adobe Employee

                                                                        It's hard to believe the video situation will get better over time with Flash 11.x on Linux being frozen (and especially for protected video that requires HAL).


                                                                        It could be interaction with other (now newer) system libraries in addition to HAL, etc.  That player was built probably 2-3 years ago.


                                                                        You could look for a crash dump for the particular browser you're using, but it's unlikely there would be any action taken on the older version.    Sorry.