9 Replies Latest reply on Apr 25, 2013 4:06 PM by rob3ynccox5

    Unable to import ditamap to RH9

    FSjursaether Level 1

      First time poster - long time lurker.


      I recently installed RH9 onto my Win7 64bit system, and I cannot import any ditamaps.


      I've followed all the instructions listed by Adobe, and from this thread: http://forums.adobe.com/message/3218894#3218894 but to no effect.

      I keep getting the messsage:


      Processing with DITA Open Toolkit failed. No Logs found.

      Check DITA Open Toolkit is installed and working.


      I know that DITA Open Toolkit is installed and working, as I'm producing DITA output just fine.


      Any help or hints is very appreciated

        • 1. Re: Unable to import ditamap to RH9
          FSjursaether Level 1

          An update to this.


          I had installed Robohelp using the Technical Communications Suite (TCS) 3.0, but just with Robohelp.

          Turns out that when I went back and re-installed *all* applications of the TCS, the import of a ditamap worked.


          This is what happens when I select to import a DITAMAP into Robohelp.

          Robohelp kick-starts FrameMaker that works "in the background" by converting the DITAMAP and its DITA XML files into a HTML Help (CHM) project that RoboHelp can open and work with. In my experience it is far faster to create the CHM project directly using the DITA OT, and then just use Robohelp to import the CHM project rather than going via FrameMaker.

          • 2. Re: Unable to import ditamap to RH9
            RoboAsh Level 2

            Hi FSjursaether,

                     Have to given the path to ditamap "D:\DITA-OT1.5.1" for the Dita OTK Home directory as shown in the image attached.


            there are two paths for Ditamap import in RoboHelp 9

                   1. through Dita OTK

                   2. through FrameMaker - but this one is required only for FrameMaker ditamap.


            In general you can use import through dita OTK only.


            Please observe that there are two ditamap types listed in the type of file filter in Import dialog

                  1. Dita Map - this will import through OTK

                 2. FrameMaker Ditamap - this will import through FrameMaker


            use the first option and it will be as fast as generating through OTK, the additional benefit of bring in content in RoboHelp before generating output will be, the capability of using other feature like apply CBT, using DHTML effect, intermediate output specific editing and many more.


            Hope this will help





            • 3. Re: Unable to import ditamap to RH9
              FSjursaether Level 1

              Hi RoboAsh,

              Don't get me wrong. I do want to use Robohelp with DITA xml files, but what you're seeing is not what I'm seeing.


              I've tried

              1. From Start page, I select Import > More...
              2. In the New Project dialog, I select DITA Map File (*.ditamap) - the one I try is called tips.ditamap
              3. In the 'DITA Map file to import' I find the ditamap, and also define a new empty folder for the location of the project.
              4. Now, in the 'DITA Open Toolkit Processing Options' I set the Home Directory exactly as you set it.


              Result: Robohelp says "The "<path-to>\tips.HHP" is not a valid HTML Help Project file"


              Why Robohelp would assume it's a HTML Help Project I don't know, but I guess that's hard-wired into RH.


              When I try to import into the Project Files of a new project, I get "Error occured while importing <path-to>\tips.ditamap. See Output View for details."

              The Output View says:

              "Processing with DITA Open Toolkit failed. No Logs found.

              Check DITA Open Toolkit is installed and working."


              And yes, the <path-to> does not contain any spaces or funny characters.

              And yes, the DITA-OT works - I'm producing output from it.

              And no, I have no environment settings set for either JAVA_HOME or DITA_DIR.


              Running on Windows 7 64-bit as Administrator

              • 4. Re: Unable to import ditamap to RH9
                Gale James

                I have the same problem. I'm using the TCS 3.5 suite with FM 10 and RoboHelp 9. Has anyone found a solution to this problem?





                • 5. Re: Unable to import ditamap to RH9

                  Bump to this. No answers?

                  I'm getting this in RH10 too.

                  • 6. Re: Unable to import ditamap to RH9
                    Captiv8r Adobe Community Professional & MVP

                    Hi there


                    Sorry, but answers on this are indeed going to be scarce. Why? Well, to be honest, I think very very few folks using RoboHelp even know what a DITAMap even is, let alone how or why one would want to work with one in RoboHelp. From my own very limite understanding of DITA (I know it's an acronym and it's used somehow with documents and I can say: DITA) RoboHelp has never been a tool used with this.


                    Best of luck to you in sorting it... Rick

                    • 7. Re: Unable to import ditamap to RH9
                      RoboColum(n) Level 5

                      Here is what I have to offer although my knowledge of DITA is only marginally greater than Rick's. My guess here is that most structured FrameMaker users wouldn't even consider importing or linking to a RoboHelp project. Anyway you could try updating your DITA Open Toolkit to the latest version. This seems to have sorted other associated problems with this workflow.

                      • 8. Re: Unable to import ditamap to RH9
                        mkocik11 Level 1

                        @Captiv8r and RoboColum(n): I understand what you mean. Bottom line is that I'm trying to use the Publish functionality in FM to create OLH output. FM of course uses RoboHelp as a passthrough (or you can associate a project and other configs if you wish). I had to try the Import Ditamap function of RH because my ditamap published from FM was not creating any topics. Adobe Support is supposed to be looking into both of these problems (they requested that I re-install TCS, I requested they troubleshoot some more). They seem to think it's because I have both TCS 3.5 and TCS 4 loaded on my system, but I'm a bit skeptical of that.


                        I am using DITA-OT 1.6.3, btw.

                        • 9. Re: Unable to import ditamap to RH9

                          When I imported a ditamap into RoboHelp 10 I received the error "xxx.ditamap hhp is not a valid Help project. To fix this. Create short-cut on your desktop. Open the short-cut, click Advanced and check the box for "Run as Administrator". This is a new step if you're running on Windows 7. For me, it fixed the problem. Hope this helps.