21 Replies Latest reply on Aug 24, 2012 7:46 AM by tolis.pas

    itunes sync 'AppName' failed to install.

    swfisgood Level 1

      I dont understand why i get this sometimes when trying to sync an app to my device (message shows on device itself)


      certain provisioning profiles just dont work. I will usually fumble around, creating new ones until i get one to work.


      The latest attempt:

      I created the provisioning profile on the iOS developer site.

      I included 2 udids.



      I created the app, it works on one device, but not the other

      itunes sync 'AppName' failed to install.


      ok, let me test again,  so i go create a new profile for just one UDID (the UDID that was working a moment ago)

      itunes sync 'AppName' failed to install.


      What!!! WHY!

      Its like some profiles are corrupt or something? What can i be missing here?


      for one example, both udids are in the profile, why would the .ipa install on one, but not the other?

      (installing from 2 different comptuers)








        • 1. Re: itunes sync 'AppName' failed to install.
          Saumitra Bhave Level 3



          Are you installing through iTunes, or xCode? What is your iOS version? Can you also post the versions of all the tools you are using?

          • 2. Re: itunes sync 'AppName' failed to install.
            Colin Holgate MVP & Adobe Community Professional

            You can expand IPA files and take the app file that is in the payload folder, and drag it straight to your device in the Organizer window of Xcode, without involving iTunes.


            What was the second device? If it was an iPhone, iPhone 3G, iPod Touch 1st or 2nd generation, or a 3rd generation 8GB, then AIR apps won't work on them.

            • 3. Re: itunes sync 'AppName' failed to install.
              Colin Holgate MVP & Adobe Community Professional

              "iTunes" was in the subject, so I took it that he used iTunes.

              • 4. Re: itunes sync 'AppName' failed to install.
                swfisgood Level 1


                flash cs5.5

                Air3.2.0.1320 beta



                ipod4 iOS 5.0

                iphone4s  iOS unkown at this time


                One provisioning profile had 2 Udids selected. I downloaded and used that provisioning profile.

                I am able to sync it to my ipod4th gen with itunes

                The second device (which denied it) is iphone4s, and the person i am giving it to is also using itunes -version unknown at this time-


                I would say its something with the iphone4s or her itunes, but i was also getting the same error here with some of the provisioning profiles.

                I just noticed now that all the profiles i have tested on the device show "verified" on the device, the app just didnt install many of the times.


                I think it is something stupid on my part, perhaps the app ID in the provisioning portal?

                I just switched it to a different app ID (I have a few app IDs listed, all from testing) and now it works again on the one device (ipod).


                I can try other tools, but the  beta testers sent file via email will most likely want to use itunes only

                • 5. Re: itunes sync 'AppName' failed to install.
                  swfisgood Level 1

                  To be clear about it, if i have a profile that works, it always works. It's not as if it fails to push to the device sometimes. It seems the profiles themselves are  the cause.

                  • 6. Re: itunes sync 'AppName' failed to install.
                    swfisgood Level 1

                    swfisgood wrote:


                    To be clear about it, if i have a profile that works, it always works. It's not as if it fails to push to the device sometimes. It seems the profiles themselves are  the cause.

                    that comment was wrong, now i am unable to sync the same ipa files that were working a moment ago.

                    I think it's craptacular itunes + iOS5

                    • 7. Re: itunes sync 'AppName' failed to install.
                      swfisgood Level 1

                      Any suggestions you can think of? I have now lost all ability to test the app even on my own device. It seems to provisioning profiles are the cause?


                      with itunes, the device itself gives the unhelpful error itunes sync 'AppName' failed to install.


                      with the iphone configuration utility, the program errors:

                      Could not install the application on device. Error: A valid provisioning profile for this executable was not found.


                      I dont understand, this has been working for months and now it does not.


                      When i try to install the application, the provisioning profile shows up on the device and states its valid.



                      I am now starting from scratch again from the iOS provisioning page, but it will not work at all this time.


                      desciption: [a name i put]


                      bundleSeedID(app id prefix)

                      i have only a choice of two or "team id"


                      budle identifier (app id suffix)

                      i had always used the wild card * 

                      this worked in the past, now i have tried creating provisioning profiles this way, or with a valid name and using the same name in app id export settings in flash Ide



                      new profile


                      name myProfile

                      [certificate selected]


                      app id

                      [selected the app id i just made]


                      device selected, UDID is  correct and worked for months prior



                      download profile


                      create the app in flash CS5.5


                      app ID = anything because i used the wind card, OR exact same as app ID created in iOS page


                      its created successful, but fails to install on device.


                      Any suggestions are welcome, i am now spending hours on this its ridiculous

                      • 8. Re: itunes sync 'AppName' failed to install.
                        swfisgood Level 1

                        sorry if i am ranting here, one last question.


                        i did everything possible, any profile i create just flat out does not work. nothing i can do, worked before, now it does not on any device.


                        To get it to work again i had to delete the certificate from the iOS page and create a new signing request from openssl, download new cert, convert to new p12, yadda yadda


                        Now it works.

                        somehow my cert magically went bad, but said it was still good?


                        at the same time i noticed this.

                        "If you do not have the WWDR intermediate certificate installed download"


                        I read to add it to the keychain.. i am on a windows, what does this mean for me?

                        Anyway i downloaded and dragged it into itunes, nothing happened but is this possibly what fixed the issue this time around? I never had to do this before, and now the link is gone from the iOS portal.


                        I need to know why i struggle with this every so often so when it comes up again next time. Once again im back working and i dont know why


                        • 9. Re: itunes sync 'AppName' failed to install.
                          swfisgood Level 1

                          I notice this thread has a crazy # views and is under popular discussions, although its 2 months old.


                          Just a side note, on windows the iphone configuration utility just wont work (for me) if the device has iOS4, with iOS5 there seems to be no problem.


                          On a mac the app seems to push ok regardless of what iOS version.

                          • 10. Re: itunes sync 'AppName' failed to install.

                            I am having the same problem. One of my developers created a Flashbuilder Actionscript mobile app which runs fine on the FB simulator but I can't install (for testing) it onto my iPad.  Do others have this problem? 


                            I am a member of three different devleopment teams.  I'v eensured I am using the correct dev_certs - matched them to each team.


                            I've matched my UDID, app_id to ensure I am using correct ones.  I can't upload ipa (at times) to TestFlightapp.com becuase of ubiquity errors - but then again sometimes it does load - but it will not install on iPad.  I also cannot install the ipa using iTunes.  I've loaded my .mobileprovision files via iTunes onto the iPad as some posts say you need to do that.


                            I've never had problems using xCode testing on my devices but we can get anything created with FlashBuilder loaded.  I've created AS and Flex ipa files used my personal dev certadnmobile provisioning in addition to the above mentioned dev_certs/mobileprovision for my work team.


                            Are otehrs having this same issue and how is it being resolved.  If we can't correct this we'll have to abandon FlashBUilder, learn ObjectiveC or do everything HTML5 based.



                            • 11. Re: itunes sync 'AppName' failed to install.
                              12345abcdefghi Level 1

                              I probably won't be much help but here's a hail Mary


                              Could your provisioning profile be outdated? They expire after a year or less


                              Is your profile installed using the iPhone configuration utility? I could find no other way to install it without the utility


                              Are you using the correct bundle identifyier in your xml file? This is a common problem if you are making an app called foo_bar you might have a created a bundle ID at apple's site called com.foo_bar.myCompany yet apple does this number on it:




                              Remove the af10234c, don't put it in the bundle ID field in flash! Cause iTunes will say something like your profile is bad.


                              I bet you can now appriciate how well though out error handling is on iTunes for developers . [sarcasm if you can't tell] Easy to use for everyone but the people that make the damn things work.

                              • 12. Re: itunes sync 'AppName' failed to install.
                                Hank von Turbo

                                Thanks 12345abcdefghi, that tip worked for me. Stupid as I was adding the actual string in the provisioning profile to the app.

                                • 13. Re: itunes sync 'AppName' failed to install.

                                  I've got the same problem, my ID on the descriptor file is same as my Bundle ID but still it failed to install. Any ideas?



                                  • 14. Re: itunes sync 'AppName' failed to install.
                                    kcBZOR Level 1

                                    getting the same problem as well.. The app is working great with the ios_development.p12 and the development mobileprovision when I debug, but when I change to the ios_distribution.p12 and ad hoc mobileprovision (all created at the same time in the portal) it says "app failed to install" on all devices I have set under Devices and work with the developer version.


                                    I'm using Flash Buider 4.6 and Air 3.2 (did the same with 3.1), the devices are a iPhone 4, iPod Touch and a 3GS.


                                    Want to get this submitted asap, any help is most appreciated

                                    • 15. Re: itunes sync 'AppName' failed to install.
                                      12345abcdefghi Level 1

                                      For what its worth (probalby not much) I was never able to test my distro.p12 compiled apps on my devices I just kinda winged it and sent the binarys to Apple hopeing I didn't goof up packaging the final version.. probably not what you want to hear...

                                      • 16. Re: itunes sync 'AppName' failed to install.
                                        kcBZOR Level 1

                                        ok I got it working.. my problem (I think) was that I was using the same .csr for the development and distribution certificates, you need to make a new .csr for each. ad hoc works and the app is off for review.

                                        • 17. Re: itunes sync 'AppName' failed to install.
                                          AirDoctrine2 Level 1

                                          I've run into this issue a number of times during development. It is really agravating as it is not intuitive where the problem lies, but has always been solvable. This typicallly happens to me when I try to add a new device for testing.


                                          This is what I do that seems to work for me:


                                          - First you have to update ALL of your mobile provisioning files through the Apple Member Center site to include your new device (debug, ad hoc, release, etc). If you miss updating any one of these your app may end up failing to install. Then download all the new files.

                                          - You need to manually delete any old provisioning files that are associated with iTunes. Simply dragging the new files onto iTunes doesn't always seem to work for me (I think this is what causes the problem for may people). Instead on Mac navigate to ~user/Library/MobileDevice/Provisioning Profiles/ and delete the old *.mobileprovision files that you are trying to replace. Manually copy the new mobile provisioning files into this folder to replace the old ones. I'm not sure where the corresponding folder is located in Windows.

                                          - Remove the old profile(s) from your iOS device. Go to: Settings->General->Profile. Select the Profile(s) and then Remove.

                                          - Rebuild your app using the new mobile provisioning files.

                                          - Drag your new ipa file onto iTunes to replace the old ipa file.

                                          - Now sync again with iTunes.


                                          Hopefully that will get you back up and running again.

                                          • 18. Re: itunes sync 'AppName' failed to install.

                                            I ran into this issue and the problem was that I had changed the <id> and <filename> tages in the xml file.


                                            For some reason this did not cause a problem on an iphone 4s, but did prevent it from being installed on the 3gs. When I changed them both back, it worked on the 3gs as well.

                                            • 19. Re: itunes sync 'AppName' failed to install.

                                              We had the same error msg when using a Development Provisioning Profile.

                                              Using FlashDevelop we followed the steps of Emanuele Feronato at http://www.emanueleferonato.com/2011/09/22/creation-of-an-iphone-app-with-flash-and-withou t-a-mac-for-all-windows-lovers/ although some of the file names are as of now inaccurate.


                                              We also got the "itunes sync 'AppName' failed to install" msg.

                                              It turns out that the Bundle Identifier (App ID Suffix) was incorrect from the application.xml file we used in our FlashDevelop project.

                                              We were missing the 'air' at the start of the ID.

                                              We had at our App ID Suffix written only se.domainname.appname and once we changed the App ID Suffix to match the ID tag in the xml it worked, ie we changed it to air.se.domainname.AppName (and at the same time used the correct camelcasing).


                                              With a new profile it worked like a charm after that  :-)

                                              • 20. Re: itunes sync 'AppName' failed to install.
                                                Yozef0 Level 1

                                                Another thing to look out for...


                                                Simply double click your provisioning file to see if it expired

                                                • 21. Re: itunes sync 'AppName' failed to install.
                                                  tolis.pas Level 1

                                                  I want to add my adventure with this message in case someone had the same problems. I had a problem with testing in-app purchases on an iphone 4. The problem was that the device was jailbroken. I updated to iOS

                                                  5.x. After the update, when I tried to install the application, I got this annoying message, but only when I tried to compile with adt.


                                                  When I was compiling from inside the flash builder everything seemed to work fine, but I could not test extensions. The problem was that when I was opening the myapp-app.xml from inside flash builder everything seemed ok and the app <id> was in the form of com.mycompany.myapp.


                                                  But when I opened the myapp-app.xml with a text editor, the app <id> was in the form of com.mycompany.myapp.debug.


                                                  This debug thing messed everything up. As soon as I removed manually the .debug surfix everything worked ok.