1 2 Previous Next 53 Replies Latest reply: Mar 6, 2012 10:17 AM by cdrice999 RSS

    Video doesn't import?

    paul_michael_kane Community Member

      Good morning!!


      Very excited to find the new beta this moring . . . and even more excited to find that it supports video editing! Only one problem . . . I can't seem to import video! Tried from two different sources: iPhone and Nikon D5100. I get an error message:


      There is a problem with the video file (1)


      Any suggestions?


      Running Windows 7, 64bit . . .



        • 1. Re: Video doesn't import?
          +becs Adobe Employee

          Can you try copying the video from camera/IPhone to your hard drive, and see if it imports that way?  I want to eliminate the possibility of an issue with the camera connection.

          • 2. Re: Video doesn't import?
            paul_michael_kane Community Member

            Thanks for the quick responce . . . I did try that . . . pulled both files to my desktop and tried importing from there . . . still no luck. Same message.



            • 3. Re: Video doesn't import?
              Victoria Bampton LR Queen ACP/MVP

              Do they import into LR3 ok?

              • 4. Re: Video doesn't import?
                paul_michael_kane Community Member

                Hi, Victoria . . .


                The videos import perfectly into LR3 . . . when I click on them, they open in their native players.



                • 5. Re: Video doesn't import?
                  Rob Sylvan Community Member

                  I have been experiencing problems with iPhone 4S video on my Win 7 machine (and my MacBook Pro too), but my D5100 video has been OK so far. They both import OK though. My problem is in the iPhone 4S playback part. Playback is either very jerky or completely halts while the audio plays on smoothly. My D5100 video plays fine. Would love to discover the culprit.

                  • 6. Re: Video doesn't import?
                    +becs Adobe Employee

                    Paul, I contacted you privately to get a sample video file for investigation.

                    • 7. Re: Video doesn't import?
                      paul_michael_kane Community Member

                      Thanks so much, Becky . . . I've responded to your email with a link to the video, which can be found here: http://www.pmkane.com/DSC_0026.MOV

                      • 8. Re: Video doesn't import?
                        +becs Adobe Employee

                        Thanks Paul. I was able to import the video without any problems.  Can you check something for me?


                        1. Quit Lightroom.  If you're running Premiere, quit that as well. 

                        2. Go to Task Manager (right click on the Task bar and choose "Start Task Manager")

                        3. Go to the Processes tab

                        4. Do you see dynamiclinkmediaserver.exe or dynamiclinkmanager.exe running?

                        5. Wait about 15 seconds and see if they go away.

                        6. If they don't go away, quit whichever of them is running (or both, if they both are). 

                        7. Restart Lightroom and try importing the video file again.


                        I'm curious if you see the processes running in step 4, and whether you have to quit them, or if they quit on their own.  I'm also curious if the video import will work after you run these steps. 



                        • 9. Re: Video doesn't import?
                          paul_michael_kane Community Member

                          I did a full shut down and restart to make sure everything was zeroed out. Only program running is LR4.


                          When I start LR4, neither of the two .exe files are running.


                          When I pop the memory card in, the two .exe files show up. They both have an *32 next to them.


                          I close out of LR4 and the dynamiclinkmediaserver.exe ends on its own . . . a few seconds later, the dynamiclinkmanager.exe ends also.


                          Restart LR4, repeat the steps and both .exe files come back up.


                          I tried doing this with a memory card file and the file off my hard drive.


                          Hope that helps . . .



                          • 10. Re: Video doesn't import?
                            Cristian Samoila Community Member



                            The same problem here, two types of video files and none of them importing. Up till now I have tested some scenarios and none seems to work.

                            First about the configuration, video files and then about the steps taken:



                            1. Hardware: laptop Dell XPS L501x, Intel Core i7 740QM QuadCore, Corsair 8 GB RAM, 500 GB HDD 7200 rpm, nVidia 435M 2GB DDR3 Video Memory

                            2. Software: Windows 7 Home Premium 64bit SP1, Adobe Photoshop Lightroom 3.6 64bit, Adobe Photoshop Lightroom 4.0 beta 64bit, Adobe Creative Suite Production Premium CS 5.5, Apple QuickTime 7.7.1

                            3. Video files: AVI HD 720p 30p filmed with Olympus EP-2, MTS Full-HD 1080p 24p filmed with Panasonic GH-2 (with and without firmware crack), MTS Full-HD 1080p 50i filmed with JVC Everio GZHM445BE (folder size 100 GB, file sizes between 4 MB and 4 GB, video lenght between 1s and 15 min). All video files behave as expected in Premiere and After Effects and as a test I have imported all the videos in that folder in a new Premiere project without any issues.


                            Steps taken:

                            1. Import folder in LR4: shows no file preview, after 1 hour nothing imported. Close LR4.

                            2. LR3.6 won't start. Open Task Manager: memory footprint of LR 3.6 peaks at 150 MB. From Task Manager killed both dynamiclinkmediaserver.exe and dynamiclinkmanager.exe, LR3.6 exits on it's own.

                            3. In LR4, select to import one file of each type, after 30 min nothing imported. Exit LR4.

                            4. Repeat step 2.

                            5. In LR3.6, import one 720p 1 second AVI file (4 MB), preview normally, close. Open LR4 beta, tried to import the same AVI file, fails. Close LR4. The AVI plays normally in QuickTime, Windows Media Player, VLC and I can import it and work with it in Premiere and After Effects without issues.

                            6. Repeat step 2.

                            7. Start LR3.6 normally, make some adjustments on a photo. Close LR3.6. Open Lightroom 4 beta, make some adjustments on a photo, close LR4. Restart LR3.6 normally, make some adjustments on a photo. Close LR3.6.


                            As soon as I try to import video, dynamiclinkmediaserver.exe oscilates for about 10 minutes between at 8 and 24% CPU usage and 60-125M memory footprint, then stabilizes at 13% CPU usage and around 83 MB memory footprint, dynamiclinkmanager.exe is always at 0% CPU usage and 8668 K memory footprint. The values here are as read from the Task Manager.


                            The two background dynamic processes won't terminate on their own after LR4 is closed on video import on both end application scenarios: cancel import and close LR; close LR, warning about import process running, ok to cancel, LR exits. These processes are only activated on video related tasks, as seen from the last step.


                            Hope that helps,



                            Message edited to add more details about the video file specs, steps taken and behaviour of both versions of LR.

                            • 11. Re: Video doesn't import?
                              derekpell@gmail.com Community Member

                              Same problem here...can't import videos from my Nikon D300s using Windows version of the beta. No video files can be imported from hard drive or card.

                              • 12. Re: Video doesn't import?
                                bulldogg187 Community Member

                                i have the same problem. 

                                Nikon d300s

                                windows 7 professional 64

                                no video files recognized when attempting to import.

                                error message "dynamiclinkmediaserver.exe has stopped working"  once i closed the dialog box all my video files change from the video icon to "preview unavailable for this file"

                                • 13. Re: Video doesn't import?
                                  carchibald123 Community Member

                                  Same problem for me.  All my video imports fine in LR3.

                                  When importing in lr4, it can see the file, but not show a preview image.  It then fails to import any video. 

                                  I have video from Apple iPhone 4, Canon 5d m2, Fuji x100.  All have the .mov extension.

                                  • 14. Re: Video doesn't import?
                                    Stone.Pan Community Member

                                    do you guys check if 'Adobe QT32 Server.exe' process is running in task manager when Lr do importing video?  if not, you can launch it by explorer manually:  it locates "C:\program files\Adobe\Adobe Photoshop Lightroom 4\Support\DynamiclinkMediaSever\dynamiclinkmediaserver\1.0\Adobe QT32 Server.exe. 


                                    PS: make sure all three processes Adobe QT32 server.exe, dynamiclinkmediaserver.exe and dynamiclinkmanager.exe are running.

                                    • 15. Re: Video doesn't import?
                                      derekpell@gmail.com Community Member

                                      Yes, all three are running, but that's not the problem as I'm still unable to import any video files into LR4 (avi, mov, etc.)


                                      No problem in LR3.

                                      • 16. Re: Video doesn't import?
                                        Stone.Pan Community Member

                                        how about kill all thress processes and relaunch lightroom?

                                        • 17. Re: Video doesn't import?
                                          Cristian Samoila Community Member

                                          So, further testing.


                                          It seems that the problem is indeed in the combination of the three processes: Adobe QT32 Server.exe, dynamiclinkmediaserver.exe and dynamiclinkmanager.exe. I managed to import some of the videos and generally after a cold restart of the computer I now see some or all the previews in the import dialog and I can import some new videos from the folder. Trying to kill the 3 processes and then restarting LR4 is less succesfull than rebooting the computer (i.e. I managed only once to import two videos after killing the processes, starting LR and manually starting Adobe QT32 Server.exe versus managing to import some videos each and every time after a cold reboot).


                                          One test after reboot was particularily good as it managed to import 470 video files before crashing. Usually it crashes after 3-5 videos imported.


                                          As a side note, I managed to glimpse a OpenGL error report related to Lightroom.exe during a reboot, but I couldn't get the name of the offending module and I couldn't find it in the Windows Error Reports logs.

                                          • 18. Re: Video doesn't import?
                                            erling_p Community Member

                                            Have similar problems.


                                            When importing videofiles: it seems importing is under way, but nothing happens. After killing process dynamiclinkmediaserver Import pop-box appears with the message: There is a problem with the video file followed by list of video filenames.


                                            Restarted LR 4, killed process dynamiclinkmanager. When synchronizing folder some .mov files were imported, but LR 4 refuses to import .avi files.


                                            When trying to work on the .mov files in LR 4 there is a message saying: There is an error working with the video. After restarting  LR 4 the videos are accessible!


                                            I have not succeeded to import avi files, so there seems to be a major problem with handling of videos.

                                            • 19. Re: Video doesn't import?
                                              Cristian Samoila Community Member

                                              OK. Problem isolated.


                                              All the imported files are MTS from Panasonic GH-2 and JVC Everio GZHM445BE. All the offending files were AVI from Olympus EP2.

                                              Due to the large number of files in the folder it didn't occur to me to verify if there was a correlation between the file types in the folder and the repeated crashes. I separated the files in two foldersby type: avi and mts and now the import runs fast and smooth even if the dynamiclinkmanager.exe is eating alot of resources for a while after the import has finished. It imported 611 MTS files / 133 GB in one go without hiccups.


                                              So, if you have problems importing video files, try to separate them in folders by filetype and (maybe) by camera model. As long as you have, even in the import dialog, mixed file types the import will fail. One of the three processes hangs either when trying to preview the files, either during import.

                                              • 20. Re: Video doesn't import?
                                                derekpell@gmail.com Community Member

                                                Video files will not import into Windows version of LR4, even an isolated AVI on my desktop. There is a major bug here.

                                                • 21. Re: Video doesn't import?
                                                  +becs Adobe Employee

                                                  If you get the ""dynamiclinkmediaserver.exe has stopped working" message when you try to work with a video file, try quitting Lightroom and see if the video problems persist when you restart.

                                                  • 22. Re: Video doesn't import?
                                                    derekpell@gmail.com Community Member

                                                    I don't get that message. The video import just stalls and doesn't import files.

                                                    • 23. Re: Video doesn't import?
                                                      +becs Adobe Employee

                                                      Can you check to see if you have QuickTime installed?   Or, if your version is older, try updating to the latest QT version?

                                                      • 24. Re: Video doesn't import?
                                                        paul_michael_kane Community Member

                                                        Just checked . . . I have quicktime 7.7.1 installled, the latest version.



                                                        • 25. Re: Video doesn't import?
                                                          derekpell@gmail.com Community Member

                                                          Have the latest QT installed.

                                                          • 26. Re: Video doesn't import?
                                                            bulldogg187 Community Member

                                                            i do get the dynamiclinkmediaserver.exe has stopped working message.  I also have the newest version of  qicktime.

                                                            • 27. Re: Video doesn't import?
                                                              +becs Adobe Employee

                                                              Next investigative step...do you have anything in your Video Cache folder? 




                                                              If you do, go to Lightroom, then Edit > Preferences.  Go to the File Handling tab and Purge the Video Cache (at the bottom of the dialog).  Restart Lightroom and try importing your videos again.


                                                              Thanks for all the help!


                                                              • 28. Re: Video doesn't import?
                                                                paul_michael_kane Community Member

                                                                Thanks Becky . . .


                                                                So I went into my AppData and found two folders in the Video folder: Media Cache & Media Chache Files.


                                                                Followed your steps to purge the Video Cache in Lightroom . . . shut it down, reopened it and tried to import the video right from my hard drive. Same result as before. Used a memory card with just a video on it from my D5100 and still, same result . . . There is now a .db file in the Video folder named LightroomPlayback.db. That appeared after I did the purge.


                                                                Thank YOU for all the help!! Really enjoying all the new features of LR4 and I am sure we'll figure this out!!



                                                                • 29. Re: Video doesn't import?
                                                                  derekpell@gmail.com Community Member

                                                                  I tried your advice Becky, purged the cache, restarted, and still not able to import videos. i think there's a bug in Lightroom.

                                                                  • 30. Re: Video doesn't import?
                                                                    +becs Adobe Employee

                                                                    Thanks guys, for giving that a try.  Definitely, there is a bug in Lightroom.  I'm just trying to figure out what is causing it.  I've collected sample videos that are failing for you, and they import without issue for me - so, again, I appreciate the help in figuring out the exact set of parameters to make this bug happen. 

                                                                    • 31. Re: Video doesn't import?
                                                                      Susan S. Community Member

                                                                      I'm on a mac, OS10.6.8,Intel Core 2 Duo 2.93 GHz, 8Gb Ram and I can't import video files either from the hard drive (already successfully imported into LR3) or straight from the camera's memory card - .MOV files from a Canon powershot G11, or .AVI files from a couple of Canon point and shoots that the kids have. As I'm on a Mac none of the solutions suggested here are much help!

                                                                      After import I get an error message saying there was a problem with the file. A few of the videos did get as far as showing a thumbnail, but I couldn't do any of the video editing processes or play them.

                                                                      • 32. Re: Video doesn't import?
                                                                        bulldogg187 Community Member

                                                                        Followed your instructions 3x…it allowed me to import 1 file then crashed.  I restarted the program and tried another experiment.   I used my Kodak zi8 to record several 10 second videos.  Had no problem importing them from the sd card.   But when I tried to import my dslr clips it crashed again.  When I say crashed I mean the error dialog box appears with the “dynamiclinkmediaserver.exe has stopped working” message

                                                                        • 33. Re: Video doesn't import?
                                                                          Julie Kmoch Adobe Employee

                                                                          Are any of you Win7 users running on an AMD processor? (From the Start menu, right-click on Computer, choose Properties, and look for the "Processor" line under the System section.)

                                                                          • 34. Re: Video doesn't import?
                                                                            paul_michael_kane Community Member

                                                                            My processor is an Intel Core i5-240 CPU 3.10GHz



                                                                            • 35. Re: Video doesn't import?
                                                                              derekpell@gmail.com Community Member

                                                                              I'm on Intel core.

                                                                              • 36. Re: Video doesn't import?
                                                                                bulldogg187 Community Member

                                                                                Intel core i7

                                                                                • 37. Re: Video doesn't import?
                                                                                  erling_p Community Member

                                                                                  Intel Core i7


                                                                                  Playing around trying to import videos noted the following:


                                                                                  - .mov files  from my Canon S95 sometimes import, but will not play until restart of LR4 b.1

                                                                                  - Still no import of .avi files from my older Canon G9 and G3 cameras.


                                                                                  Sometimes the infobox gives a list of files that it will not import, and sometimes it says: "movie files contain no video frames"

                                                                                  Don't know if this helps on isolating the problem.


                                                                                  I have tried all the suggestions on this thread, but still no import of .avi video files neither when trying direct from camera, card reader or from HD. And yes they import in LR3.6 flawlessly.

                                                                                  • 38. Re: Video doesn't import?
                                                                                    cdrice999 Community Member

                                                                                    Searching for information about this problem led me to this thread.  I'm both happy and sad to see I'm not alone with this issue.


                                                                                    I see the same behavior -- I cannot import (via import or folder synchronize dialogs) *any* video (multiple types, including Canon P&S .avi, Nikon DSLR .avi, Kodak Zi8 .mov, etc.).  The original copies of all of these are correctly manged in LR3 (I made a unique copy to experiment with LR4).  I am attempting to import in place using files on a local hard drive ("adding" to catalog, not copying or moving).


                                                                                    Attempts to import appear to hang and cause dynamiclinkmediaserver to spike and maintain constant 50% cpu utilization, and imports remain hung (I have left them running as long as an hour) until I kill the dynamiclinkmediaserver process.  After killing dynamiclinkmediaserver, I receive either "unable to import files" or "movie files contain no video frames" error messages.  I have the latest Quicktime version installed.I have cleared the video cache, re-installed Quicktime and rebooted with no change in behavior.


                                                                                    Processor is Intel Core2 Duo T7500 (2.2GHz), running Windows 7 64-bit with 4G RAM.


                                                                                    If there are additional suggestions or more information needed, I will be happy to try and/or provide it...

                                                                                    • 39. Re: Video doesn't import?
                                                                                      +becs Adobe Employee

                                                                                      We've been hearing reports that some anti-virus software is flagging some of Lightroom's video-related DLL as possible threats.  The files get quarantined, so Lightroom can't access them, and they are required for video support. 


                                                                                      The specific files we've heard about thus far are:


                                                                                      Go to your anti-virus software and check whether these files have been quarantined.  Mark them as safe, restart Lightroom, and see if videos will import.




                                                                                      1 2 Previous Next