1 2 Previous Next 43 Replies Latest reply: Jun 20, 2012 4:43 AM by Samoreen RSS

    "unknown error while writing metadata" error while working in Silver Efex Pro2 and Lightroom 3.6

    billyphoto Community Member

      Anyone else having this issue?

       

      I'm having an issue with Lightroom 3.6 and Nik Silver Efex Pro 2 2.003. After round tripping from LR to SEP, the TIF file created in Lightroom and modified in SEP cannot update metadata when returned back to Lightroom 3.6. Reverting to LR 3.5 seems to solve the issue. I have found others on various forums with a similar issue involving SEP and/or other 3rd party plugins with LR 3.6.

       

      Lengthy troubleshooting details below:

       

      Working in Lightroom 3.6/Camera RAW 6.6 and SEP2 v. 2.003 x64. Also I am running Mac OSX 10.7.2 Lion and using Photoshop CS 5.5 v12.1.

       

      Edit RAW file in SEP2 as TIF image, make adjustments in SEP2 and save. Back in Lightroom new SEP version appears in Lightroom catalog, BUT as soon as I make any changes to SEP version of image, (change rating, develop further... any change at all) the image suddenly gets flagged with the ! metadata error.

       

      If I try to export metadata back to image, I get a "There was an unknown error while writing metadata to this photo. Retry?" error. I can choose Import Settings from Disk, Cancel or Retry Metadata Export.

       

      If I choose Retry, I get the same error. If I choose Import Settings from Disk, it changes my file back to the state it was immediately following the SEP save and the ! goes away, but as soon as I try to make any new metadata change, I'm back to the same ! error.

       

      This happens with RAW files from a 5D Mark II and a Leica X1 that have been converted to DNG during Lightroom import. I have no other cameras to experiment with. My SEP2 workflow has remain unchanged and this is a problem that has only started to occur in the last few weeks.

       

      Additionally, if I open a RAW file from Lightroom into SEP, letting SEP launch with the image, but choose cancel before making any SEP adjustments, the TIF file Lightroom created to open in SEP is not affected by this. In other words, as long as I don't let SEP save over the new TIF file, I don't have any metadata errors.

       

      Even if I open the "corrupt" TIF file in Photoshop and resave it with a different file name and import the renamed file back into Lightroom, Lightroom cannot make any metadata changes without incurring the ! error on the file.

       

      I have optimized and tested the integrity of my Lightroom Catalog and uninstalled and reinstalled SEP2 v. 2.003 and I have the same results.

       

      Every time I use SEP2 with Lightroom 3.6 to make a B&W conversion, I'm left with what *appears* to be a damaged file. When I try to export any SEP2 processed TIF file from Lightroom as the original file (no resizing or any change to the file) Lightroom gives me an error saying, "The file appears to be unsupported or damaged."

       

      If I export the file as a JPG, Lightroom manages to export it properly. Very strange.

       

      As a final test, I opened one of the original DNG files directly in Photoshop, used SEP2 from within Photoshop and saved the new TIF file. I imported that into my Lightroom catalog and I have no metadata issues with the file created from SEP2 in Photoshop rather than Lightroom. My issue appears to be limited to Lightroom 3.6.

       

      Reverting to Lightroom 3.5 seems to solve the issue and happily, all of my SEP TIFs can now accept metadata changes. The original TIF files can also be exported from LR without errors and there appears to be no permanent damage to the post SEP processed TIF files.

       

      I have also posted this on the Nik forums so they are in the loop on this issue.

       

      If anyone has any other solutions or workarounds, I'd love to hear them. Thank you.

       

      Billy

        1 2 Previous Next