17 Replies Latest reply: May 21, 2012 12:56 AM by jj_fedora RSS

    RDS error after installation

    PegasusT4 Community Member

      Just installed CF 10 beta on Win 7 32bit and Apache 2.2.22. No errors detected on install or startup. RDS  selected to run in Admin.

      Running files locally in FF, Deramweaver and CFB 2beta and everything looks like it is working fine.


      However, trying to connect to RDS is not working.


      In Dreamweaver 5.x, trying to connect gives the following..

      "The server name or address could not be resolved. Possible reasons:

           1. The URL specified for this site's testing may be incorrect.

           2. The testing server may be incorrectly configured. e.g. CF may not be running"

      CF files run fine inside and outside of DW. The URL is correct too.


      In CFB 2 beta, I also get an error in RDS Configuration when hitting the test button.

      'Unable to contact the RDS Server "localhost". This can be caused by incorrect configuration on either the client or the server.'

      Please verify your connection ... blah blah blah.

      The HTTP request to talk to your server returned with the following message: 'Could not initialize class com.adobe.rds.core.services.Messages'


      Localhost is set up as local port 80, selected CF+Tomcat.

      Document Root = c:\inetpub\wwwroot

      Server Home = c:\coldfusion10\cfusion


      I feel like I'm missing something, soI tried uninstalling CF10 and reinstalled CF9. Both DW and CFB correctly connected to RDS when I set it up. RDS Dataview and RDS Fileview both worked correctly. Uninstalling CF9 and reinstalling CF10 resulted in the same errors. RDS did not work.


      What am I missing?




        • 1. Re: RDS error after installation
          Shilpi Khariwal Adobe Employee

          Hi Pegasus,


          Can you please confirm if RDS service check box in enabled in Administrator -> Security -> RDS





          CF engineering Team

          • 2. Re: RDS error after installation
            PegasusT4 Community Member



            Yes, Enable RDS Service IS checked in admin.



            • 3. Re: RDS error after installation
              Shilpi Khariwal Adobe Employee



              I tried again with CF10 with and without apache connector. I get the mentioned error if RDS service is disabled, (on RDS screen in Administrator). If the service is enabled, with RDS username and password, it is working in both CFBuilder and component browser. Is there any stack trace or error you see in error logs?


              Try toggling the RDS Service button once more and see if it works. Also your CF server, JRE used and apache all 32 bit, or there is a difference?


              If the issue still persist, i request you to please file an issue in https://bugbase.adobe.com/. We will look into this.



              • 4. Re: RDS error after installation
                PegasusT4 Community Member

                Hi Shilpi,


                I tried toggling RDS services off, restarting CF, get the error.

                I then toggled RDS services on, restarted CF, still get the error.


                Clicking on RDS Dataview I still get 'Unable to contact the RDS Server "localhost." Could not initialize class com.adobe.rds.core.services.Messages.

                And in setting up RDS in CFB, I get the same error I listed in the first post.


                Everything I'm running is 32 bit on Win 7 32 bit.


                I looked at all the CF logs files in Debugging & Logging >Log Files and see no errors whatsoever. In eventgateway.log there is the message "Event Gateway Disabled", but that's it.



                • 5. Re: RDS error after installation
                  Shilpi Khariwal Adobe Employee

                  Hi Doug,


                  We are not able to repro in our installtion of standalone and plugin configuration. Can you please extract the RDS Core plugin(com.adobe.rds.core_*.jar) check for the class com.adobe.rds.core.services.Messages.class.


                  Also check the password in your RDS settings at ColdFusion Administrator and ColdFusion builder server configuration dialog.  You can reset your RDS password, using passwordReset script located at <cf-home>/bin. This will eleminate possiblity of any configuration errors.


                  Also check regstering the other remote server and try accessing the RDS for the same.




                  • 6. Re: RDS error after installation
                    PegasusT4 Community Member



                    I'm not a java programmer so you'll have to help me on this. I did a search on com.adobe.rds.core and came up with com.adobe.rds.core.prefs file in c:\users\username\adobe coldfusion builder workspace\.metadata\.plugins\.org.eclipse.core.runtime\.settings\ , but I found no .jar file anywhere using windows search.


                    Where should it be? And what should I use to view the class names?


                    I tried the passwordReset script and there were two choices: change Admin PW and change Admin Component(jetty) PW. I have no idea what the jetty server path is.



                    • 7. Re: RDS error after installation
                      Shilpi Khariwal Adobe Employee



                      In the CF builder installation directory, there will be plugins directory. In this there will be a file with .jar extension and name as com.adobe.rds.core_1.0.2.v20100601277104.jar. Note the numer after com.adobe.rds.core might be different.


                      Now you can open this file with Winrar. There look for directories in the mentioned order -


                      com -> adobe -> rds -> core -> services -> Message.class


                      If the above mentioned class is present in the jar, we are good



                      • 8. Re: RDS error after installation
                        PegasusT4 Community Member


                        Found the jar and Message.class was there. Size 1543 Date 6/1/2010, CRC 74676E7.


                        Don't forget I cannot run RDS in Dreamweaver CS5 either, so I don't think this is necessarily a CFBuilder problem.


                        The only errors I see in the CFB error.log are

                        Unable to find Action Set: com.adobe.ide.coldfusion.ui/ExternalToolsSet

                        Problems occurred when invoking code from plugin: "org.eclipse.jface"

                        And the usual com.aptana.xxx errors


                        Is there any way to see if RDS is actually running?



                        • 9. Re: RDS error after installation
                          Shilpi Khariwal Adobe Employee

                          You can check RDS by using the URL http://<yoursite>/CFIDE/componentutils/packagelist.cfm


                          This will ask for your RDS authentication. After entering username and password, see if the components list comes or not?



                          • 10. Re: RDS error after installation
                            PegasusT4 Community Member



                            I tried http://localhost/CFIDE/componentutils/packagelist.cfm and the list correctly came up.



                            • 11. Re: RDS error after installation
                              PegasusT4 Community Member

                              Here's a dump of the error log from CFB.


                              Problems occurred when invoking code from plug-in: "org.eclipse.jface".

                              at com.adobe.rds.core.eclipse.RDSServerManager.CheckAuthFailure(RDSServerManager.java:711)
                              at com.adobe.rds.core.eclipse.RDSServerManager.ExecuteCommandForByteArray(RDSServerManager.j ava:773)
                              at com.adobe.rds.core.eclipse.RDSServerManager.ExecuteCommand(RDSServerManager.java:621)
                              at com.adobe.rds.core.eclipse.RDSServerManager.ExecuteCommand(RDSServerManager.java:597)
                              at com.adobe.rds.dataview.views.DatabaseView_ECListener.treeExpanded(Unknown Source)
                              at org.eclipse.jface.viewers.AbstractTreeViewer$3.run(AbstractTreeViewer.java:1107)
                              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
                              at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
                              at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
                              at org.eclipse.jface.viewers.AbstractTreeViewer.fireTreeExpanded(AbstractTreeViewer.java:110 5)
                              at org.eclipse.jface.viewers.AbstractTreeViewer.handleTreeExpand(AbstractTreeViewer.java:148 7)
                              at org.eclipse.jface.viewers.TreeViewer.handleTreeExpand(TreeViewer.java:952)
                              at org.eclipse.jface.viewers.AbstractTreeViewer$4.treeExpanded(AbstractTreeViewer.java:1496)
                              at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:132)
                              at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
                              at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
                              at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
                              at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
                              at org.eclipse.swt.widgets.Tree.wmNotifyChild(Tree.java:7538)
                              at org.eclipse.swt.widgets.Control.wmNotify(Control.java:5534)
                              at org.eclipse.swt.widgets.Composite.wmNotify(Composite.java:1896)
                              at org.eclipse.swt.widgets.Control.WM_NOTIFY(Control.java:5086)
                              at org.eclipse.swt.widgets.Control.windowProc(Control.java:4584)
                              at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
                              at org.eclipse.swt.internal.win32.OS.CallWindowProcW(Native Method)
                              at org.eclipse.swt.internal.win32.OS.CallWindowProc(OS.java:2425)
                              at org.eclipse.swt.widgets.Tree.callWindowProc(Tree.java:1533)
                              at org.eclipse.swt.widgets.Tree.WM_LBUTTONDOWN(Tree.java:6411)
                              at org.eclipse.swt.widgets.Control.windowProc(Control.java:4564)
                              at org.eclipse.swt.widgets.Tree.windowProc(Tree.java:5937)
                              at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
                              at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
                              at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2531)
                              at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3752)
                              at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
                              at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
                              at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
                              at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
                              at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
                              at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
                              at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                              at com.adobe.ide.coldfusion.rcp.intro.Application.start(Unknown Source)
                              at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
                              at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)
                              at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)
                              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
                              at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
                              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                              at java.lang.reflect.Method.invoke(Method.java:597)
                              at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
                              at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
                              at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

                              • 12. Re: RDS error after installation
                                Shilpi Khariwal Adobe Employee



                                This is really helpful. This might be able to point us to somewhere logical. Can you please log an issue for this at https://www.bugbase.adobe.com


                                The stack trace is what is important here. We will look into this.


                                Thanks once again,


                                • 13. Re: RDS error after installation
                                  PegasusT4 Community Member



                                  I believe the problem was with virtual hosts in Apache. I have many virtual hosts and had added the line

                                  JkMountFile "cfroot\config\wsconfig\1\uriworkermap.properties"

                                  to all the entries except the one for localhost, which I apparently missed.


                                  Adding that line seems to fix the problem as RDS is now working in CFB and DW.



                                  • 14. Re: RDS error after installation
                                    Shilpi Khariwal Adobe Employee

                                    Thanks for confirming Doug.

                                    • 15. Re: RDS error after installation
                                      Giancarlo Gomez

                                      Thank you for posting that Doug!!!!!!


                                      I was about to go crazy and you supplied the answer .. also I am on a 24+ hour working binge so I think I may need to go to bed soon .. LOL.

                                      • 16. Re: RDS error after installation

                                        I have the same problem of PegasusT4, but my server is IIS7.

                                        Any idea?



                                        • 17. Re: RDS error after installation

                                          Awesome fix guys, got me out a hole there !!