0 Replies Latest reply: Feb 23, 2012 12:34 PM by Lone Jet RSS

    Unable to consume .Net web service in ColdFusion 8

    Lone Jet Community Member

      I have a .Net web service which appears to be working fine. I generates a WSDL and I can successfully test it locally.

       

      I am using the basic code below in CF to consume the service:

       

      <cfinvoke method="getBannerViews" returnvariable="getBannerViews" webservice="http://www.xzxxxxxxxxx.org/ws/bannerAdViews.asmx?WSDL" refreshwsdl="true">

       

      Problem is, I am getting this very long error when I run my CF page:

       

      The fault returned when invoking the web service operation is:<br> <pre>AxisFault faultCode: {http://www.w3.org/2003/05/soap-envelope}Receiver faultSubcode: faultString: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---&gt; System.NullReferenceException: Object reference not set to an instance of an object. at Banner_Ad_Manager.bannerAdViews.getBannerViews() --- End of inner exception stack trace --- faultActor: faultNode: faultDetail: {http://xml.apache.org/axis/}stackTraceystem.Web.Services.Protocols.SoapException: Server was unable to process request. ---&gt; System.NullReferenceException: Object reference not set to an instance of an object. at Banner_Ad_Manager.bannerAdViews.getBannerViews() --- End of inner exception stack trace --- at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:221) at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:128) at org.apache.axis.encoding.DeserializationContext.endElement(DeserializationContext.java:10 87) at org.ap... ''</pre>

       

      What am I doing wrong?