22 Replies Latest reply on Mar 10, 2012 12:35 PM by greenman8268 Branched from an earlier discussion.

    Re: help light room 3


      I'm getting the same error, but the numbers are a little different.  Adobe chat has been no help.  In fact, they created additional problems for me.


      LR3 Failed Install print screen.jpg

        • 1. Re: help light room 3

          hi all.

          i have been told by the adobe customer help that .

          ERROR1937 can be caused by conflict with..netframework

          they say i may need to reload .net framework 3.5 sp1                           QUOTE.

          if you are getting error 1935 while reinstaling .net framework 3.5 spi .i would request you to contact microsoft for further support ,as adobe uses these components for instaling the product.

          they supply a link that explains in full how to go through the process .

          it includes modifuing the registry,and ads

          a disclaimer this procedure involves modifying the windows registry .

          adobe doesnot provide support for problems caused by improperly modifying the registry.

          [so unquote] try this and you are on your own.

          i have had no problem with PS5 istalled only a couple of months ago so why am i getting grief now?

          regards bernard.

          • 2. Re: help light room 3
            F. McLion Adobe Community Professional & MVP

            Did you try to remove and reinstall the .net framework?

            • 3. Re: help light room 3
              BlueGrassPhotog Level 1

              Adobe is supposed to get back to me on my Error 1935 issue, but who knows when that will be.


              I did find some information on Intuit's TurboTax website which I may try when I return from the weekend.


              Here's the link to their instructions:


              http://turbotax.intuit.com/support/iq/Install-Product/Error-1935--An-error-occurred-during -the-installation-of-assembly/SLN12416.html


              If that doesn't work, just google error1935 turbotax.

              • 4. Re: help light room 3
                greenman8268 Level 1

                not yet.

                i have 6 downloads of .net all showing the same update date in the registry,

                not being a tart i keep looking at the warnings about moding the registry,

                i paid good money for the software and expect it to work without a load of

                fafing about.

                • 5. Re: help light room 3
                  BlueGrassPhotog Level 1

                  Any luck with LR3 Installation, yet?


                  Adobe has gone "dark," on me.

                  • 6. Re: help light room 3
                    greenman8268 Level 1

                    hi eric no luck so far.

                    i have been given a link to info similar to yours .

                    the issue seems to be about scraps of orphan files causing the error code.


                    i have tried using [netfix] and[1935 fix] to no result i get so far in the loading and it stops and rolls back i don't profess to be a tech so try not to make things worse. if it aint broke don't

                    try to fix it.as i have said before i paid good money for the goods and do not see why i need to pay for someone to install the software ,it is supposed to work first time

                    i had no problem with PS5 only a week or so before i purchased light room.

                    PS5 works fine.

                    regards bernard

                    • 7. Re: help light room 3
                      Jeri H Adobe Employee

                      Eric, I found your post and moved it to the Downloading, Installing, and Setting up forum.

                      • 8. Re: help light room 3
                        Gautham K Level 4

                        Hi Greenman8268 & Eric29466926,


                        Have you tried the steps mentioned in this document: Error 1935 | Assembly Component?


                        This document has multiple solutions in case reinstalling the .net framework doesn't work.


                        Please respond to this post if none of the solutions recommend in the document help resolve the issue.



                        • 9. Re: help light room 3
                          BlueGrassPhotog Level 1

                          Hi Gautham,


                          Yes, I've tried all those with the same result.  I want to point out that the assembly component is different, as reported by Windows Event Viewer, "Microsoft.VC90.MFCLOC."  I don't know if that makes any difference or not.


                          I have installed two other software packages successfully, and I am experiencing no other problems with Adobe or other products.


                          Thank you for responding.

                          • 10. Re: help light room 3
                            Gautham K Level 4

                            Hi Eric29466926,


                            The one step I would recommend is creating a new account with administrative rights and trying to install the product in that account.


                            The HRESULT error code shown could directly relate to a permissions issue with the Windows installation folders.


                            Also, are you running Windows Vista or 7?


                            In case the new admin account does not resolve the issue, I would require time to research further as you seem to have performed most of the listed troubleshooting steps.

                            • 11. Re: help light room 3
                              BlueGrassPhotog Level 1



                              I tried the new administrator account suggestion, which Adobe chat "guaranteed," to be the right resolution, but received the same error after restarting my system, logging into the new account, and attempting the LR3 install.


                              Sorry, I don't have/know the HRESULT error code because I was not aware, nor was I instructed/asked about that code by Adobe chat tech reps.


                              I am running Vista, and I was just about to tell you that all updates have been applied, but I started Windows Update to confirm, and found (4) Security updates for .NET Framework 4, (3) Other Updates to .NET Framework 4, and (1) update to .NET Framework 3.5 SP1.


                              I'll install those updates, restart my system and try the LR3 Install.


                              If there is something else you want me to try, or if you want me to login, again, under the new administrator account and try the install again, for the purpose of obtaining some helpful error codes, please let me know.


                              Thank you for your assistance.

                              • 12. Re: help light room 3
                                Gautham K Level 4

                                Hi Eric,


                                Error 1935 could be a result of many factors, specially the components of the operating system.


                                Please install the pending Windows updates and then try installing in a new administrator account.


                                Let me know if that doesn't work.


                                The HRESULT error code shows in the screenshot you have posted in the initial post. Hence you don't have to reinstall to obtain the error codes.



                                • 13. Re: help light room 3
                                  BlueGrassPhotog Level 1



                                  I tried as you suggested, in fact I tried twice, now a total of three times in creating a new admin account, but I am still getting the same error.


                                  Just for ha-ha's, I decided to download an older version 2.4, and guess what?  It installed successfully.  I'm not going to try anything else but I hope that minor success may provide a clue as to what is happeneing with LR3.


                                  Thanks for your assistance, Gautham.



                                  • 14. Re: help light room 3
                                    BlueGrassPhotog Level 1

                                    Hi Greenman,


                                    I still have the same install problem with LR3, but I downloaded an older version, 2.4, and installed it successfully.  I'm hoping that provides a clue to our problem.  Have you tried installing an older version?



                                    • 15. Re: help light room 3
                                      Gautham K Level 4

                                      Hi Eric,


                                      I have sent you a private message requesting for information.


                                      Please reply with the details.



                                      • 16. Re: help light room 3
                                        BlueGrassPhotog Level 1

                                        Hi Gautham,


                                        After a very long day of frustration in front of the computer, I am happy to report that LR3 has been installed and appears to be functioning properly.  I was starting to lose hope, but after researching the issues over and over, I decided to follow the instructions on Aaron Stebner's web page.  http://blogs.msdn.com/b/astebner/archive/2006/09/04/solving-setup-errors-by-using-the-subi nacl-tool-to-repair-file-and-registry-permissions.aspx 


                                        Before I ran SubInAcl, however, I decided to run the System Readiness Tool for Vista,  http://support.microsoft.com/kb/947821  which verifies the integrity of some of the resources, not necessarily "permissions" related, but I knew it would not hurt to run, and it could correct some other inconsistencies.


                                        I then ran SubInAcl as instructed, and installed LR3 successfully.  I want to remind you that this is the program that I was instructed to run by Adobe chat, but not as specifically instructed on Aaron's web page, which caused my Vista license to become invalid.  I sincerely hope that this resolution will become part of the problem resolution steps offered by first-level Adobe Chat support.  Adobe will save a lot of people a lot of time, hopefully, if this works for others as well as it has worked for me, but Adobe must provide this information at the initial level of support.  The LR3 install problem was, most certainly, related to "permissions," as you had mentioned, previously.  And, as I watched Bobby attempt to resolve the problem, I could see he was consistently denied access to many folders.


                                        I want to thank you and Bobby Johnson for trying to resolve my issue, even though the problem was related to Vista, and not to LR3.  Without your help, I would have not had a clue on which direction to go in seeking a resolution.


                                        I just have one last inquiry.  Bobby had uninstalled MS Visual c++ 2008 Redistributable, and was going to re-install, until he started to run into more "permissions," problems.  If LR3 is functioning, is there a reason I that I need to re-install Visual c++ 2008?


                                        Thank you, so much, for all you help, Gautham.



                                        • 17. Re: help light room 3
                                          BlueGrassPhotog Level 1

                                          Hi Greenman,


                                          I wanted to make sure you were aware of the resolution which resolved my LR3 Install problem.  If you look farther down the thread, you'll see my comments to Gautham.  Let me know if you have any questions, and if it resolves your problem.





                                          • 18. Re: help light room 3
                                            Gautham K Level 4

                                            Hi Eric,


                                            Glad to know that the issue has been fixed.


                                            I would recommend running a Windows update which should reinstall the Visual c++ 2008 pack which is the updated version for Windows Vista.


                                            You computer currently has Visual c++ 2005 deployed.

                                            • 19. Re: help light room 3
                                              BlueGrassPhotog Level 1

                                              Hi Gautham,


                                              I still have the trial version 2.4 installed; would you recommend that I remove it?  I'm being very tenuous about doing anything, but my system seems to be functioning normally.


                                              Thank you.



                                              • 20. Re: help light room 3
                                                Gautham K Level 4

                                                Hi Eric,


                                                Uninstalling the trial version of LR 2.4 should not cause any issues with the functioning of LR 3.


                                                I would recommend backing up your catalog in case you have not done so already : File Locations|Lightroom 2.x

                                                • 21. Re: help light room 3
                                                  BlueGrassPhotog Level 1

                                                  Hi Gautham,


                                                  Thank you for your quick response, and all your assistance.



                                                  • 22. Re: help light room 3
                                                    greenman8268 Level 1

                                                    hi eric.

                                                    not yet but i will.

                                                    will i be charged for this service ?

                                                    i tried administrator privilage install.

                                                    i tried a seperate account.install.

                                                    i have updated rked fine.to the moste resent version of win 7

                                                    i have uninstalled earlier versions of photoshop just in case there was any conflict.[even though they worked fine]

                                                    but i still get the 1935 error and a rollback.

                                                    i am prepared to try an earlier version just to get it up and running and maybe i can upgrade to LR3?

                                                    or just give it a miss and dump the adobe setup.

                                                    thankyou for your respons.