1 2 3 Previous Next 110 Replies Latest reply: Jun 27, 2012 3:22 AM by bacma RSS

    Photos won't display in Parent folders or All Photographs

    zdybkela Community Member

      After upgrading to LR4 from LR3 when I go to the library and click on "All photographs" none of my 86000 photos show up.

       

      The same thing happens in folders module....for example:

       

      1. My photos are in folders titled 20120306

                                                      20120201

      2. Those folders are siored in a single "parent" folder called 2012

      3. All the "parent" year folders are in a folder called MAIN

       

      When I click on main it does not display any photos but it tells me how many photos are in the folder

      When I click on 2012 it does not display any photos but it tells me how many photos are in the folder

      When I click on 20120306 it then dislays the photos.

       

      I am not sure why clicking on 2012 it would not show me ALL of the photos taken in 2012, that is what LR3 did......

       

      PLEASE help as I am very puzzled by this!

      Kevin

        • 1. Re: Photos won't display in Parent folders or All Photographs
          Gregg Mack Community Member

          I don't yet have Lightroom 4 installed, but I know how to get Lightroom 3 in and out of the mode you are now in.

          Be in the Library module and select your MAIN folder in the Folders panel.  Go to the Library menu and choose

          "Show Photos in Subfolders" to toggle that option on and off. I suspect right now it is turned off on our system.

          • 2. Re: Photos won't display in Parent folders or All Photographs
            zdybkela Community Member

            That is what I originally thought it might be but when I do that nothing changes.......

            • 3. Re: Photos won't display in Parent folders or All Photographs
              selphs03

              I had the same problem. All I did was optimize catalog, restart lightroom and then restart the computer. After that all of the images come back in the main folder and are visible. Hope that helps.

              • 4. Re: Photos won't display in Parent folders or All Photographs
                chholmes57 Community Member

                I have the same issue.  The All Photographs collection under Catalog shows the message "Click the Import... button to begin", although the numerical value of total images is there.  I tried re-optimizing, and restarting, but this did not work for me.  When I first upgraded, some of my other top level folders (2011, 2012, etc) showed a message "no photos in selected folder", but this seems to have resolved itself.

                • 5. Re: Photos won't display in Parent folders or All Photographs
                  gryphon1911 Community Member

                  I too am having this same issue.   I tried what selps03 recommended and still nothing.

                   

                  Also, the main foilder that holds the physical files does not display what is in the sub folders.  If I go to each individual folder, it will show the data.   The "All Photographs" selection in the catalog shows the 29,000 number, which is correct, but does not show me the previews.

                   

                  The other odd thing is that if I type in a keyword in the text filter box, I get image previews to display.

                  • 6. Re: Photos won't display in Parent folders or All Photographs
                    selphs03 Community Member

                    Well, I had the problem fixed, but now it's back. It won't show me the previews for the images in the "All Photographs" section. If I go down and click on the actual folders, it will show the images. Anyone have any idea what's going on?

                    • 7. Re: Photos won't display in Parent folders or All Photographs
                      gryphon1911 Community Member

                      I got a solution, but do not know if it is optimal.

                       

                      There seems to be a bug in the upgrade function.  If you let the Lightroom install do the catalog upgrade, no previews.

                       

                      I went in, created a new catalog - then did LIBRARY --> Import from catalog...   and that seems to have worked.

                       

                      Took quite a few minutes to get the 29000+ files moved over, but better than losing the catalog all together and having to rebuild it all.

                      • 8. Re: Photos won't display in Parent folders or All Photographs
                        zdybkela Community Member

                        I tried optimizing and rebooting and STILL have the same problem! I have 86,075 in the numerical value under "All photographs" and no photos show up, only "Click the Import... button to begin"

                         

                        HELP!!

                        • 9. Re: Photos won't display in Parent folders or All Photographs
                          lancerogers Community Member

                          I'm trying the import from previous catalog approach, after 8 hours now, I'm at 15k of 45k photos....It would be really nice to know what the issue is and whether there is a workaround that does not take hours to complete.  I have a very recent computer, i2700k, 16gb ram, plenty of disk space, nothing else running.  My photos are on multiple drives

                          • 10. Re: Photos won't display in Parent folders or All Photographs
                            zdybkela Community Member

                            If you reimport I would assume that you lose all of your metadata.....keywords, flags, applied develop settings, etc.

                             

                            I am on the phone with Adobe right now.......

                            • 11. Re: Photos won't display in Parent folders or All Photographs
                              lancerogers Community Member

                              I cancelled the reimport, deleted the catalogs.  Went back to open a new catalog from the old catalog.  The conversion takes place.  New catalog is slightly larger.  I tried re optimizing, but still left with "Click the import... button to begin".  So, I'm back at no usable catalog.  Please update with what you hear from Adobe.  I may have to call as well.

                               

                              Update, I spent two hours on Chat with Adobe, let them take over driving, still same issue.  Final step before escalating to next level is they started the import from the old catalog again, so I'm back to waiting for that to finish.

                              • 12. Re: Photos won't display in Parent folders or All Photographs
                                zdybkela Community Member

                                I was on the phone from 8am (5am pacific) when Adobe opened until 12:15 and wanted to update this post with what I found out.

                                 

                                I have a case number and it is now escalated to an engineer as we have tried everything to resolve the issue. I did notice that when openeing a smaller catalog the issue does not seem to surface. My main catalog is over 86,000 images and NONE of the images show up in the library module when viewing All Photographs. It seems as the size of my catalog is where the engineers will be talking a look at. The 86,000 images worked perfectly fine in LR3.

                                 

                                Does any one else have a large catalog? If anyone else has this problem can you post the size of your catalog.

                                 

                                This is now a KNOWN bug in LR4.

                                • 13. Re: Photos won't display in Parent folders or All Photographs
                                  chholmes57 Community Member

                                  Same problem.  I'm at just over 88,000 images.

                                  • 14. Re: Photos won't display in Parent folders or All Photographs
                                    richardondrovic

                                    Same problem, 108,434 images. Any parent folder whose child folders have in excess of roughly 1100 total images exhibits that problem for me.

                                    • 15. Re: Photos won't display in Parent folders or All Photographs
                                      lancerogers Community Member

                                      Same problem here but I'm only at 45k images.  Adobe wanted me to import, but the import from catalog was taking way too long.  I am currently exporting my current catalog in smaller chunks.  I'm trying one at 5k and the second at 40k.  Once the export finishes, I will try and import from catalog on both of these.

                                      • 16. Re: Photos won't display in Parent folders or All Photographs
                                        richardondrovic Community Member

                                        It isn't just a parent/children issue, I can multi-select any combination of folders and when the total number of images in the multi-selection exceeds roughly 1100 the "no photos in selected folder" problem occurs. If I de-select any folder to reduce the total number of images in the multi-selection, the message goes away and the images reappear in the browser.

                                        • 17. Re: Photos won't display in Parent folders or All Photographs
                                          BirderFrank

                                          I too had problem this morning with 73,000 photos. I use the 'All Photos" selection all the time especially when filtering. Reading these posts I started from scratch with a new catalog and an import from my last LR3 catalog. Yes, it took 6 hours, and YES IT IS FIXED. So, just do it. I was working on my PC doing spreadsheets, internet, e-mail etc the whole while, suffering through the mollases. But, everything is so sluggish, I think I'll still be running LR3 until the first LR4 update. Very dissapointing that the prerease testing did not elucidate fixes for these issues. But we need to betatest so that the CS6 release fares better!

                                          • 18. Re: Photos won't display in Parent folders or All Photographs
                                            RainerBri

                                            I have the same Problem on my Side. I have 110.000 Images. In LR3 was this no Problem. Only now in LR4.

                                            • 19. Re: Photos won't display in Parent folders or All Photographs
                                              web-weaver Community Member

                                              What happens if - in the Library Module - you go >Library and check <Show photos in subfolders>?

                                              Does that not show the photos in the parent folder? It did in Lr4 beta.

                                               

                                              This item is worded confusingly. It should read: "Show photos that are in subfolders also in the parent folder."

                                              WW

                                              • 20. Re: Photos won't display in Parent folders or All Photographs
                                                zdybkela Community Member

                                                BirderFrank,

                                                WHat about all of your flags, stars, develop settings? Are you able to get this information back?

                                                 

                                                I will post any information that I get when the engineer from Adobe calls me back. He told me possibly within 24 hours. I will let everyone know as soon as I know!!

                                                 

                                                Kevin

                                                • 21. Re: Photos won't display in Parent folders or All Photographs
                                                  lancerogers Community Member

                                                  Web-Weaver, checking "Show photos in subfolders" does not solve the issue. 

                                                   

                                                  Birder Frank, glad it worked for you.  I left my running all last night and only made it through 15k images. I canceled it this morning and called Adobe.  They started me doing in import from catalog again, but I canceled that as well.  I am currently exporting my current catalog in smaller chunks to see if that will resolve the issue.  First export 5800 images ran just fine.  Exporting the rest 39k went to 80% complete and then crashed LR3.  I'm now splitting up the remaining 39k into < 10k chunks, exporting those.  I'll reply again once I get exported.

                                                  • 22. Re: Photos won't display in Parent folders or All Photographs
                                                    BirderFrank Community Member

                                                    Exactly what I did. I ran a test with 2 small folders and A Files worked so I gave it a go. The sluggishness I have not solved though.

                                                    • 23. Re: Photos won't display in Parent folders or All Photographs
                                                      BirderFrank Community Member

                                                      Everything was there....flags, presets, key words, and collections.

                                                      • 24. Re: Photos won't display in Parent folders or All Photographs
                                                        gryphon1911 Community Member

                                                        It took my 29,044 catalog of images roughly 25 minutes to process through.

                                                         

                                                        I'm running an Intel i7 2.5Ghz, 12MB RAM and the catalog is located on the internal HDD serial ATA 1TB, Windows 7 64-bit.

                                                         

                                                        Is everyone doing the minimal preview?  Doing anything beyond that not only increases the size of the catalog, but also requires more processing time during the import.

                                                         

                                                        Getting machine specs might help us find a common thread to all this.

                                                        • 25. Re: Photos won't display in Parent folders or All Photographs
                                                          BirderFrank Community Member

                                                          That worked for everything BUT the All Photos top level selection.

                                                          • 26. Re: Photos won't display in Parent folders or All Photographs
                                                            lancerogers Community Member

                                                            I'm running 3.3ghz i7 2700k, 16gb of ram. 8900 images on internal HDD, ~37k images on external drive.  By attempting to export first, I'm hoping to bypass the preview issue as it should use the previews that are there already, there is no option to render previews on import from catalog that I am aware of.  My export of the 8900 images just went to 85% and crashed lightroom.  I have shut down machine, rebooted, optimized the catalog and attempting export again.

                                                             

                                                             

                                                            Edit: So, I had to reduce my export to ~5100 images to get it to complete.  When it finished, it presented an error window indicating it could not find/did not have previews for all the images.  Seems kind of odd to me as I can see them all.  I'm exporting another image file of ~3k images next.  Then I will try and import them.

                                                             

                                                            It's gonna be real ugly if I have to regenerate 45k previews again.

                                                             

                                                            Edit again: Ok, this is not going to work.  The Export Catalog actually copies everything from the current drive to the backup location, the catalog and the images etc.  Upon import, the files are not imported from their locations, but rather the images just backed up in the export are what is imported.

                                                             

                                                            I'm going to move all my images to one primary drive.  Try regenerating all previews and see if I can import from the LR3 catalog again and get it to complete.  What a nightmare this is.

                                                            • 27. Re: Photos won't display in Parent folders or All Photographs
                                                              richardondrovic Community Member

                                                              Everything (including displaying all photos by selecting the root folder) is now working correctly for me. Here is what I did:

                                                               

                                                              1) Told LR4 to create a new catalog

                                                               

                                                              2) Opened the new catalog in LR4

                                                               

                                                              3) File... Import from another catalog...

                                                               

                                                              4) Pointed the import to a copy of my (non-converted) LR3 catalog

                                                               

                                                              5) LR4 first converted the LR3 catalog to a temp LR4 catalog and then did the import

                                                               

                                                              6) Total time to import 108,423 images (on a NAS box) was about 1.75 hours

                                                               

                                                              7) At the end of the import process, LR4 threw an error message about an error importing the catalog. I dismissed the message and all appears to be fine. Everything works and all of my keywords etc are where they should be.

                                                               

                                                              8) YMMV, but this is definitely worth a try for you guys.

                                                              • 28. Re: Photos won't display in Parent folders or All Photographs
                                                                richardondrovic Community Member

                                                                I just discovered that, as an added bonus, my *entire* catalog reverse-geocoded during the import!

                                                                • 30. Re: Photos won't display in Parent folders or All Photographs
                                                                  Cristian Samoila Community Member

                                                                  There is a possible solution if nothing else works. In the old LR3 catalog select all the photos and write the metadata to files. Then reimport in a new LR4 catalog. There is the issue that you lose the history of edits but the files are imported. As far as I experienced, sometimes the catalogs become slightly corrupted and start to behave very strange but only when certain conditions are met.

                                                                   

                                                                  Since LR4 beta went public, I think that I made the most extensive import tests on huge folders and only had problems after going over 200000 files (1.5 TB of mixed photo and video files with metadata written to files or as sidecar). In one go, LR4 imports 200000 files from my dataset in about 4h30min without issues. If you go over 210000 files the performance decreases very fast. For 225000 files it takes at least 10h if LR manages not to crash. And it never arrived at 230000 in one go.

                                                                   

                                                                  IMPORTANT: Be aware that on large imports LR consumes lots of temporary disk space. For the 220000 files import, I need around 70GB free space. That space is freed after the import is complete and LR is restarted. If you don't have enough space LR may crash without warning about low space.

                                                                   

                                                                  My config: Intel Core i7 740QM, 8 GB DDR3, 500 GB internal drive, multiple 2 TB external drives.

                                                                  • 31. Re: Photos won't display in Parent folders or All Photographs
                                                                    dj_paige Community Member

                                                                    Cristian Samoila wrote:

                                                                     

                                                                    There is a possible solution if nothing else works. In the old LR3 catalog select all the photos and write the metadata to files. Then reimport in a new LR4 catalog. There is the issue that you lose the history of edits but the files are imported. As far as I experienced, sometimes the catalogs become slightly corrupted and start to behave very strange but only when certain conditions are met.

                                                                    This really isn't a solution. The problem is NOT that the new LR4 catalog that was created by converting the LR3 doesn't have the right photos. It does have the right photos!

                                                                     

                                                                    The problem is that there is a bug in the way LR4 displays the photos in certain instances. Creating a new catalog by importing (in addition to the huge number of disadvantages that re-importing has) does nothing to eliminate the bug, and of course the same bug could affect the new LR4 catalog you spent so much time importing photos into.

                                                                    • 32. Re: Photos won't display in Parent folders or All Photographs
                                                                      JimmysPhoto Community Member

                                                                      gryphon1911's posted process worked for me.  And FYI: I have 188,659 files and it took almost exactly 3-hours to complete.

                                                                      • 33. Re: Photos won't display in Parent folders or All Photographs
                                                                        idogu

                                                                        Same issue here with 94'400 pictures. Issue though not with all subfolders. Assume it was based on a certain number of pictures in the (sub)folder.

                                                                         

                                                                        Issue resolved:

                                                                        > Created a new catalogue in LR4

                                                                        > Importing the old LR3 catalogue

                                                                        > Took estimated 40mins for 94k pictures

                                                                        > Ignored the error warning after import was finalized

                                                                        > seems as if everthing is perfectly fine, incl. all stars, tags, and other metadata not previously saved to pictures

                                                                        > I will keep both, old LR3 and upgraded LR4 catalogues as backup (you never know)

                                                                         

                                                                        Good look and have fun with LR4

                                                                        • 34. Re: Photos won't display in Parent folders or All Photographs
                                                                          lancerogers Community Member

                                                                          Jimmy, did you have any indication of progress for this step?  I'm trying this step and the only progress I can see is the photo count jumped to 500, then made its way to 3500 and now it just seems stalled out.  I don't want to cancel, but it does not appear to be doing anything at all.  The other thing I see is that it is not creating previews/copying previews and updating them.  It looks to me like it started and then stopped almost immediately.

                                                                          • 35. Re: Photos won't display in Parent folders or All Photographs
                                                                            Dannypo

                                                                            Hi

                                                                            I have a catalogue with 118000 and another one with 38000 and both work ok. I converted a third catalogue with just over 9000 and here the main directory and All Photographs display the correct count but no pictures

                                                                            • 36. Re: Photos won't display in Parent folders or All Photographs
                                                                              JimmysPhoto Community Member

                                                                              I had a   v e r y  s l o w  progress bar the entire time- and just as gryphon noted above, there was an "unknown error occurred" error at the end without any consequence.

                                                                              • 37. Re: Photos won't display in Parent folders or All Photographs
                                                                                jgiraud

                                                                                I have the same issue with about 120k pictures. I was able to create a new catalog and reimport the LR3 catalog but I lost all my publishing service setups and galleries which is unacceptable. How can Adobe not test this, this is not an isolated incident by the looks of things.

                                                                                 

                                                                                I did try to recreate the standard size previews and it appeared to work for a few folders but not others.

                                                                                 

                                                                                I also received the catalog conversion error at the end of the import but it didn't seem to impact anything.

                                                                                • 38. Re: Photos won't display in Parent folders or All Photographs
                                                                                  Vittoria Coffee Community Member

                                                                                  I also have had the problem and to take it further I have found that for me it is the number of Thumbs (Including VIrtual Photos) in the sub directory.

                                                                                   

                                                                                  The magic number for me is 3418,

                                                                                   

                                                                                  With 3417 thumbs total in the subdirectories then they dispay in the parent folder but as soon as I go to 3418 thumbs in the sudirectories all thumbs in the parent folder dissappear.

                                                                                   

                                                                                  Hope we get a fix soon this is sending me balmy.

                                                                                   

                                                                                  I do not want to loose all of my collections and virtual photos let alon my edit history.

                                                                                   

                                                                                  I will stick with LR3 till it is solved I think

                                                                                  • 39. Re: Photos won't display in Parent folders or All Photographs
                                                                                    Vittoria Coffee Community Member

                                                                                    Have Just got the result I want with a work around that I think someone else has suggested.

                                                                                     

                                                                                    Let lr4 upgrade the lr3 catalog as per normal.

                                                                                     

                                                                                    Then in lr4 create new catalog.

                                                                                     

                                                                                    Then choose to import photos from existing catalogue with: FILE/Import from another catalog....

                                                                                     

                                                                                    Choose the newly creat lr4 catalog from the previously upgrade LR4 catalogue.

                                                                                     

                                                                                    Everything appears to be as it should be.

                                                                                    1 2 3 Previous Next