11 Replies Latest reply: Feb 20, 2013 1:44 PM by CapitanKat RSS

    Cannot Search by Metadata in Filter Bar (LR4)

    dj_paige Community Member

      This is upsetting. I try to use the Filter Bar in LR4 to search by metadata, and I keep getting "No Photos Match The Filter", even though the Filter Bar is telling me that 108 photos match the filter.

       

      Please note I have All Photographs selected, and the Filter Bar says 108 photos match "Buffalo Zoo", but there are 0 file types (!!!!), 0 lenses (!!!!) and 0 cameras available in this search. How can that be? How do I get this search to work?

      lr4_metadata_search.gif

        • 1. Re: Cannot Search by Metadata in Filter Bar (LR4)
          Lee Jay Community Member

          Try exiting LR and restarting.

          • 2. Re: Cannot Search by Metadata in Filter Bar (LR4)
            dj_paige Community Member

            I did that (twice) before I posted my question. It doesn't help.

             

            By the way, if I click on a Collection, LR4 shows me the right photos. If I click on a Publish Service, I get no pictures. If I click on the arrow to the right of a keyword in the Keyword List panel, I get the same results as described above. Filter Bar fails, as shown.

            • 3. Re: Cannot Search by Metadata in Filter Bar (LR4)
              dj_paige Community Member

              Perhaps there is an interaction with the Map Module, which I was looking at just before I started doing these searches. So, I went back into the Map Module, clicked around, then back to the Library Module, and the problem with the Filter Bar is gone. Not really sure what I did in the Map Module, or how that could make a difference to the Filter Bar ... so we'll leave this as a mystery for right now, and maybe something to think about. I'm going to sleep.

              • 4. Re: Cannot Search by Metadata in Filter Bar (LR4)
                Lee Jay Community Member

                dj_paige wrote:

                 

                Perhaps there is an interaction with the Map Module, which I was looking at just before I started doing these searches. So, I went back into the Map Module, clicked around, then back to the Library Module, and the problem with the Filter Bar is gone. Not really sure what I did in the Map Module, or how that could make a difference to the Filter Bar ... so we'll leave this as a mystery for right now, and maybe something to think about. I'm going to sleep.

                 

                I've seen this before, but never in a repeatable way.

                • 5. Re: Cannot Search by Metadata in Filter Bar (LR4)
                  cjs007 Community Member

                  Yep. I was hit with this too. I came to the forum, found this thread, played with the Map Module and now it's fixed (but I've no idea why).

                  • 6. Re: Cannot Search by Metadata in Filter Bar (LR4)
                    dj_paige Community Member

                    I'm guessing, so please don't say I have the answer ...

                     

                    I think perhaps a "filter" got set in the Map Module somehow, and when you go back to the Library Module, this map "filter" remains in effect and isn't removed by the usual Ctrl-L.

                     

                    But who knows...

                    • 7. Re: Cannot Search by Metadata in Filter Bar (LR4)
                      nxf2

                      I too have this problem and I too can get the filter to work by opening the map module then returning to the Library. I think dj_paige is correct with the "sticking filter" as I can repeat the problem by;

                       

                      - Enter map module,

                      - Right click on the filmstrip and selecting All Photographs

                      - Click Visible On Map on the Location Filter at the top of the page

                      - Enter Library module, and select Library Filter

                      - Right click on the filmstrip and select any folder.........the Metadata now does not work,

                       

                      - Enter Map module again and notice the Location Filter is now set to None and the metadata filter will work in the library module

                       

                      I hope this may aid Adobe in fixing the problem?

                      • 8. Re: Cannot Search by Metadata in Filter Bar (LR4)
                        dj_paige Community Member

                        Great work, nxf2 (I love your handle too)

                         

                        Please clarify one thing ... did you do this in LR4.0, or LR4.1RC, or both?

                        • 9. Re: Cannot Search by Metadata in Filter Bar (LR4)
                          nxf2 Community Member

                          dj.... I used LR4.0

                          Sometimes I get the beta/release candidates but ever since LR had the big problem with one of their releases a while ago I have been more nervous and usually wait until the full update is posted.

                           

                          This does not mean I am not a supporter of RC.....as my ideas on big companies using the public to test their products has changed slightly over the years. I now accept that it is impossible for the likes of Adobe to write software and test it on every combination of hardware available globally. So I am now a supporter of  RC.....and like the fact that the public are given the chance to help.

                           

                          (But if you are listening Adobe...please don't get complacent!!)

                          • 10. Re: Cannot Search by Metadata in Filter Bar (LR4)
                            nxf2 Community Member

                            I have now upgraded to RC1 and I still get the problem

                            • 11. Re: Cannot Search by Metadata in Filter Bar (LR4)
                              CapitanKat

                              Here's how I got it back...had same issue in LR 4 today, found this post online, and couldn't get it back, then finally...

                               

                              Library > Find...

                               

                              It pulled up the search box along with my missing filter bar at the tops.

                               

                              Hope this helps.