10 Replies Latest reply: Mar 19, 2012 9:28 AM by rarewolf RSS

    Lr4 not importing raw (RW2)

    rarewolf Community Member

      I've upgraded from Lr3, which was configured for importing raw & jpg, and keeping them independent.  I've installed Lr4, and imported/upgraded that Lr3 library, but the Lr4 import ignores the raw files.  I don't know if it's because it cannot read the Panasonic G3 raw format (RW2), or if I've configured something wrong, or if it's a bug(?)  Please advise ...

       

      Edit:  I was successful with importing the raw files to the same location with Lr3, and Lr4 does sync these RW2 files, so it's not a problem with reading the raw data ... but seemingly something to do with configuring the import ... but I cannot find where to enable importing the raw.  Lr4 was/is configured for enabling "Treat JPEG next to raw files as separate photos".

       

      Mac OS 10.7

       

      TIA & Cheerios from the Avalon Peninsula 

       

      Message was edited for clarification by: rarewolf

        • 1. Re: Lr4 not importing raw (RW2)
          ssprengel CommunityMVP

          Could you verify your settings:  LR4: Edit / Preferences / General / Import Options:  Treat JPEG files next to raw files as separate photos.  This should be enabled to have it function the same as LR3, then report back.  You also might try importing a RW2 file that does not have a corresponding JPG next to it and see what happens.

          • 2. Re: Lr4 not importing raw (RW2)
            rarewolf Community Member

            Thanks for your response!  I was able to verify the settings and your suggestion -- see the "edit' in the primary post.  I also copied a rw2 to an independent directory on my harddrive, and Lr4 did recognize the file as a duplicate.  So, it does appear that Lr4  will recognize and import Rw2, but that I seem to have a possible problem with importing from the SD card in the SD reader port of my Macbook Air.  Anyone seen this problem before?  Lr3 doesn't have the problem, but Lr4 does ... strange!

            • 3. Re: Lr4 not importing raw (RW2)
              ssprengel CommunityMVP

              Do you have a global filter that is restricting RW2 files from being viewed?  File Type is one of the Metadata filter possibilities so it could be set.  Try importing a NEW RW2 w/o a JPG and see what happens.  Also, try importing from your internal hard-drive, to narrow down if the source is part of the issue.

              • 4. Re: Lr4 not importing raw (RW2)
                rarewolf Community Member

                ssprengel wrote:

                 

                Do you have a global filter that is restricting RW2 files from being viewed?  File Type is one of the Metadata filter possibilities so it could be set.  Try importing a NEW RW2 w/o a JPG and see what happens.  Also, try importing from your internal hard-drive, to narrow down if the source is part of the issue.

                I'm not sure how a global filter would affect Lr4 and not Lr3(?)  ... and I'm not also sure a metadata filter would affect the memory card (or its reader) and not the harddrive(?)

                 

                Regarding the harddrive test you suggest ... I first copied a pair (jpg+rw2) of files to a "test" folder, and Lr4 saw both (but I cancelled).  I then inserted the SD card, and tried to import, but Lr4 saw only the JPGs.  I then copied all of the files to the same "test" folder, and imported all of them, RW2s included.

                 

                I suppose I also have to assume it could be a problem with the memory card -- it is a Sandisk 16Gb "Extreme Pro", that works well in every other respect.  I've first assumed it's a problem with a new software, but I'll ask around to see if anyone has experienced similar problems with the SD card of the SD card reader.

                • 5. Re: Lr4 not importing raw (RW2)
                  ssprengel CommunityMVP

                  LR4 may be using different system functions to read USB devices which might make things different if something isn’t quite right, somewhere.  Can you change the USB-port you import from or change the drive-letter you import from?  (I am replying by E-mail so don’t see your previous posts to remember if you’re on Windows or a Mac.)

                   

                   

                   

                  Is your diagnosis that LR4 imports the RW2s as hidden when you use the reader but imports the RW2s as visible when using your hard-drive, or do the RW2s not get imported when importing from a USB-attached device?

                  • 6. Re: Lr4 not importing raw (RW2)
                    rarewolf Community Member

                    The SD card reader is a slot built into my Macbook Air.  It works in every respect, including Lr3 ... just not Lr4 ...

                    • 7. Re: Lr4 not importing raw (RW2)
                      rarewolf Community Member

                      This would appear then to be a bug.  However, I cannot find any link on any Adobe support for reporting a bug direct to Lightroom support(?)  Where do I go from here?

                      • 8. Re: Lr4 not importing raw (RW2)
                        ssprengel CommunityMVP

                        The Adobe Feedback site is the place to report bugs with Lightroom and most Adobe products.

                         

                        http://feedback.photoshop.com/photoshop_family

                         

                         

                         

                        I would make the subject a little more precise by mentioning it is when importing from a MBA’s card-reader.

                        • 9. Re: Lr4 not importing raw (RW2)
                          rarewolf Community Member

                          That website refuses to accept my AdobeID.  Stupid dialog keeps telling me the UsedID is not availabele ... well, DUH!!!

                          • 10. Re: Lr4 not importing raw (RW2)
                            rarewolf Community Member

                            Apparently the correct answer was to format the SD card.  Out of the box, the Sandisk "Extreme Pro" 16Gb SD card worked in every respect with Lr3 ... but as soon as I upgraded to Lr4 the RW2 files disappeared, and Lr4 saw only the JPGs.

                             

                            I saw no need to reformat the card, and it's not the easiest process with the Pany G3, but I just imported 230 images (raw+jpg) via copying first to the HD ... and decided as a last resort to reformat the card.  I took a test photo and ... voila, Lr4 can now see the RW2 raw files ...

                             

                            Just goes to show I guess ... not everything makes sense!

                             

                            Do I get points for the correct answer??

                             

                            Cheerios