1 2 3 Previous Next 110 Replies Latest reply: Jun 27, 2012 3:22 AM by bacma Go to original post RSS
      • 40. Re: Photos won't display in Parent folders or All Photographs
        Dannypo Community Member

        I just tried something else, which solved the problem for me.

         

        I opened LR4, created a new catalogue. I then imported the LR3 catalogue directly to the new LR4 catalogue. The system obviously converted the LR3 catalogue on the fly. At the end of the import I got e message saying that that LightRoom couldn’t import the catalogue, but it did it and all works ok J

         

        Like I said, all works ok and the development history is preserved.

         

         

         

        Regards

         

        Danny

         

        <http://www.dportnoy.com/> My website

         

        My photo blog

        • 41. Re: Photos won't display in Parent folders or All Photographs
          Rob Sylvan Community Member

          It does seem to solve the problem if you use the Import from another catalog function to upgrade your LR3 catalog, but keep in mind that Publish Service connections are not included in catalog import/export, so you would lose those in the transition to LR4, and would have to re-create them all from scratch.

           

          If you don't use Publish Services then this is not an issue for you.

          • 42. Re: Photos won't display in Parent folders or All Photographs
            Dannypo Community Member

            You are right. I have to set them up again …..

             

             

             

            Regards

             

            Danny

             

            <http://www.dportnoy.com/> My website

             

            My photo blog

            • 43. Re: Photos won't display in Parent folders or All Photographs
              lancerogers Community Member

              Well, after 15 hours of running, the progress bar has moved to about 1/3rd the way and the photo count lower left in the grid indicates 14k photos.  I am canceling.  Basically, I cannot get LR4 to convert the catalog.  I'll try one more approach.  I do use publish services.  flickr, smugmug, picassa, facebook.  Not sure if this is part of the issue, but I really don't want to lose all this work either.

              • 44. Re: Photos won't display in Parent folders or All Photographs
                serge_vc

                I encountered the same problem after upgrading to LR4. No images were shown when viewing All Photographs. I created a new catalog and imported from my freshly created LR4 catalog but that didn't work. I created a second new catalog but this time I chose to import from my previous LR3 catalog which did fix the problem, for now.

                • 45. Re: Photos won't display in Parent folders or All Photographs
                  jgiraud Community Member

                  This will work but you give up all your publishing service configuration

                   

                  Thanks

                  Jacques

                  • 46. Re: Photos won't display in Parent folders or All Photographs
                    Philip Flower Community Member

                    I am just working my way through this.  Importing from an LR3 catalog solves the disappearing photos problem, but I have been using the publish services a lot in LR3 and losing them is a pain.

                     

                    Has Adobe not responded at all to this yet?

                    • 47. Re: Photos won't display in Parent folders or All Photographs
                      zdybkela Community Member

                      Just wanted to let everyone who is following this post know that I did not hear from Adobe with any further information. I was told that I would hear back by today and since they did NOT contact me I have resubmitted a request for someone to do so. I know that there are MANY people with this same issue and all I can say is that I WILL update this post as SOON as I hear anything.

                       

                      Until then a GREAT workaround with the EXACT steps were posted by richardondrovic .

                       

                      Regards,

                      Kevin

                      • 48. Re: Photos won't display in Parent folders or All Photographs
                        lancerogers Community Member

                        Thanks zdybkela, just FYI, the workaround does not work for me.  I ran for over 15 hours and only processed 15k images.  I cannot get the old catalog to import.  The main problem appears to be that when the catalog gets converted, it does not create all of the previews.

                        • 49. Re: Photos won't display in Parent folders or All Photographs
                          Dawn Camp

                          Thank you! richardondrovic's solution worked for me.

                          • 50. Re: Photos won't display in Parent folders or All Photographs
                            zdybkela Community Member

                            UPDATE........I spoke to adobe this morning and they have an engineer still working on this issue! They are monitoring this forum post so instead of calling them with this same issue it would be better to post here that you are having the same problem.

                             

                            This is in fact a bug with LR4 and hope to see it fixed SOON......As I said above there is a great workaround posted by richardondrovic.

                            • 51. Re: Photos won't display in Parent folders or All Photographs
                              Rob Sylvan Community Member

                              That does work to solve the original issue but it comes at the cost of your Publish Services as they are not included in catalog export/import. Just keep that in mind before you proceed.

                              zdybkela wrote:

                               

                              UPDATE........I spoke to adobe this morning and they have an engineer still working on this issue! They are monitoring this forum post so instead of calling them with this same issue it would be better to post here that you are having the same problem.

                               

                              This is in fact a bug with LR4 and hope to see it fixed SOON......As I said above there is a great workaround posted by richardondrovic.

                              • 52. Re: Photos won't display in Parent folders or All Photographs
                                BKKDon Community Member

                                It may only be an issue with the COPY as I have over 6K in one parent directory on the HD (Win 7 64 bit) and they all show up when I click on the parent directory.

                                I only ever Add to the catalogue so I don't move the photos to a new location.

                                • 53. Re: Photos won't display in Parent folders or All Photographs
                                  lancerogers Community Member

                                  Well, it is also working for some folks, but not me.  I am on my 5th attempt to import the catalog to a new LR4 catalog. I have made it through importing 15k images.  My current import has been running for 9 hours and imported 2500 images.  At this rate, I need 99 more hours to complete importing of my measley 45k image catalog.   This is horrible.  The issue appears to be with the previews somehow and I suspect that once previews are actually built or copied that they are not indexed correctly and that somehow the import is doing a table scan before it actually adds each record. Like I said, I'm glad it works for others, but 100 hours to lose all my published information.....It's really sad that my LR3 catalog converted rather quickly and all the images are there along with the publish information.  You can see the counts, just no previews and no images.

                                  • 54. Re: Photos won't display in Parent folders or All Photographs
                                    mjacho Community Member

                                    I am having the same issue that everyone else has noted.  I will wait for adobe to fix this bug as long as it doesn't take too long.  thanks everyone for your suggestions and help in this matter.

                                    • 55. Re: Photos won't display in Parent folders or All Photographs
                                      lancerogers Community Member

                                      Well I attempted to contact Adobe again today through Chat.  They had me create a small LR3 Catalog of 600 photos, then export that catalog, then import that catalog to LR4.  Once it worked the chat person basically wiped his hands of any issue, indicated it is not a software problem and told me it was a performance issue.  Suggested I reduce the size of my catalog.  I respectfully disagree, but am appalled that Adobe basically has no upgrade path for a 45k image catalog and their solution is break the catalog into tiny pieces. Not really sure what that solves.  It certainly does not help me given that I use LR to publish all my stuff. I also use LR to create collages which if things are in different catalogs becomes a pain.  Really cannot understand why 45k images is such an issue.  Photoshop Elements handled the volume without issue.  When I asked whether the failed conversion from LR3 to LR4 was a bug, the answer I received was that we were able to convert your new catalog no problem......  Not really sure if they are just overwhelmed or not, but this is rediculous answer.  I have spent in excess of 60 hours attempting workarounds to convert my catalog with no answer from Adobe and no answer that works.  I'd be willing to lose all my publish information to be able to convert.  I suspect I will have to export my existing catalog into 5 or 6 other minor catalogs and then attempt to import each of those.  The problem with this approach is that the import function takes upwards to 8 hours or more to check for duplicate images once the catalog starts to grow and I cannot get the initial import to complete.  I'm basically dead in the water until Adobe fixes the conversion issue that leaves me unable to view the photos.

                                      • 56. Re: Photos won't display in Parent folders or All Photographs
                                        Benjamin Warde Adobe Employee

                                        Hi All,

                                         

                                        Has anyone experiencing this problem tried throwing out their Lightroom preferences to see if that fixes the problem?  This link describes where the preference files are located:

                                         

                                        http://kb2.adobe.com/cps/843/cpsid_84313.html

                                         

                                        Try quitting Lightroom, throwing out the preference files, and relaunching lightroom.  Let me know if that fixes the problem.  If it doesn't, it would be very helpful if someone could provide a catalog (the upgraded LR4 catalog) that is exhibiting the problem.  Only the catalog is necessary, not the photos.  The catalog can be zipped to make it smaller, and can be uploaded to Dropbox or a similar service, and you can then provide a link to it here.  Or, if you prefer, I can provide instructions for sending the catalog directly to me at Adobe via FTP.

                                         

                                        Thanks,

                                        Ben

                                        • 57. Re: Photos won't display in Parent folders or All Photographs
                                          zdybkela Community Member

                                          Benjamin,

                                           

                                          I have been on the phone with Adobe for over FIVE hours now and did try what you mentioned. I have talked with support and escalated support and now I am sitting stagnant waiting for a call back that I was promised by last Friday......Still NO call or NO resolution.

                                           

                                          Contact me directly and I would be glad to send my catalog to have it looked at.

                                           

                                          Kevin

                                          • 58. Re: Photos won't display in Parent folders or All Photographs
                                            Benjamin Warde Adobe Employee

                                            Thanks Kevin, I've sent you a private message.

                                             

                                            -Ben

                                            • 59. Re: Photos won't display in Parent folders or All Photographs
                                              lancerogers Community Member

                                              The issue is not with preferences, it is with the preview process.

                                               

                                              When LR converts a catalog it attempts to copy the previews without question and does not give an option to "not copy" the previews.  There is an error routine that keeps tracks of what previews could not be found and therefore not copied forward during conversion. This error routine crashes LR because it cannot handle any substantial amount of mismatches.  Somewhere north of 3000 image previews not found.  I can repeat this easily by exporting more than 3000 images from my LR3 catalog for items that no longer have previews available.  In the automated catalog conversion, the previews not found is ignored (most likely because it never asked if I wanted previews copied forward) The catalog conversion works fine, but somewhere in the preview crashing, the catalog is left in a state that does not allow the regular images of the catalog to be viewed.  I can prove this.

                                               

                                              I was successful today in first exporting my LR3 Catalog without copying previews.  This took all of 2 minutes or so. I then created a new empty LR4 Catalog and then immediately imported my recently exported LR3 catalog.  Again, about 5 minutes to convert to LR4 and all images visible no issues; other than, I lost all of my published collection information.  I am currently rebeuilding that.  Most of my publish collections use jfriedl plugins, so really not a big deal to rebuild except for Smugmug. 

                                               

                                              The SmugMug plugin allows you to sync what is online with the catalog, but it presents potential matches....1 at a time.  I get at least two potential matches on almost every photo.  One that is an exact match with the jpg version of the file and then a potential match with the NEF.  Unfortunately, I have to tell the plug in to accept the "Perfect" match, 1 at a time.  I have 10k images at Smugmug.  So, once again, I can either switch to jfriedl's plugin for SmugMug or work my way through 10k photos 1 at a time.....At least I am working in LR4 now.  Still no reasonable answer from Adobe.  They blame the plugins and publish services and basically offered no help to retain publish information intact. Very disappointed with their support on this and not really sure why we have to trouble shoot this for them.  Perhaps they tested everything with < 500 images or with something that had recent previews all available. I delete previews after 30 days. The first thing they asked me to do was create a small catalog then convert it. Once that worked, they basically wiped their hands of the issue and stated the software is working correctly and everything else is just performance issues.  Honestly, they must not know what the issue is or don't care.  I also offered to troubleshoot it for them.

                                              • 60. Re: Photos won't display in Parent folders or All Photographs
                                                Lee Jay Community Member

                                                lancerogers wrote:


                                                I delete previews after 30 days.

                                                 

                                                How?  You can't do that from within LR, you can only delete 1:1's.  The smaller sizes can't be deleted from inside of LR.

                                                • 61. Re: Photos won't display in Parent folders or All Photographs
                                                  lancerogers Community Member

                                                  Benjamin, I have a 45k image catalog. I attempted to delete the preference file. Happy to send you the catalog for troubleshooting if you provide the upload information.  Please see my other post on where I believe the issue to be.

                                                  • 62. Re: Photos won't display in Parent folders or All Photographs
                                                    lancerogers Community Member

                                                    The issue is with the "rendered" previews.  Not with the smaller sizes from inside LR.  The error routine that is "Counting" not found previews is the one that rebuilds the "Preview Data"  My catalog is working fine now and I specifically requested on export not to copy previews.

                                                    • 63. Re: Photos won't display in Parent folders or All Photographs
                                                      Lee Jay Community Member

                                                      lancerogers wrote:

                                                       

                                                      The issue is with the "rendered" previews.  Not with the smaller sizes from inside LR.  The error routine that is "Counting" not found previews is the one that rebuilds the "Preview Data"  My catalog is working fine now and I specifically requested on export not to copy previews.

                                                       

                                                      All the previews, of all sizes, are rendered from inside of LR.  I delete all my 1:1s after 7 days, probably had only a few percent of them when I upgraded (out of over 100,000), and the upgrade went smoothly.

                                                      • 64. Re: Photos won't display in Parent folders or All Photographs
                                                        lancerogers Community Member

                                                        Great, glad it worked for you.

                                                         

                                                        Not sure what the issue is with my previews or why.  I do know that if I export my current LR3 Catalog with the option selected to copy previews, LR3 crashes.

                                                         

                                                        If I export my catalog with the option not checked to copy previews, export runs just fine.

                                                        • 65. Re: Photos won't display in Parent folders or All Photographs
                                                          Benjamin Warde Adobe Employee

                                                          I have been able to reproduce this problem using Kevin's (zdybkela's) catalog.  I've entered the issue in our bug database, so an engineer will be looking at it as soon as possible.  I'll post back to this thread when I have more info.

                                                           

                                                          Thanks,

                                                          Ben

                                                          • 66. Re: Photos won't display in Parent folders or All Photographs
                                                            jrg1963

                                                            After reading your post, I decided to try an experiment. I went back to my LR3 catalog and deleted all the 1:1 previews. I moved the catalog into a new directory so there was no preview folder hoping it would force LR4 to create all new previews. . I opened the catalog in LR4 and it asked if I wanted to convert the catalog. I went ahead (118k images) and it converted the catalog. Exactly the same issue as before, can't see images in parent folders with more than about >3k images. I also have lots of galleries on SmugMug I am not willing to recreate.

                                                            • 67. Re: Photos won't display in Parent folders or All Photographs
                                                              Firillu Community Member

                                                              Very annoyed. I have same issue here with a catalog of >80,000 images. "No Photos in Selected Folder" for every folder I select, parent, child, and All Photos.

                                                               

                                                              Quality control at Adobe is obviously slipping.

                                                               

                                                              Well, I tried all suggestions and experments mentioned, and closest I got after many wasted hours of fiddling was with re-importing a converted catalog into a new one, but that broke all stacked photos apart. MAJOR FAIL.

                                                               

                                                              FWIW, I'm on a MBP 2011 with 8Gb RAM, OS X 10.7.3

                                                              • 68. Re: Photos won't display in Parent folders or All Photographs
                                                                jrg1963 Community Member

                                                                I noticed that you said you can't see any previews at all even if you click on child folders. Is that accurate  In my case I can see the photos if I click in the child folder. Early in my catalog, I have only jpegs but a few years in, I started shooting raw+jpegs on Nikon. It's in those parent folders that the problem start. I'm running LR4 on Win 7 x64 on a custom Intel PC with 24GB RAM with 6tb RAID5 array. Catalog sits on a Crucial 240gb SSD.

                                                                • 69. Re: Photos won't display in Parent folders or All Photographs
                                                                  lancerogers Community Member

                                                                  For me, I was not able to see previews for any photo in the main catalog except for photos in publish collections, I was able to see all of those. I'm running LR4 on Win 7 x64 custom Intel 16gb RAM.  Catalog and images are on E drive (1 TB Internal HDD).  Operating system and programs are on C (Crucial 256gb SSD).  All of this was on another machine and moved to this machine, but all moves of images performed in LR, not through the OS.  I suspect that the export in the conversion routine from LR3 to LR4 catalog is filling up the error table for previews not found and rather than crashing, is most likely overwriting storage somewhere creating unpredictable results, or that another process proceeds while the error processing is still writing, but without knowing how those routines work, I'm just guessing.  I can consistently prove that LR3 crashes on export of the catalog for anything North of say about 3500 images.  However, LR4 does not crash when converting same catalog.  If I do an export for LR3 and unselect the "Copy Preview" option, no crash and import/conversion to LR4 is successful.

                                                                  • 70. Re: Photos won't display in Parent folders or All Photographs
                                                                    Firillu Community Member

                                                                    jrg1963 wrote:

                                                                     

                                                                    I noticed that you said you can't see any previews at all even if you click on child folders. Is that accurate 

                                                                    yes it is accurate.

                                                                     

                                                                    i can only see photos in collections but nothing in folders.

                                                                    • 71. Re: Photos won't display in Parent folders or All Photographs
                                                                      Vittoria Coffee Community Member

                                                                      IMO the issue is not the number of levels of folders or which level the folder is that you are trying to view..

                                                                       

                                                                      It is the number of photos in a folder or group of folders.

                                                                       

                                                                      For me the magic number is 3418, if there are more than 3417 photos in a folder they will not display.

                                                                      If I reduce a folder to 3417 after upgrading the catalog to LR4 then the photos appear. As soon as I increase back to 3418 or more they dissappear again.

                                                                       

                                                                      This is the same foe several levels of folders or the lowest folder.  Same thing happens.

                                                                       

                                                                      I too have succesfully done the work around by importing either form the new LR4 catalog or the old LR3 catalog, But either way I lose publishing services.

                                                                      • 72. Re: Photos won't display in Parent folders or All Photographs
                                                                        Vittoria Coffee Community Member

                                                                        I am curious as to how many photos you have in individual collections.

                                                                         

                                                                        Increase the number to 4000 and see if they still display.  Sounds silly I know but stranger things!!!!!

                                                                        • 73. Re: Photos won't display in Parent folders or All Photographs
                                                                          Firillu Community Member

                                                                          in my case the number of photos is irrelevant. Folders containing only 14 photos still don't show up.

                                                                           

                                                                          I uninstalled Lr4 and re-installed 4 times now and got the same issue all the time.

                                                                           

                                                                           

                                                                          Was also wondring when we should expect a fix on this - this week, this month or this year? I need to know so that I can take a decision accordingly.

                                                                          • 74. Re: Photos won't display in Parent folders or All Photographs
                                                                            lancerogers Community Member

                                                                            Same here Firillu, it did not matter for me how many photos in folders, none showed up with the exception of the publish services.  All the publish services would show the photos, the main folder would not at any level.

                                                                            • 75. Re: Photos won't display in Parent folders or All Photographs
                                                                              Jim Stamates Community Member

                                                                              Add me to the list. MacBook Pro.

                                                                              Agree with Vittoria; no matter what folders I select, as soon as there are more than 3400 (about) images the 'No Images in Selected Folders' appears and all the images dissappear.

                                                                               

                                                                              I'll wait for fix but it is odd that it wasn't caught in beta.

                                                                              • 76. Re: Photos won't display in Parent folders or All Photographs
                                                                                Weide67 Community Member

                                                                                i have the same problem (Win 7 64bit). My magic number is about 1200. I'm waiting for a bugfix and furthermore work with V3.6. I will not install a faulty database.

                                                                                • 77. Re: Photos won't display in Parent folders or All Photographs
                                                                                  Jim Stamates Community Member

                                                                                  Okay, I deleted all my 1:1 previews in LR3 cat. Then I created a new cat in LR4 and imported from cat3. It didn't take that long (1-2 hours) All 90k+ images are now visable in all folders and sub-folders including 'All Photographs'

                                                                                  All the keywords, develop settings, crops, flags, etc. seem to be intact.

                                                                                   

                                                                                  True, the publish services is not set up.

                                                                                   

                                                                                  Didn't we have to do something like this when converting LR2 to LR3? I remember it wasn't a simple task as it was supposed to be.

                                                                                  • 78. Re: Photos won't display in Parent folders or All Photographs
                                                                                    Kurt_Huber

                                                                                    I have the same issue with 32k files on Win7 64.

                                                                                     

                                                                                    I wait for an official statement from Adobe how to work around this or the next update before working in LR4.

                                                                                    • 79. Re: Photos won't display in Parent folders or All Photographs
                                                                                      picbod

                                                                                      Yep, me too. 298,000 images. All raw 5DmKII files.

                                                                                       

                                                                                      I originally posted in Lightroom Forums with all details here:

                                                                                       

                                                                                      http://www.lightroomforums.net/showthread.php?14927-LR4-catalogue-update-doesn-t-see-files -in-Loupe-Grid-Develop-or-filmstrip!