3 Replies Latest reply on Mar 20, 2012 12:07 PM by brianmwise

    ePub Creation - TOC FILE MISSING - issues with 7zip VS zip.exe


      Since this question isn't actually answered - IE, the same issues are occurring that I found elsewhere with the ePub Script, I needed to reup the question.


      Here's my biggest issue - when 7zip is selected BY RoboHelp to generate an ePub, it does not work.

      However, when RoboHelp tells me to select zip.exe from stahlforce.com/dev/zip.exe, it works just fine.


      But there's no way for me to set ZIP.EXE as the standard choice when I build an ePub and run the script - it immediately tells me TOC FILE MISSING as it's doing the Creating NCX(TOC) file.





      I still get an error.


      This occurs if the XML Generate file is in the SSL folder of the project or not, regardless of whether it's on a C drive or an E drive (or a network drive, USB key, etc etc etc)


      If I manage to, by some MIRACLE, get it to use zip.exe instead, it'll cheerfully compile with a TOC.


      My system path already has System32 in it. No need to modify it.


      System: Windows 7 Professional 64-bit

      7zip: latest build

      RoboHelp: 9.0.2 in ATCS3


      Thus far, I have:


      1. Removed all the spaces from my Project Name and ePub outputs per this post: http://forums.adobe.com/message/3155109#3155109

      2. Followed Praful's instructions to the letter after contacting him to find out exactly how one goes about adding the system32 to the Path variables.

      3. Run the generator fifty-nine times.


      Out of those fifty-nine times, I have also:


      A. Downloaded 32-bit 7zip and used it as the Zip source, and it craps the bed with a TOC Missing error. No go.

      B. Downloaded 64-bit 7zip and used it as the Zip source, and it craps the bed with a TOC Missing error. No go.

      C. Downloaded zip.exe as requested, used it as the Zip source, HOORAY! It works!

      D. Try to replicate, it goes back to 7zip and craps the bed. KHAAAAAAAAAAAN!


      Now, I've done this on my C drive (an SSD) and my E drive (a regular storage drive) and used RoboHelp in both locations, doing both on the C and the E drive so that all is contained (project, folder, output, everything) in the same location. I've done this on clean systems and "dirty" systems, and every. SINGLE. TIME. RoboHelp cheerfully informs me that there is no TOC file.


      When this happens, it is ALWAYS when it tells me to use 7zip instead of, say "zip.exe".



      Like so.


      My default ePub reader has been Adobe Digital Editions. It still does this.

      I changed the default ePub reader to Sony Reader Library. It still does this.

      I changed the default ePub reader to Calibre. IT STILL DOES THIS.


      I've done it with the C drive as the sole environment system.

      I've done it with the E drive as the sole environment system.

      I even installed RoboHelp on a computer with a single hard drive and did nothing but generate this file.


      When RoboHelp asks me for zip.exe location, it compiles BEAUTIFULLY.


      But then it goes right back to 7zip and craps the bed.


      Now, when I say "It still does this", I mean I reverted to all the variables from that point forward. So when you get to "C drive as the sole environment system" that means everything above it, I did with that final condition.

      So to answer the pending question, "What's your system?" it is in Windows 7 Professional running 64-bit.


      Yes, I've tried Praful's system path variable.

      Yes, I've tried clean installs.

      Yes, I've tried it on a solo hard drive.

      Yes, I've tried it on a clean build of Win7.

      Yes, I've tried all of this.


      It is still crapping the bed when it gets to the TOC Path missing.


      As others have stated, there are no errors in the log. There's no unreferenced files, no weirdness in the naming conventions of the project, nothing.


      But if it goes to 7zip, it craps the bed.

      If it stays with zip.exe, it's fine.


      So, what else can you guys help out here with? This is not a terribly hard thing - to compile an ePub really ISN'T that hard. But what I need to know is what else could I possibly do to fix this?


      Is there a setting to make the zip.exe the ONLY zip extension in the script? That seems to work, but RoboHelp likes to jump back to 7zip.

      Like others, I've followed these instructions extremely carefully, but there always seems to be an "oh yeah, make sure...." that comes along with RoboHelp that never gets linked up in the manuals.


      So what's the next "Oh yeah, make sure"? I'd like to know because frankly at this point RoboHelp is doing a less helpful job than the $40 ePub creator program I bought out of frustration with the ePub generation process.

        • 1. Re: ePub Creation - TOC FILE MISSING - issues with 7zip VS zip.exe
          brianmwise Level 1

          As a side note:


          I shouldn't have to specify the C drive as the source file drive. I should be able to have RoboHelp on one drive running and be able to build and compile an ePub on a secondary drive or network location without having to jump through fifteen different hoops.


          Somehow, though, the ONLY way this is working is when it asks specifically for zip.exe.


          Incidentally, this "feature" has made my coworkers jumpy around me, mainly because I've let fly with curses that make the Baby Buddha lose his chi. Any assistance - even to the point of going into the script itself and rearranging the file calls would be EXTREMELY appreciated.


          One more note: Since Robohelp asked for 7z.exe or 7za.exe, I went looking for 7za.exe. Not finding it, I figured, hey, what the heck, I'll copy the zip.exe (that actually works), then add it to the file list and select 7za.exe as the file instead.


          Once again, RoboHelp's bed got crapped.

          • 2. Re: ePub Creation - TOC FILE MISSING - issues with 7zip VS zip.exe
            Willam van Weelden Level 5

            Hi, 7zip is the old method of zipping up the epub. When installing 902, a new script is provided, but you need to make it available by hand. Perhaps this new version helps with your problems.


            See the 9.0.2. readme:

            ePub output

            After installing the patch, copy the updated ePub Generator.jsx script from [InstallDir]/RoboHTML/presets/scripts/ to the following location:

            • On Windows XP: [USER]/Application Data/Adobe/RoboHTML/9.00/Scripts/Sample Scripts/
            • On Windows 7: [USER]/AppData/Roaming/Adobe/RoboHTML/9.00/Scripts/Sample Scripts/


            Just a bit of guessing here: Are there any special characters (ë, à, etc.) in the name of your project? Does the XML output actually have a TOC assigned for output?


            Would it be possible to share the proejct so we can have a look?





            • 3. Re: ePub Creation - TOC FILE MISSING - issues with 7zip VS zip.exe
              brianmwise Level 1

              Yeah, that's the odd part. Periodically it would dance between requiring 7zip.exe and zip.exe. One thing that's just irksome is that while I do read the combinations, it's not exactly spelled out with grave detail on exactly what you need to do to update the script EXCEPT in the release notes.


              So, to compile the advice that has been given here and elsewhere:


              Make sure the following are done if you're having issues completing the ePub, or it craps the bed doing the TOC generation:


              Make sure that C:\Windows\System32 is in the path variable per http://www.computerhope.com/issues/ch000549.htm.


              Make sure your project doesn't have any special characters in the list (mine didn't), and if you're REALLY having issues, shorten or remove the spaces.


              Make sure you're updated to RoboHelp 9.0.2.


              Make sure you follow William's notes per the release notes in RoboHelp 9.0.2 to manually update the Javascript (you'll have to go to Start > Control Panel > Appearance and Personalization > Folder Options > Show Hidden Files and Folders > Set "Show Hidden Files, Folders, and Drives" and click Apply before you'll be able to open AppData in your C: drive and copy the Javascript over.




              Back up the original BEFORE replacing it, and then do a replacement of the original JavaScript ePub Generator script with the new one.


              For me, the quick copy of the Javascript seems to have fixed the issue, but it took a HELL of a long time troubleshooting through all the disparate thread to find a complete troubleshooting solution.


              And unfortunately no I can't make the project shareable due to sensitivity; I could have theoretically done a setup with a fake project that was having the same problems. But I greatly appreciate the tip, William!

              1 person found this helpful