1 2 Previous Next 57 Replies Latest reply on May 19, 2014 1:31 PM by Omke Oudeman Go to original post
      • 40. Re: Bridge Error writing Metadata to some [....].jpg
        Curt Y Level 7

        Yammer, you might visit this link in the Mac forum.  Similar problem?



        • 41. Re: Bridge Error writing Metadata to some [....].jpg
          Yammer Level 4

          That's the same thread as above

          • 42. Re: Bridge Error writing Metadata to some [....].jpg
            Yammer Level 4

            The silence is deafening.

            • 43. Re: Bridge Error writing Metadata to some [....].jpg
              Curt Y Level 7

              Yammer P wrote:


              That's the same thread as above

              I clicked on link and it is started by Mike D with metadata problems on a mac.  So try again?

              • 44. Re: Bridge Error writing Metadata to some [....].jpg

                Curt, your link is to a post in the thread i linked to above it. No big deal but that's what Yammer was talking about.


                Yammer, I haven't been able to put my finder on the exact cause yet. My gut tells me it has something to do with Bridge not understanding XMP files written by older versions of Lightroom, but I can't confirm that.


                The really frustrating thing is that if this error would generate a code that could be traced to a specific condition, we could at least identify the cause and figure out a work-around.



                • 45. Re: Bridge Error writing Metadata to some [....].jpg

                  I'm yet another person having the same problem (CS5 in a Win7 PC), when I'm in Bridge and try a Replace Metadata for an image file I get the famous "Error writing metadata to jpeg file" .  I run CS5 on a Win7 Pro PC which I just got three days ago and moved my photo images (2TB) drive from my old PC (running XP)  to my new PC (running Win7 Pro).  However,  I have discovered the following:


                  1) When I use Windows Explorer to look at the properties of the FOLDER containing my jpeg file they are noted as read-only

                  2) When I copy the exact same jpeg image file to my C drive (which was formatted under Win7), a folder I just created - Not marked read-only, and try replace the metadata - no problem


                  I believe its a question of Win7 ownership and permissions. I believe that the for some reason the physical drive I moved from my old PC to my new PC retains "ownership and permissions", so Win7 notes all of the folders as read-only, and won't write the metadata to the jpegs in that folder.


                  A very very poor workaround is to turn off the UAC (User Account Control). Set to never.  I have tried a number of suggested solutions but not found a way to remove the read-only setting for my image folders.  I will try copying some of my image files to a new drive formatted under Win7 Pro and see if that eliminate the problem for me. 


                  Please try setting your UAC to Never and let me know if that helps.  Also let me know if you find a way to remove read-only from folders.



                  • 46. Re: Bridge Error writing Metadata to some [....].jpg
                    Curt Y Level 7

                    haggest wrote:


                    I believe its a question of Win7 ownership and permissions. I believe that the for some reason the physical drive I moved from my old PC to my new PC retains "ownership and permissions", so Win7 notes all of the folders as read-only, and won't write the metadata to the jpegs in that folder.


                    You are correct.  Files made on another computer do not have the same permission levels as ones made on the same computer


                    Here is a solution from Pixel Basher


                    The key to solving this issue lies is understanding that in terms of Windows 7 Security, every internal or external hard drive, plus folders, sub-folders and files thereon has an OWNER. Also each OWNER has a certain level of PERMISSION to do things such as moving files to a different folder, deleting or re-naming them etc. If you try to do things that you don't currently have Permission to do, that is when you get an ‘Access Denied’ error message. Also your system has an Admistrator or Administrators and at the outset you need to ensure through the Control Panel that you are listed as one of them. .


                    If, like me, you didn't realise these things, (and why would you if Microsoft or your computer or hard drive suppliers couldn't be bothered to really make sure you knew about them), then trying to fathom the ‘Access Denied’ problem becomes a stressful and frustrating nightmare as I can testify having spent a week at it!


                    The steps that I took to resolve the issue and which I believe now constitute the 'Correct Answer' are as follows:


                    1. First make sure that you have Administrator rights on your system via the Control Panel

                    2. Next ‘right click’ on the Drive whose files you want to gain full access to, for example the drive that your pictures are stored on, and click on 'Properties'.

                    3. Under the Security tab you will see a list of Groups and Users on this drive and the Permissions that they have to do things.

                    4. Before doing anything to edit these Permissions, first click on the Advanced button. This opens another window with a tab showing the Owner of this drive.
                    5. Click on the Owner tab and if you are not already listed as the owner, make yourself the owner by selecting your name from the list. I believe it should appear there if you are an admistrator or user. (In my case at this stage the owner was initially shown as an obscure string of numbers and letters which I believe identified the drive when it was connected to the lap top I was using before I upgraded my machine)

                    6. Now be sure to check the box that says "Replace Owner on Subcontainers and Objects" and the click Apply. On completion of this step, the drive in question and all the folders, subfolders and files thereon should now be 'owned' by you. You could check this out by right clicking on a particular folder then clicking Properties > Security > Advanced > Owner. Your name should appear. So far so simples!

                    7. Now go back to the Security Tab for your drive (Step 2 / 3 above) and look at the Permissions you currently have. Your aim now is to allow yourself 'Full Control.' If you don’t currently have this level of permission click Edit, select your name on the list, check ‘Full Control’ and 'Apply' the change.

                    8. I think I'm right in saying that at this point whilst still working in the Drive directory you are now given the option of ticking boxes which allow you to, in effect, cascade the permission you have just granted yourself to all the files and folders on that drive. Tick the box to allow this and Windows should then take care of the rest.If I'm not quite correct here then in my particular case, for example, all my images were stored on my external drive. The top level, or 'parent' folder in which all my pictures could be found was the 'My Pictures' folder and I had created a number of folders and subfolders ('child ' folders) within that folder. The permissions I gave to the Parent folder – My Pictures – were cascaded down through the Child folders.

                    9. On completion of the above step I tested the result in Windows Explorer by dragging a few files back and forth between folders and it now worked perfectly - I was now able to move / delete / rename etc all files without now getting the dreaded access denied message. What a sense of relief! This meant that I could now open Bridge normally rather than having to right click it and 'Run As Admistrator' - albeit that is a very useful thing to do until you get the problem sorted as described.
                    • 47. Re: Bridge Error writing Metadata to some [....].jpg
                      theMikeD Level 1

                      This happens on Macs too, so while the suggested steps may fix the problem, the underlying bug remains.

                      • 48. Re: Bridge Error writing Metadata to some [....].jpg
                        Curt Y Level 7

                        It is not a bug.  It is how the OS system sets up permission levels in both Win and Mac. 

                        • 49. Re: Bridge Error writing Metadata to some [....].jpg
                          haggest Level 1

                          Curt - You are the man! And didn't even remember the right-click - run as Admin trick.  I had been looking at 10-15 posts on Win7 permission, trying things for hours, but yours was the first that said START AT THE ROOT dummy, then I followed your instructions step-by-step and it works.  Thanks to the Forum another problem resolved. Now what was that winning lottery number?


                          Many many thanks!


                          • 50. Re: Bridge Error writing Metadata to some [....].jpg
                            Yammer Level 4

                            Curt Y wrote:


                            Yammer P wrote:


                            What I'd like to know is why an image refused to generate a thumbnail, until I renamed it outside Bridge.

                            Usually it is becasue there is some error in how the image file was constructed.  By saving it in another program whatever error was there, it was eliminated.  This is the same problem in a parallel thread http://forums.adobe.com/thread/925441?tstart=0 where OP can add metadata to files generated with his camera until he saves it in PS.

                            I'm reading through this thread again and noticed this.


                            You misinterpreted what I wrote. All I did was 'rename' the 'damaged' raw image (using Explorer). I did not open it in any application. Its binary contents were unaltered.


                            Bridge could not generate a thumbnail, even if the image's cache and XMP were removed, but it could generate a thumbnail for an EXACT copy of the image with a new filename (done outside Bridge). What does that tell you? It tells me that the filename/handle is tainted, and Bridge already has made assumptions about it (presumably a database entry using the filename as a key).


                            To me, this seems to be a similar behaviour to the metadata problem. Jingshu Li / Melissa was easily able to keyword a raw image+sidecar from my system when I could not - even when I copied them to several different locations on my computer. This suggests to me that the files themselves are not the problem, but my copy of Bridge had a problem with the files. I was able to use Camera Raw to update one minor develop setting, and the problem went away. I assume Bridge updated a database entry with this action, and corrected the previous problem.

                            • 51. Re: Bridge Error writing Metadata to some [....].jpg
                              theMikeD Level 1

                              IMHO it's definitely a bug, and a longstanding one. Nobody here can speak to the cause of this behaviour since we don't have access to the source. All we can do is grope around in the dark trying to find a work-around based on the effects it causes and guess at the root reason.


                              No other application exhibits this behaviour, including those that read and write metadata; only Bridge. And the fixes range from "open the file in another program, make a small metadata change and save it again" to "modify the disk permissions" to "add filesystem metatdata."


                              IMHO the root cause has to do with a subtle interaction betwen the parsing engine than handles XMP data and something else that I can't pinpoint, possibly a bug in the code that interfaces between file read-writes used in the Bridge code and the OS code that does the actual read-write to disk. Or possibly a bug in the database code that incorrectly flags files as unwritable...although I doubt this one since deleting the Bridge cache doesn't fix it, at least for me.


                              But it is definitely a bug.



                              • 52. Re: Bridge Error writing Metadata to some [....].jpg

                                @ Curt - Great work with the permissions issue.  Unfortunately, your approach has not resolved the issues for me.  My image assets live on a Linux based NAS and I use two different Windows 7 systems to access the files.  Both systems are experiencing the apparently related problem of not being able to assign a rating (or lable) or keywords on some apparently random files.  The most frustrating part is that the permissions on the two Windows boxes are identical but they each experience the error but on different files.  In other words, a file that generates a metadata error when adding a keyword on one system will not generate the error on the other system and vis-versa.  When I encounter an error on one system, I could use the other computer to make the required change.  After switching back to the main platform I am once again able to alter the asset metadata with the system that initially produced the error.


                                Initially I was using switching from one computer to the other and then back to do my work but the frequency of the metadata errors has been increasing to the point where switching is becoming unworkable and the issues Bridge (CS5) are impacting my productivity.


                                @ QE Team - Is a fix for this issue actually in development?


                                @ Anyone - Can anyone please suggest a reliable and relatively inexpensive alternative tool for browsing and sorting my assets?  And does this bug continue into CS6?

                                • 53. Re: Bridge Error writing Metadata to some [....].jpg
                                  Yammer Level 4

                                  I started using CS6 this week, and I am still bedding-in the new software, installing plug-ins, generating caches and indexes, etc.


                                  I'm very pleased about Bridge going 64-bit. This makes life easier for two reasons: better/smoother performance; hosting 64-bit plug-ins, including Camera Raw.


                                  I also read that Bridge has a new database; I'm not sure how this was announced, but it fills me with optimism.


                                  I've had a couple of attempts at generating keywording metadata errors, and I am pleased to report that I failed! I followed the old method of grouping several subfolders' files and applying keywords in bulk, and the whole thing happened painlessly.



                                  I suppose it's early days, but this problem could now be a thing of the past, but only if you get CS6. There's no fix for older versions, which is unfortunate for everyone who has suffered with this problem for years.


                                  I thought that the preview/thumbnail regeneration issue had gone too, but it didn't take long to start again. Despite letting my computer index and cache 33,000 items this week, it still insists on updating parts of the cache on random subfolders.

                                  • 54. Re: Bridge Error writing Metadata to some [....].jpg
                                    gary0a1 Level 1

                                    For browsing and sorting ACDSEE always ran rings around bridge.


                                    As far as this metadata error, it's not fixed in CS6. I photograph as well as design. Photos don't usually have the problem. Designs do (for me). I may spend a day creating graphics and at the end assign the copyright etc. to all my work. But when I select a bunch it sometimes tells me it can't apply to all. Once it gets done applying the one(s) that it won't apply to can't be done even indivitually. Could be jpg, PNG or whatever. And yes, opening them and making a minor change and re-saving usually does the job. But it's a real PITA.

                                    • 55. Re: Bridge Error writing Metadata to some [....].jpg
                                      nantucketbob Level 1

                                      Windows 7, 64 bit.  I gave everyone in the Drive Security windows full control.  It worked for some images, but not all.  I did the same for that individual folder of Jpegs.  Still cannot write to the files. CS5

                                      • 56. Re: Bridge Error writing Metadata to some [....].jpg

                                        The year is 2014 and this still seems to be a problem. I am on a new Mac Pro 6 Core with the latest software running Bridge Creative Cloud and I still have trouble writing keywords to some TIFF files. I know it's not a permissions issue because I can write keywords to IPTC Core on the exact same files using ACDSee no problem. This alone may force me to switch to ACDSee if Adobe can't solve this issue. Looks like this started years ago. Anyone have any updates?

                                        • 57. Re: Bridge Error writing Metadata to some [....].jpg
                                          Omke Oudeman Level 5

                                          and I still have trouble writing keywords to some TIFF files.



                                          Can you specify the file name convention you are using, just a wild guess but sometimes extra dots or strange characters can cause problems. I cant recall having problems with writing keywords to Tiff but I mostly use PSD so not that well a good tester for your problem.


                                          If ACDSee can write the keywords to a tiff file and Bridge not then there is a serious problem going on, and you should try tech support for Adobe (Not easy, I know) but that would be the correct path to follow.

                                          1 2 Previous Next