1 Reply Latest reply: Mar 28, 2012 1:48 AM by CR Henderson RSS

    LR3.6 and Canon 5D Mark III

    cztkab

      Does anybody know whether Adobe will update LR 3.6 to accomodate the new Canon 5D Mark III?  Am I correct that the new LR 4 also doesn't support the Mark III?

       

      Thanks,

      Thomas