8 Replies Latest reply: Mar 30, 2012 5:25 PM by Noel Carboni RSS

    Cannot load on 64-bit, Windows 7 (permissions)

    zulishk

      Configuration:

       

      Windows 7 Professional, 64-bit

       

      Installed Adobe CS6 Beta Extended on different drive (not C:) drive.  In my case, I used the W: drive (an NTFS drive).

      When opening either 32-bit or 64-bit versions of Photoshop, I get the following error UNLESS I "Run as Administrator" from the context menu:

       

      "Could not open a scratch file because the file is locked, you do not have necessary access permissions, or another program is using the file.  Use the 'Properties' command in the Windows Explorer to unlock the file."

       

      When I run as administrator, I can use Photoshop.  HOWEVER, I do not get all the filters in the Filter menu (some show up in the Filter Gallery, some not at all).

       

      I believe the filter issue existed in PS5 as well.

       

      If there's anything I'm not reading or seeing, please point it out -- I'd like to not worry about missing filters AND use the 64-bit version (unless anybody knows a reason why I shouldn't bother with the 64-bit mode).  Using the 32-bit is acceptable, but still have some filters missing in the Filter menu, probably becuase I have to run it as administrator.

       

      Thanks in advance!

       

      Additional Information:

      1) My account is an administrator account.

      2) I've tried holding Ctrl+Shift+Alt after launching and deleting the settings. 

        • 1. Re: Cannot load on 64-bit, Windows 7
          Noel Carboni Community Member

          What drive(s) are listed for Scratch use in Edit - Preferences - Performance?  I'm sure someone's going to want to know that information.

           

          When not at privilege-elevated status, do you actually have write access to the root folder of the drive(s) listed for scratch use?

           

          -Noel

          • 2. Re: Cannot load on 64-bit, Windows 7
            gswetsky Community Member

            zulishk,

             

            I was just gearing up to ask the same question.  I had to set CS6 to run as administrator as well.  I dislike having to click on, "Do you want to allow this program to make changes to your computer?" before CS6 will start.  I have Windows 7 Professional 64 bit.

             

            As to your problem with filters, go to Edit->Preferences->Plug-Ins.  At the top, check the box "Additional Plug-Ins Folder" and fill in the path to your additional filters, click OK then restart Photoshop.  I had to do that so my Topaz filters would show up.

             

            I am rather disappointed that CS6 didn't find all the custom settings, etcetera that I use in CS5.

             

            Gerry

            • 3. Re: Cannot load on 64-bit, Windows 7
              zulishk

              @gswetsky:  I don't have additional filter folders.  I'm missing built-in ones (such as the Artistic or Brush Strokes).  Which plug-in folder should I add to bring these back?  I'll look around.

               

              @Noel Carboni:  I assumed PS tries to use C: as the scratch by default, but I've always changed it to use a SDRAM disk.  I've changed it to other drives with the same result.  I suppose the question should be this: What exact permissions does PS require for the scartch disk?  Administrators and SYSTEM have FULL, whereas Authenticated Users have MODIFY and USERS have READ (this is the default, in Windows 7).  I'll try to edit these and see where it goes.  I'm thinking if USERS require FULL access to fix the issue, then Adobe is overlooking something in their design.

               

              Thanks for all your replies!

              • 4. Re: Cannot load on 64-bit, Windows 7
                zulishk

                @gswetsky:  Actually, I found the problem in the same location you discussed.  You now have to put a checkmark in "Show all Filter Gallery groups and names" in the Plug-Ins preferences to enable them in the menu.

                 

                @Noel -- Changing Users to FULL did fix the issue for me, thanks.  Not sure why, though, since I'm always logged in as Admin.

                 

                Thanks all!

                • 5. Re: Cannot load on 64-bit, Windows 7
                  gswetsky Community Member

                  By the way, I noticed a similar problem trying to open Bridge as a standalone program, i.e. not through Photoshop.  It came up and immediately closed.  I solved this by allowing it to run as administrator.

                   

                  I just tried opening Extend Script Toolkit CS6, and there was no problem.  Sure wish I could get a definitive answer on this problem.  I don't feel safe running these programs as administrator when I shouldn't have to.

                   

                  Gerry

                  • 6. Re: Cannot load on 64-bit, Windows 7
                    Noel Carboni Community Member

                    zulishk wrote:

                     

                    @Noel -- Changing Users to FULL did fix the issue for me, thanks.  Not sure why, though, since I'm always logged in as Admin.

                    Actually, no, you're not.

                     

                    Microsoft's UAC feature "demotes" you to non-privileged user status during normal operations.  You only are a member of the Administrators group when you escalate privileges (e.g., if you use "Run as Administrator" to start the application).

                     

                    Permissions are complex enough as it is, but since the advent of UAC in Vista I am surprised anyone who hasn't had a lifetime of computer systems training can get Windows permissions to work for them.

                     

                    A slightly more restrictive "fix" would be to add your specific username and grant it Full Control permissions, though the settings you applied will work for all users who log into to your system.

                     

                    -Noel

                    • 7. Re: Cannot load on 64-bit, Windows 7
                      zulishk

                      @Noel -- PS shouldn't require special/unusual permission modifications.  The %TEMP% folder should be the default where all other applications can write temporary files, and PS ought to offer only the drives which it can access in the Preferences (and mark the other ones as "cannot access" rather than aborting a first-time launch of the application).  Not a good execution, IMHO.

                       

                      Thanks for all your help!

                      • 8. Re: Cannot load on 64-bit, Windows 7
                        Noel Carboni Community Member

                        Normally it's expected, in this day and age of operating systems protecting themselves from their users, that UAC-aware applications escalate to a privileged level during installation and grant themselves permissions to all the things they'll need to access later.

                         

                        But I suspect activity such as granting permissions to all the root folders of all the hard drives might be considered being a "bad citizen" in the application realm.

                         

                        As far as qualifying the drives and allowing only those to which the application can write, I agree with you 100%.  It should make it obvious that there's a problem and even give you some guidance as to how to make a drive available for scratch use.

                         

                        -Noel