11 Replies Latest reply: Apr 1, 2012 10:24 PM by JonPaso RSS

    When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64

    JonPaso

      I wanted to try the new brushes in Ps CS6 64. I opened a new document RGB 8 bit 8.5 X 11 300 ppi.

      When I tried the different brushes I got lag when I painted a line to when the color was applied.

      I even got the swirling blue circle showing it was working. As the brush size gets larger the lag increases.

      At this time no crashes or program hangs. This problem is repeatable. I expected to paint as I applied the line/color.

      Computer: phenom II X4 3.4 GHz  16 gig 1333 (10600) DDR3 Memory, Ati HD 5870 Vid. card 1 gig memory, Windows 7 64 bit

      4 Sata II HD's Photoshop has its own scratch drive.

      I was unable to paste my system info from CS6 to this document.It seems that option is not available here.

        • 1. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
          Noel Carboni Community Member

          Pasting is available - just use Control V after placing your cursor (or Shift Right-click).

           

          There has always been some delay with really huge brushes (e.g., thousands of pixels in size)...  What size are you using?

           

          In Edit - Preferences - Performance, is the GPU checkbox checked?

           

          -Noel

          • 2. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
            ckc48 Community Member

            I found the same behavior. I was using brushes that ranged from 20 px to 35 px on average when trying out the new brushes (the ones with the airbrush and pencil icons). The lag (and the spinning blue ring) made it difficult to see exactly what I was doing.

             

            I also got the same lag when using a 5px hard brush to draw in individual hairs on a sketch. Granted, I was working pretty fast and making longish quick strokes on my tablet, but the program just couldn't keep up.

             

            I had the same problem with CS4 where I would have to pause after every few strokes, but I thought that was supposed to be resolved in this version.

             

            The GPU checkbox is checked. I have NVidea GE Force GTS 240 (Dell OEM version) witht he latest drivers, 12 GB of RAM (72% dedicated to PS in preferences) and (for what it's worth) I also have an 8GB flashcard dedicated to Ready Boost. There were no other documents open, but the document I was working on was a multi-layered 11x14 inch @ 320 ppi--in case that makes a difference.

            • 3. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
              Noel Carboni Community Member

              I'd say it's a definite bug if you're perceiving any lag at all with a 35 pixel brush of any type on pretty much any size document.

               

              The question is, where is the root cause?  Most folks certainly aren't seeing lag with brushes that size, or there'd be a bigger outcry here.

               

              I'm sure Adobe is paying attention to this, and any detailed information you can provide will no doubt be valuable to them in their attempts to make sure your combination works well by the time of release.

               

              -Noel

              • 4. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                JonPaso Community Member

                The brush was15 pixels and up. At 100 pixels or larger it was very long delay the spinning ball would go on and off several times.

                This was one white blank new Doc. Just testing the brushes to see how they worked. This occured with most of the brushes

                Oh yes, got the same results using a mouse or my Wacom Tablet. In CS5 don't get that kind of lag even with large brushes.

                • 6. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                  Noel Carboni Community Member

                  Since Photoshop is so dependent on the display driver implementation giving it access to the GPU, try these things to help isolate that the display driver could be the problem:

                   

                  1.  Disable the GPU checkbox in Preferences - Performance, then quit and restart Photoshop.  Does the lag continue?

                   

                  2.  Visit the web site of the maker of your GPU - in your case ATI.com (which redirects to amd.com) - and download/install the latest driver they have released for your hardware and operating system (which I believe is Catalyst 12.3).  Then Enable the GPU checkbox, and quit and restart Photoshop.  Does the lag continue?

                   

                  Good luck.

                   

                  -Noel

                  • 7. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                    Ryadia™ Community Member

                    With 16 gig of RAM, you should be able to make 80% of it available to Photoshop. Windows only needs 2000 MB to function unless you are going to have other programs open. Doing this will reduce the lag. Also using a scratch drive that is not on the same drive as windows uses for its swap file will help. The problem is not exclusively Photoshops. I've experienced this issue as far back as CS3 (lag when doing certain things). It is all memory related. What size files are you working on when you find this?

                     

                    Summary:

                    Allocate 80% or your 16 gig of RAM to Photoshop.

                     

                    Move the scratch drive to the fastest drive you have that is not being used for Windows swap file.

                     

                    If you don't have a second drive you can do this with, I suggest you get one they are cheap enough.

                     

                    Presuming you do this, partition the new drive into two partitions. Allocate one of them exclusively for PS scratch drive. The second partition use as your Windows swap file (Virtual RAM) and make it as large as you like but at least 12000 Mb. Fix the size (don't let windows manage the size). This way Windows won't lose any time enlarging and squeezing the file.

                     

                    Open the (PS) Preferences (under edit menu) and ensure the "use graphics Processor" box is ticked. In the drawing mode choose "advanced" and make sure "Use graphics processor to accelerate" is ticked. If you find any odd behaviour after doing that, you might need to update the graphics driver. By odd behaviour I mean the eraser circle disappearing... Mainly cursor behaviour. This will mean the graphics card does not like being used the way Photoshop uses it. This issue is a seperate one to your problem but sometimes fixing one can cause another.

                     

                    Making a memory intensive graphics program like Photoshop run at its best and smoothest will always require some experimentation with setting and RAM sizes. Let us know how you go please?

                     

                    Douglas

                    • 8. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                      Ryadia™ Community Member

                      I'd just like to add on what Noel said with a warning... Updating Catalyist and some Radeon drivers can cause a Windows fault. Fixing it is described by both Microsoft and AMD. Its a real pain if you need Catalyist for screen brightness adjustments. Catalyist is not essencial for a Radeon card to work. You can just install the card driver but that won't give you access to all the neat features available in Catalyst. I'd adopt the attitude : "Don't fix what isn't broken".

                       

                      Sorry to butt in on you Noel...

                       

                      Douglas

                      • 9. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                        Noel Carboni Community Member

                        doug87510 wrote:

                         

                        With 16 gig of RAM, you should be able to make 80% of it available to Photoshop.

                         

                        I always run Photoshop at 90% on my 16 GB system, actually.

                         

                        And no worries. 

                         

                        -Noel

                        • 10. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                          JonPaso Community Member

                          I have tried it with the GPU Checked and unchecked, no help either way.

                          drivers are the latest. Building my own computers from the 386 thru todays computers.

                          running Mem at 80% for Ps.

                          Running 4 HD Sata II . The scratch disk is just that ,no programs on it, 1 terabyte space 931 gig formatted.

                          I run no other programs while in PS.

                           

                          Jon

                          • 11. Re: When useing paint brushes, getting lag between the stroke and laying down the color. Win 7 64
                            JonPaso Community Member

                            Side note. PS runs better on Intel cpu, As hinted by A.

                            my next build will be Intel for PS.

                             

                            Jon