5 Replies Latest reply: Apr 3, 2012 2:08 PM by LRuser24 RSS

    LR4.1 RC edit in Ps problem

    Firillu Community Member

      I decided to try Lr4.1 and found that I had a preset to edit in Photoshop CS5 that in Lr3 and Lr4 trial version worked by first creating all the Tiffs in the batch in Lr, THAN opening them in Photoshop.

       

      Now, it is opening them one by on in Photoshop, which renders Photoshop unusable in the long time it takes to do so.

       

      Is this fixable?

        • 1. Re: LR4.1 RC edit in Ps problem
          Dorin Nicolaescu-Musteață Community Member

          If you want Lr to render the TIFFs before opening in Ps, you still can. Choose "render with Lightroom adjustmets" (you might need to restore your suppressed prompts in Prefs) or just set up Photoshop as a secondary editor.

          • 2. Re: LR4.1 RC edit in Ps problem
            Firillu Community Member

            that's not working unfortunately.

             

            i restored the suppressed prompts in prefs, created another new edit preset with Ps CS5 as a secondry editor, but it still opens all in Ps without rendering inLr4.1 first.

             

            this issue is new with Lr4.1. Lr4 and were working fine.

             

            This is a huge issue as I work with largish batches and if Ps opens the images, the computer is unusable.

            • 3. Re: LR4.1 RC edit in Ps problem
              c.frans w Community Member

              If you right-click them in the filmstrip it works, and in Library Grid View it works also , but in Loupe View right click only transfers that photo.

               

              Frans

              • 4. Re: LR4.1 RC edit in Ps problem
                Firillu Community Member

                No, not on this computer (MBP, OS X 10.7.3)

                 

                It won't work neihter from filmstrp nor grid.

                • 5. Re: LR4.1 RC edit in Ps problem
                  LRuser24 Community Member

                  Did you install ACR 6.7 RC in Photoshop? It seems that LR 4.1 RC will accept ACR 6.7 RC as compatible and as a consequence will no longer ask the "compatibility question" and will open the photos through Photoshop's ACR.

                   

                  If this is the case, the only way to go back would be to revert back to ACR 6.6 - however I don't know how to do that exactly (perhaps a full Photoshop deinstall/reinstall is needed for that).

                   

                  EDIT: Another possibility would be to create a second external editing preset for Photoshop. I am not 100% sure, but using that should force LR to render the images by itself, regardless of the compatibility of Photoshop's ACR, because Photoshop is then treated as "just another editor". This would be useful for all installations where LR and PS are ACR-compatible and LR should render the image.

                   

                  EDIT: 2: Unfortunately, the external editing preset does not work because LR recognizes the PS executable and behaves exactly as with the main "Edit in PS", i.e. it passes the photos to Photoshop's ACR instead of rendering them itself. However, there is a trick I learned somewhere: Copy the photoshop.exe to e.g. photoshop2.exe and set the editing preset to that copy. Then LR will no longer recognize it as Photoshop and will render the TIFFs/PSDs itself. I tried it out using 35 Raws at once - seems to work great. NOTE: a) I cannot guarantee that Photoshop will always behave as expected in this configuration (although I cannot imagine why it shouldn't), b) I only tried that out for Windows 7 (64 Bit) and c) when Photoshop is updated, don't forget to copy the executable again!

                   

                  Message was edited by: LRuser42