0 Replies Latest reply: Apr 4, 2012 1:06 AM by flexstan RSS

    Parameter is incorrect compile problem in virtual box

    flexstan Community Member

      Hi, since Linux support for flash builder (flex builder at the time) was dropped longer ago, we Linux users are forced to use virtualbox to run flash builder. Latest virtualbox 4.1 has an issue to build flex projects.

      I spent hours yestarday to try to solve this and finally only working solution I found was to downgrade back virtualbox to version 4.0

      Stuff I tried after upgrading to VB4.1

      1. building existing flex project in existing installation of flash builder 4.5

      2. using 4.5.0 sdk and 4.5.1 SDK to compile.

      3. trying to set lower flash target, and changing other deployment params

      4. getting rid or any aditional compiler parameters

      5. setting up same project again using same fodler with files

      6. setting up project from scratch with project source files got fresh from repo

      7. trying with new flash builder installation 4.6 trial with 4.6 flex sdk

       

      none of these helped and all resulted in compilation error

      Parameter is incorrect, flex problem, location "Unknown".

       

      As this thread explaines http://forums.adobe.com/thread/982266

      there may be other solution which is to setup new windows virtual machine and install flex there.

      but for me this is just another bad solution as mine so far (not upgrading VB)

       

      After downgrading back to VB 4.0 all even existing projects in both 4.5 and 4.6 built with no problems.

      Just to complete I'm using Windows 7 as OS in VM.

       

      If anyone finds acceptable solution please share..

       

      thanks.