6 Replies Latest reply: Jul 24, 2012 11:51 PM by Hadouken2 RSS

    FMLE 3.2 doesn't show audio devices

    _sfjuocekr_ Community Member

      At first when I had installed FMLE it would only see my G35 microphone, not much use and so I installed the Realtek drivers with stereo mix. As it seems FMLE only saw my microphone input, because it wouldnt pick up on the stereo mix and also didnt show Virtual Audio Cable.

       

      By now I had gone crazy, I can NOT stream without audio. So I had removed all audio devices, reinstalling and configuring each one of them. Now FMLE shows me no inputs at all!

       

      So please fix this problem, FMLE is obviously not finding audio devices where it's supposed to be looking and that it was able to "find" my G35 in the first place was just coincidence at best.

       

       

      Im on Windows 7 x64 SP1, FMLE3.2 and latest drivers for audio devices installed.

       

      Screenshot of VAC streaming music, stereo mix shows final output level of the chain: http://i.imgur.com/Z57RF.jpg

       

       

      edit: after some inspection I found out that FMLE is looking here:

       

      HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum

        • 1. Re: FMLE 3.2 doesn't show audio devices
          -cdplayer- Community Member

          thank you for give me this idea

           

          i believe it's because fmle only get device info in

          "HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum\{33D9A762-90C8-11D0-BD43-00A0C91 1CE86}"

           

          but win7 x64 got another 64-bit next to it

          "HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum 64-bit\{33D9A762-90C8-11D0-BD43-00A0C911CE86}"

           

          if you install x64 driver for your device fmle won't recognize it,

           

          so i copy everything under

          "HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum 64-bit\{33D9A762-90C8-11D0-BD43-00A0C911CE86}

           

          to replace the

          "HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum\{33D9A762-90C8-11D0-BD43-00A0C91 1CE86}"

           

          then my fmle 3.2 found my device and work fine

           

           

          in my case i found 3 places need to change

          "HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum\{33D9A762-90C8-11D0-BD43-00A0C91 1CE86}"

          "HKEY_USERS\S-1-5-21-1935447303-2600364710-218316825-1000\Software\Microsoft\ActiveMovie\d evenum\{33D9A762-90C8-11D0-BD43-00A0C911CE86}"

          "HKEY_USERS\S-1-5-21-1935447303-2600364710-218316825-1004\Software\Microsoft\ActiveMovie\d evenum\{33D9A762-90C8-11D0-BD43-00A0C911CE86}"

           

          maybe you can try to fix it with my method

           

          hope this will help ,and sorry for my poor english

          • 2. Re: FMLE 3.2 doesn't show audio devices
            cyxxhmx12 Community Member

            I've been having this same problem and -cdplayer-'s solution worked for me.  I just added the key for the preferred audio input device from devenum 64-bit to devenum in the 2nd key he posted above

             

            "HKEY_USERS\S-1-5-21-1935447303-2600364710-218316825-1000\Software\Mic rosoft\ActiveMovie\devenum\{33D9A762-90C8-11D0-BD43-00A0C911CE86}"

             

            Thanks -cdplayer- !

            • 3. Re: FMLE 3.2 doesn't show audio devices
              chrisczek Community Member

              Ive got the same Problem.

              Somehow fmle never uses the proper devices.

               

              i tried to use VAC but i dont get it to be used in fmle

              can anyone help how to fix?

               

              my system is windows 7 professional 64bit

              • 4. Re: FMLE 3.2 doesn't show audio devices
                Achmonek Community Member

                Have the same thing going on.

                Specs - Windows 7 x64 SP1

                Realteck HD Audio - Codec ALC892

                 

                Got this keys in registy:

                http://imageshack.us/g/11/38729889.jpg/

                http://img205.imageshack.us/img205/2408/59353332.jpg

                 

                Any help ???

                 

                UPDATE:

                Tryed with my old X-fi Fatal1ty Pro Xtreme Gamer - same thing.

                • 5. Re: FMLE 3.2 doesn't show audio devices
                  Benydc92 Community Member

                  That is the wrong key to look at, thats no the key to change. is this one:

                  HKEY_USERS\S-1-5-21-1312392363-2256890078-3854120228-1000\Software\Microsoft\ActiveMovie\d evenum\{33D9A762-90C8-11D0-BD43-00A0C911CE86}\Line In (Realtek High Definitio

                  • 6. Re: FMLE 3.2 doesn't show audio devices
                    Hadouken2 Community Member

                    I see the keys, how do I actually move the keys? There is no way for me to copy and paste or just move. If I copy keys, only name will be copied over but none of the other stuff inside like data and values get transfered over....