14 Replies Latest reply on May 29, 2013 11:14 AM by RobbyW

    Error Loading Tracklog

    Matti_J_434

      I have seen another post to this effect, but in that case, timing info was missing from the file.

       

      I am running LR4 on Lion 10.7.3.  I am able to successfully geotag my photos using a gpx file from my Holux M241 and Jeffrey Friedl's Geotagging LR plugin.  When I try to do it using the same gpx file via the new load tracklog feature in LR4, I just get the non-descript error "Error Loading Tracklog".

       

      The GPX file can be found here:

      http://dl.dropbox.com/u/2703272/Holux_M-241_Start_20120317-144038_Finish_20120317-153038.g px

       

      Any ideas what is wrong?  Is there a error log somewhere that would provide more helpful information?

       

      Thanks,

      Matti

        • 1. Re: Error Loading Tracklog
          b_gossweiler Level 5

          Matti,

           

          This file does not contain any trackpoints, but

          • A route with 51 route points
          • 51 way points

           

          I edited the file as follows:

          • added <trk>, </trk>
          • added <trkseg>, </trkseg>
          • removed <rte>, </rte>
          • changed all <rtept> to <trkpt>
          • changed all <wpt> to <trkpt>

           

          then the file can be loaded into LR4. You can download a copy from here:

          https://www.yousendit.com/download/M3BuMWZPYStUWUExZXNUQw

           

          I would check the Holux documentation on how to record a proper tracklog. Jeffrey's plug-in seems to be tolerant enough to consider your route points as track points.

           

          Beat

          • 2. Re: Error Loading Tracklog
            Matti_J_434 Level 1

            Yes, that worked.

             

            So I did a little more research.  Looking at the xml schema for the GPX format, there does not seem to be much of a difference between a route and a track.  All the elements are the same between a route and a track.  To me they seem redundant.

             

            There appears to be three main types of points, waypoints, tracks and routes.  GPS Babel can convert any type to any type. So I used GPS Babel to convert the route to a track and it has the same effect you suggested by doing a global search and replace for various elements.

             

            I had a look at the Holux tool, and I did not find a way to change the output from a route to a track. So it looks like GPS Babel is the easiest way to make the change.

             

            I tried my original file with waypoints and route at Aperture, and it handled it no probelm.

             

            So it seems that LR is working as advertised.  It is looking for tracks, importing them and ignoring the rest.

             

            It would be nice if LR would handle routes as well, the elements for a route are the same so it is probably not a lot of work to add it.  It seems that Jeffrey and Aperture must already be doing this.  At the time I bought the Holux M241 it was one of the more popular dataloggers available, so I am sure others will likely run into this problem.

             

            For now, I will eiher continue to use Jeffrey's plug in which I bought for the first time back in LR2.  Or maybe create an automator action with GPS Babel to convert ruotes to tracks.

             

            Perhaps Adobe will add route processing as a feature request for the next point version?

             

            Thanks for the help!

            • 3. Re: Error Loading Tracklog
              b_gossweiler Level 5

              Matti_J_434 wrote:

               

              Perhaps Adobe will add route processing as a feature request for the next point version?

               

              Thanks for the help!

              I guess you'd have to put in a feature request for this, if you want it to happen. Just as a side note, Garmin MapSource won't open the *.gpx file either ...

               

              Beat

              • 4. Re: Error Loading Tracklog
                kgeissler2

                I also have a Holux M241 and can not load any of the GPX files it creates either.  I guess I will have to stick to GeoSetter to geotag my photos.  I tried GPS Babel, but when I loaded the output file into LR4, it seemed to only load the track and not all of the waypoints.

                • 5. Re: Error Loading Tracklog
                  wrapper99

                  I am also using  Holux 241 and GPS babel and having load errors on LR 4.

                   

                   

                  Geotag Lite on iphone worked fine.

                  • 6. Re: Error Loading Tracklog
                    kgeissler2 Level 1

                    The best fix I found was to download GPS Babel and use that do download the data from the M241.  Here is the link I found:

                     

                    http://www.idimager.com/forum/viewtopic.php?f=29&t=9245

                    • 7. Re: Error Loading Tracklog
                      wrapper99 Level 1

                      Tried several options including route to track... no sucess.

                      • 8. Re: Error Loading Tracklog
                        kgeissler2 Level 1

                        It needs to be Routes to Waypoints, not Routes to Tracks

                         

                        http://www.idimager.com/forum/viewtopic.php?f=29&t=9245#p55812

                        • 9. Re: Error Loading Tracklog
                          wrapper99 Level 1

                          Tried Routes to Waypoints too. Did not work.

                           

                          But I forgot to mention I am using Lightroom 4, not ID imager.

                          • 10. Re: Error Loading Tracklog
                            kgeissler2 Level 1

                            I am also using LR4.  I post above link to show you how to get a correct GPX file.  The software that comes with the M241 produce a "weird" GPX that can't be read by many apps.  If you use GPS Babel to produce the GPX file, it will work great in LR4.  Just make sure you use the filter to convert Routes to Waypoints.  I have used this method and my GPX file loads perfectly into LR4.  Just hookup the Holux to your USB port, start GPS Babel and select the Holux M241, set the correct COM port, set the filter, and set the output file to GPX.  Works like a champ.

                            • 11. Re: Error Loading Tracklog
                              wrapper99 Level 1

                              That worked. 

                               

                              The problem was I was downloading a file using the Holex utility and then using GPSBabel to read the Holex output file.

                               

                              Using GPSBabel to read directly from Holux did the trick.

                               

                              Thanks.

                              • 12. Re: Error Loading Tracklog
                                RobbyW

                                Hi,

                                 

                                do you use any special settings in GPSBabel to doownload the files like Lightroom wants them to be ?

                                 

                                Many thanks

                                 

                                Robert

                                • 13. Re: Error Loading Tracklog
                                  Matti_J_434 Level 1

                                  Under filters you'll want to check off transform and convert routes to tracks.  Here is a screen shot

                                  Screen Shot 2013-05-28 at 8.50.09 PM.png

                                  • 14. Re: Error Loading Tracklog
                                    RobbyW Level 1

                                    Hi,

                                     

                                    many thanks for your help ! But, unfortunately, I still have some problems :

                                     

                                    Here you can see the result of two different GPX files ( one created by the Holux-tool and one created by GPSBabel with your filter applied :

                                     

                                    GPS-Babel output :

                                    <?xml version="1.0" encoding="UTF-8"?>

                                    <gpx

                                      version="1.0"

                                      creator="GPSBabel - http://www.gpsbabel.org"

                                      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                                      xmlns="http://www.topografix.com/GPX/1/0"

                                      xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd">

                                    <time>2013-05-29T17:41:03Z</time>

                                    <trk>

                                      <name>track-1</name>

                                      <desc>Log every 108754081 sec, -132102522 m</desc>

                                    </trk>

                                    </gpx>

                                     

                                    Holux-Tool output ( only a part of it )

                                     

                                    <?xml version="1.0"?>

                                    <gpx

                                    version="1.0"

                                    creator="Holux Utility"

                                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                                    xmlns="http://www.topografix.com/GPX/1/0"

                                    xsi:schemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd">

                                    <wpt lat="51.342556" lon="6.579871">

                                    <time>2013-05-29T17:02:35Z</time>

                                    <ele>96.63</ele>

                                    <speed>1.76</speed>

                                    <name><![CDATA[Point 0]]></name>

                                    </wpt>

                                    <wpt lat="51.342560" lon="6.579908">

                                    <time>2013-05-29T17:02:40Z</time>

                                    <ele>89.21</ele>

                                    <speed>0.71</speed>

                                    <name><![CDATA[Point 1]]></name>

                                    </wpt>

                                    <wpt lat="51.342556" lon="6.579910">

                                    <time>2013-05-29T17:02:45Z</time>

                                    <ele>85.97</ele>

                                    <speed>0.47</speed>

                                    <name><![CDATA[Point 2]]></name>

                                    </wpt>

                                     

                                    As you can see, the putput of Holux contains some PGP-point, and the one created by GPSBabel only the header.

                                     

                                    Lightroom accepts the file by GPSBabel, but doesn't show any points or tracks,

                                     

                                    Here is a screenshot how I configured GPSBabel ( unfortunatly in German )

                                     

                                    GPSBabel01.png

                                    GPSBabel02.png

                                     

                                    Do you or does anyone else have any idea what could be wrong ?

                                     

                                    Many thanks for future answers !

                                     

                                    Robert