1 Reply Latest reply on Apr 13, 2012 4:59 AM by BKBK

    ssl 3.0


      Hi All,


      I'm having some major trouble trying to get an HTTPS request to work, we've been sent an SSL certificate for use with some web service work. I've added the cert to the correct keystore but continue to receive connection refused errors. I tried monitoring the request with Fiddler and for some reason the raw request headers show that CF is trying to establish an SSL 2.0 handshake - the server doesn't support 2.0.


      Ive also tried using CFX_HTTP5 which didn't help me as well.


      I've read numerous articles and have followed the instructions listed, I'm really stuck for ideas.


      I'm running CF Developer edition from my local - version was changed to standard as developer and enterprise have a known bug with SSL.


      I've tried disabling SSL 2.0 in the registry.


      The only way I've managed to get this to work is by adding the certificate to Fiddler and running my request with CFX_HTTP5 using Fiddler as a proxy.