10 Replies Latest reply: Jul 6, 2012 6:53 AM by Carlos1327 RSS

    Apache not working  with FMS 4.5 on Windows 2008


      FMS 4.5.1 Windows 2008 SP2 (64bit).


      I've searched everywhere for a possible solution to this, so my apologies if this has been asked before and my thanks for any potential help that anyone can offer to help resolve this.


      We are deploying Adobe Flash Media Server 4.5.1 on a new server but Apache does not work (does not serve html files or stream Quicktime H.264 files).


            Assorted Problems & Error messages:

      1.  The webroot/index.html page loads locally, but the HLS/HDS streams result in a 2032 error.


      2. The webroot/index.html page does not load from  external locations:

  (does not load externally).

  (our old server, FMS 4.0 and Windows 2003). Everything on this server works, the 2 major differences being that it is running FMS 4.x on Windows 2003.


      Some RTMP streaming works externally and internally (f4v files):

      http://www.librarymedia.net/flash/player.html?source=rtmp:// 50kbps.f4v


      FMS does not stream Quicktime H.264 files even though f4v files work.

         New server (does not work): http://www.librarymedia.net/flash/player.html?source=rtmp:// l.mov

                                    (f4v works): http://www.librarymedia.net/flash/player.html?source=rtmp:// 50kbps.f4v


      Old server (Quicktime/H.264 file works): http://www.librarymedia.net/flash/player.html?source=rtmp:// l.mov


      Apache does not serve Quicktime/H.264 files: I made sure that Apache had all of the correct mime types specified.


          Error messages and attempted solutions:

      1. Apache's erro_log file:

             a. httpd.exe: Could not determine the server's fully qualified domain name, using for ServerName


      2. FMS master.log file

            a. FMSHttpd -k start returned 1:


      Solutions: http://wiki.apache.org/httpd/CouldNotDetermineServerName

      1a:  Edited httpd.conf file to include ServerName


      1b: The presence of this error message also indicates that Apache httpd was unable to obtain a fully-qualified hostname by doing a reverse lookup on your server's IP address.

      In order for the server to accept external connections a reverse DNS lookup needs to be created. I created a reverse DNS lookup and  edited the /etc/hosts file to include the IPaddress, Fully Qualified Domain Name (FQDN), shortname.


      This is the format suggested by the article:

            localhost.localdomain   localhost       foo.example.com


      Running the nbtstat -a command on the machine results in the following:


      WIN-8AIHI2J0524<00>  UNIQUE      Registered

      THS-LIBRARY-VOD<00>  GROUP       Registered

      THS-LIBRARY-VOD<1C>  GROUP       Registered

      WIN-8AIHI2J0524<20>  UNIQUE      Registered

      THS-LIBRARY-VOD<1B>  UNIQUE      Registered


      So the FQDN = WIN-8AIHI2J0524.Ths-library-vod.local


      I edited the /etc/hosts to the following (with versions using the local host ip and the external ip address, IPv4 is being used):


      # The following lines are desirable for IPv6 capable hosts

      ::1 localhost ip6-localhost ip6-loopback

      fe00::0 ip6-localnet

      ff00::0 ip6-mcastprefix

      ff02::1 ip6-allnodes

      ff02::2 ip6-allrouters

      ff02::3 ip6-allhosts


      I've also read Adobe's port configuration articles and  changed the ports that Apache and FMS use as specified in the conf/fms.ini file, but nothing has worked so far. I restored everything to the original settings until I can find out exactly how to fix this.


      Thank you.

        • 1. Re: Apache not working  with FMS 4.5 on Windows 2008
          Carlos1327 Community Member

          Jus looked at the edge log and found the following error: Application HDS-vod is not defined. Using the following article to try to resolve this just in case anyone else runs across this problem:


          http://help.adobe.com/en_US/flashmediaserver/devguide/WSeb6b7485f9649bf23d103e5512e08f3a33 8-8000.html#WS082c29d45e6ad098-2074c7cd1322864f23b-8000

          • 2. Re: Apache not working  with FMS 4.5 on Windows 2008
            Nitin Goel Adobe Employee

            Did you properly installed the server or

            1. Overritten the old server with the new one.

            2. Just untar the linux installer zip and copied them.


            The httpd.conf issue happens to me, in case I just do unzip of the bundle on linux and start using it.. If I do proper ./installFMS and then use the fms from installed path, then it works fine..

            • 3. Re: Apache not working  with FMS 4.5 on Windows 2008
              Carlos1327 Community Member

              I uninstalled FMIS and re-installed everything (Windows 2008 SP2 64bit, FMIS 4.5.1).


              1. The Apache errors are gone (FMSHttpd -k start returned 1: & Could not determine the server's fully qualified domain name errors not coming up).


              2. I am now getting the following error in the edge log: Failed to create listener for adaptor _defaultRoot_, IP , port 80: TCCommBridge::createListener bind failed!!!.


              Same problems persist (IPs .5 and .6 are two different servers):

                   New FMS 4.5 server: (does not load externally).

                   Old FMS 4.x server: (everything works)


              Errors from the webroot/index.html page:

                    Error # 2032 when trying to play HLS & HDS files (added mime types to Apache).

                    RTMP files play fine.


              RTMP streaming works externally, but H.264 files do not work for some reason:

              http://www.librarymedia.net/flash/player.html?source=rtmp:// 50kbps.f4v works, but my own files do not work, e.g.,

              http://www.librarymedia.net/flash/player.html?source=rtmp:// l.mov


              This file works with the old server, so I don't think that it is a problem with the file itself:

              http://www.librarymedia.net/flash/player.html?source=rtmp:// l.mov


              HLS and HDS streaming from the webroot folder does not work. RTMP streams f4v files, but not H.264 .mov files.


              I have no idea why this is happening and therefore no clue on how to fix it.


              Thank you for the help Mr. Goel.

              • 4. Re: Apache not working  with FMS 4.5 on Windows 2008

                Narrowed it down to this:


                1. Fixed: Got Apache to serve html pages to external connections:


                2. FMS does not stream Quicktime/H.264 files, f4v files work.http://www.librarymedia.net/flash/player.html?source=rtmp:// 50kbps.f4v


                Re-encoded the file in Media Encoder. Changed extension from .f4v to .mov and the file  works. This is therefore a problem with the way the files are being encoded by Compressor. I don't know what the difference is between FMS 4.x and 4.5 when it comes to this issue since the .mov files from Compressor work with no problem with 4.x.


                http://www.librarymedia.net/flash/player.html?source=rtmp:// l2.mov



                I don't want to use Media Encoder because:

                1. My workflow is based on Compressor, and more importantly,
                2. I feel that I get better results with Compressor (better quality).


                Any  ideas, anyone?



                • 5. Re: Apache not working  with FMS 4.5 on Windows 2008
                  Carlos1327 Community Member

                  Solved. Followed all of the directions to the articles listed in the original post and resolved all errors.


                  Solved the Quicktime/H.264 issue by checking the hinting streaming dialog in Compressor.


                  Everything is working now.

                  • 6. Re: Apache not working  with FMS 4.5 on Windows 2008
                    Carlos1327 Community Member

                    The problem has returned.

                    1. Everything works internally: pages, HLS/HDS streams, rtmp streams.
                    2. Nothing works from external connections:


                    Streams result in the following error: server not found rtmpt:// (error from http://www.librarymedia.net/Pages/THS-Graduation2012.html , works fine internally).


                    80/vod suggests that there is a problem with port 80. I'll look at the conf files and change the port settings for FMS and Apache (what I did above).


                    Any help would be greatly appreciated.

                    • 7. Re: Apache not working  with FMS 4.5 on Windows 2008
                      Apurva Udaykumar FormerEmployees



                      Can you just try a telnet from any external client to the public IP of the FMS machine and port 80 just to ensure there are no firewall issues happening?

                      Also, can you check if you have not set any domain restrictions say in allowedSWFdomain.txt & allowedHTMLdomains.txt if you are using live or vod sample applications?




                      • 8. Re: Apache not working  with FMS 4.5 on Windows 2008
                        Carlos1327 Community Member

                        First, I should let you know what I've done:

                        1. I could not establish a connection when I pinged the external IP, so I contacted our network admin to make sure that ports 80, 1935, and 1111 were open on this server. They are open.
                        2. Windows Firewall is turned off.
                        3. Everything works internally so FMS and Apache are serving rtmp and HDS/HLS streams.
                        4. Configured Apache to use port 80 and configured Flash Media Server not to use port 80 to see if that was the problem (did not fix connection problems):

                        http://help.adobe.com/en_US/adobemediaserver/configadmin/WSdb9a8c2ed4c02d261d76cb3412a40a4 90be-8000.2.3.html#WS829c643386b9152167c57eb5131f88a5f28-7ffa.2.3

                                 a. rootinstall/Apache2.2/conf: Changed the line Listen 8134 to Listen 80.

                                 b. rootinstall/conf/fms.ini: Removed 80 from the ADAPTOR.HOSTPORT parameter, ADAPTOR.HOSTPORT = :1935.


                        Windows: Telnet commands:

                        o 80

                        o 1935


                        Results: Could not open connection to the host on port 80 or 1935: Connect failed.


                        OS X: telnet 80

                        <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">


                        <title>501 Method Not Implemented</title>


                        <h1>Method Not Implemented</h1>

                        <p>to /index.html not supported.<br />



                        <address>Apache/2.2.21 (Win32) DAV/2 Server at WIN-8AIHI2J0524.Ths-library-vod.local Port 80</address>



                        Thank you for your help Mr. Udaykumar.

                        • 9. Re: Apache not working  with FMS 4.5 on Windows 2008
                          Apurva Udaykumar FormerEmployees

                          Hi Carlos,


                          I'm able to telnet your machine on port 80 but connection fails on port 1935. Can you please reconfirm that port 1935 is open?


                          You need to add port 80 in Apache and not replace it. So your httpd.conf will have :

                          Listen 80

                          Listen 8134


                          Your fms.ini should have :

                          ADAPTOR.HOSTPORT = :1935


                          Once you make these changes, please restart your server and then try.

                          If you're unable to access anything on the server, could you please check the Master log under <root_install>/logs for any errors and check what process is bound to those ports.



                          Ms Apurva

                          • 10. Re: Apache not working  with FMS 4.5 on Windows 2008
                            Carlos1327 Community Member

                            Ms. Apurva ,


                            I changed the files back as you suggested (the failure was occuring with the default settings) and our admin assured me yesterday that the ports that I inquired about were open. I'll ask him again.


                            The telenet command for both ports 80 and 1935 result in Connect failed for me. I'll check Windows Firewall (turned off)  and McAfee to see if there is anything there blocking ports.


                            Confirm that external connections are blocked: (does not open outside of localhost). No problem accessing with our old server (


                            I ran this command in nmap and here are the results (11 ports closed): nmap -Pn80


                            Starting Nmap 6.01 ( http://nmap.org ) at 2012-07-06 08:29 Eastern Standard Time

                            Nmap scan report for

                            Host is up (0.00092s latency). nmap -p 80 says that the host is down (for both ports).

                            Not shown: 988 filtered ports


                            PORT     STATE  SERVICE

                            1720/tcp open   H.323/Q.931

                            6000/tcp closed X11

                            6001/tcp closed X11:1

                            6002/tcp closed X11:2

                            6003/tcp closed X11:3

                            6004/tcp closed X11:4

                            6005/tcp closed X11:5

                            6006/tcp closed X11:6

                            6007/tcp closed X11:7

                            6009/tcp closed X11:9

                            6025/tcp closed x11

                            6059/tcp closed X11:59


                            Nmap done: 1 IP address (1 host up) scanned in 5.72 seconds


                            Host status: up

                            open ports: 1

                            filtered ports:988

                            Closed ports:  11



                            ipv6: not available

                            MAC: not available.


                            Master log file:

                            2012-07-0609:22:416712(i)2581173FMS config <NetworkingIPv6 enable=false>-


                            2012-07-0609:22:416712(i)2581173FMS running in IPv4 protocol stack mode!-


                            2012-07-0609:22:416712(i)2581173Host: WIN-8AIHI2J0524 IPv4:


                            2012-07-0609:22:416712(i)2571011Server starting...-


                            2012-07-0609:22:466712(i)2581413H:\Program Files\Adobe\Flash Media Server 4.5\Apache2.2\bin\httpd -f ./conf/httpd.conf -d "H:\Program Files\Adobe\Flash Media Server 4.5\Apache2.2" -n FMSHttpd -k start returned 0: -


                            2012-07-0609:22:466712(i)2581224Edge (1508) started, arguments : -edgeports ":1935" -coreports "localhost:19350" -conf "H:\Program Files\Adobe\Flash Media Server 4.5\conf\server.xml" -adaptor "_defaultRoot_" -name "_defaultRoot__edge1" -edgename "edge1".-


                            2012-07-0609:22:466712(i)2571111Server started (H:\Program Files\Adobe\Flash Media Server 4.5\conf\server.xml).-



                            edge log:

                            2012-07-0609:22:461508(i)2581173FMS detected IPv6 protocol stack!-


                            2012-07-0609:22:461508(i)2581173FMS config <NetworkingIPv6 enable=false>-


                            2012-07-0609:22:461508(i)2581173FMS running in IPv4 protocol stack mode!-


                            2012-07-0609:22:461508(i)2581173Host: WIN-8AIHI2J0524 IPv4:


                            2012-07-0609:22:471508(i)2631174Listener started ( _defaultRoot__edge1 ) : localhost:19350/v4-


                            2012-07-0609:22:481508(i)2631174Listener started ( _defaultRoot__edge1 ) : 1935/v4-


                            2012-07-0609:22:491508(i)2631174Listener started ( _defaultRoot__edge1 ) : (rtmfp-core)/v4-


                            2012-07-0609:22:491508(i)2631174Listener started ( _defaultRoot__edge1 ) : (rtmfp-core)/v4-


                            2012-07-0609:22:491508(i)2631509Public rtmfp-core addresses for listener _defaultRoot__edge1 are:;


                            2012-07-0609:22:491508(i)2631174Listener started ( _defaultRoot__edge1 ) : (rtmfp)/v4-


                            2012-07-0609:22:491508(i)2631174Listener started ( _defaultRoot__edge1 ) : (rtmfp)/v4-


                            Not sure what to do.