20 Replies Latest reply: Jul 25, 2012 4:56 AM by ShackyC RSS

    Audio out of sync

    Jules NYC

      I am trying to encode a two hour sequence and the audio is completely out of sync in a few locations.  I encoded this same sequence 4 times and each time the audio is out of sync is different areas.  All the footage was shot with an HD Flip Cam, and I've been encoding footage shot on the this camera for 5 months with no problems.  It plays perfectly in Premiere.  The sequence is twice the length as my others, but I can't imagine Adobe can't handle that.

       

      Does anyone have any suggestions as to what the problem might be?  I'm trying to encode the video to Windows media.  The footage is 1280x720 (1), 30,000 fps, 44100 Hz-compressed.

       

      The sequence is 1280x720 (1) 29,97 fps 48000 Hz - Stereo.

       

      I'm on a learning curve here as I'm still learning editing as well as understanding Adobe.

       

      Any help would be so very appreciated.

       

      Thanks,

      Jules

        • 1. Re: Audio out of sync
          Todd_Kopriva Adobe Employee

          What exact versions of Premiere Pro and Adobe Media Encoder? Have you installed the latest updates? There are bug fixes for audio/video synch in the updates for CS5.

           

          What operating system? What kind(s) of source footage? Do you have any third-party effects or codecs installed?

          • 2. Re: Audio out of sync
            Jules NYC Community Member

            Thanks for your reply.  I have Adobe PP CS5 - and I believe that I have installed all the latest

            updates.  In fact, that was the first thing that I tried.  Unless there are updates that I'm not aware of?  I

            installed them right in Adobe by clicking the help tab and clicking install updates.

             

            My operating system is Windows 7, Intel (R) Core (TM) i7 CPU 950 @ 3.07 GHz

            Ram 6.00 GB

            64 bit Operating System

             

            If you need any more info I'm happy to provide.

             

            MY footage was shot with a HD Flip Cam - 1280 x 720, 44100 Hz compressed

            The sequence I created is 1280 x 720, 48000 Hz - Stereo

             

            Any advice would be appreciated.

             

            Jules

            • 3. Re: Audio out of sync
              Todd_Kopriva Adobe Employee

              > I believe that I have installed all the latest updates.

               

               

               

              Please check.

              • 4. Re: Audio out of sync
                rik.mahieu

                I am/was having the same problem.

                 

                I shot video on canon Mk5 II (1920x1080 @ 25fps), and recorded external audio on a zoom H4n. I transcoded the h.264 canon footage with neoscene to cineform avi. Edited my sequences. Exported video as TIFF sequence to After Effects for color correction, then exported from AE to uncompressed avi, and imported back in PP. Audio from zoom H4n synced in PP, then exported to Soundbooth. In Soundbooth applied effects and noise removal, exported as mono track and saved as 32 bit floating point stereo .wav file. Audio imported in PP.

                 

                Now my project sequences consisted of 3 audio tracks and 2 video tracks. With 1 active video track (AE color corrected avi) and 1 active audio track (Soundbooth 32 bit floating point stereo .wav)

                 

                In PP sequence video and audio are in sync.

                 

                Export to uncompressed avi with uncompressed sound was OK.

                Export to h.264 (video: 1024x576 @25fps, both 1-pass, 2-pass, progressive, profile: high @ level 3.2, bitrate 2-4 and 3-4 | audio AAC stereo, 44.1 kHz, 192 kbps) OUT OF SYNC. Normally these settings are good.

                 

                My workstation:

                Intel i7 920 @ 3.20 Ghz

                12 GB RAM

                Nvidia GTX 275, driver 259.81

                Windows 7

                 

                Premiere Pro 5.03

                Adobe Media Encoder 5.0.1.0

                 

                Now when I play back in:

                - Quicktime Player (ver. 7.7 build 1680.34) audio is completely out of sync, video is behind of audio 500-1000ms.

                - VLC (version 1.1.1.11, both with and without GPU acceleration) - IN SYNC

                - Media Player Classic (build 1.3.2086.0, FFmpeg compiler GCC 4.4.1), audio is out of sync 500-1000ms, BUT when I uncheck H264/AVC (DXVA) [6.4.0.2 ffmpeg], audio is in sync.

                 

                So I am not really sure what the problem is right now. I thought the AAC encoder was the problem. But maybe, it seems either FFmpeg playback or Nvidia driver is not working properly with h.264 exported from MCE. I will update my Nvidia driver, see if DXVA works properly then. If not I will update Media Player Classic and see if that makes any difference.

                 

                Any other suggestions?

                • 5. Re: Audio out of sync
                  JSS1138 Community Member

                  So I am not really sure what the problem is right now.

                   

                  I am.  The QuickTime player.  Don't use it.

                  • 6. Re: Audio out of sync
                    rik.mahieu Community Member

                    I normally don't use QT player on PC, but a lot of clients do. And I would like them to watch video's in sync. So I would like to know, if there are known problems with h.264 output from Adobe Media Encoder version 5.0.1.0: mpeg4 header, synchronization markers, AAC etc.? I have not yet updated MPC and ffmpeg.

                     

                    @Todd: What happened to update 5.04? 

                    • 7. Re: Audio out of sync
                      Todd_Kopriva Adobe Employee

                      > @Todd: What happened to update 5.04? 

                       

                       

                      Here are the details of the Premiere Pro CS5 (5.0.4) update. Note that it's just for a single fix for Mac OS and is irrelevant for Windows.

                      • 8. Re: Audio out of sync
                        JSS1138 Community Member
                        I would like them to watch video's in sync.

                         

                        Then you may have to talk to the folks in Cupertino and get them to fix their software.

                        • 9. Re: Audio out of sync
                          rik.mahieu Community Member

                          Ok, I tried to export to .mp4/H.264 on my mac, problem is solved, but not quite the workflow I prefer..

                           

                          In my windows project the video and audio were aligned and in sync. Now I exported the video and audio from my windows project separately and imported them back to premiere pro on my mac. Now the video and audio in my project are NOT synchronized when I hit 'Render entire work area'. Even when I export to H.264, still not in sync. When I offset the audio 2 frames further, the project is in sync, and when I export to H.264, also the video file is in sync.

                           

                          So now with Mac it's WYSIWYG, in Windows it is a bit vague, because it's WYSIWYG in VLC player, the rest is out of sync.

                           

                          Specs:

                          Mac Pro 2011 (3.1)

                          32 GB RAM

                          Nvidia Quadro 4000 (2048 MB)

                           

                          Mac OS X version 10.6.8

                          Premiere Pro version 5.04

                          Media Encoder version 5.0.1.0

                           

                          PC

                          Asus P6T6 WS Revolution

                          Intel i7 920

                          MSI Nvidia GTX275 (896 MB)

                          12 GB RAM

                           

                          Windows 7 Ultimate Edition

                           

                          Premiere Pro version 5.03

                          Media Encoder version 5.0.1.0

                          • 10. Re: Audio out of sync
                            rik.mahieu Community Member

                            I still haven't fixed this problem. When I use external audio (from either Soundbooth or delivered from studio), the audio is in sync with premiere project, but when I export to H.264 I need to skip the audio 3-4 frames.

                             

                            Render Settings:

                             

                            PAL 25fps (progressive)

                            Profile (Main or High depending on resolution)

                            Level: 3.1, 3.2 (576p) or 4.2 (720p)

                            Bitrate: VBR (1-pass), 1.6 / 3.2 (576p) or 6 / 9 (720p)

                            Keyframe Distance: off or 25 or 50 frames

                             

                            Audio: AAC, Stereo, 44.1 Khz (High), 192 - 256 kbps

                             

                            Multiplexer: standard

                             

                            PPro version 4.02

                            Media Encoder: 5.0.1.0

                            • 11. Re: Audio out of sync
                              JSS1138 Community Member

                              Premiere Pro is up to 4.2.1.  Try updating.

                              • 12. Re: Audio out of sync
                                ikander

                                I'm glad I'm not the only one with this issue--this has been driving me nuts for a while. If I export out h.264 mp4s from premiere, they play out of sync by 1 or 2 frames when played back with quicktime on a PC.

                                 

                                Yes, I realize that VLC is a superior player, but I can't force my clients to download a piece of software. They're viewing it in quicktime and it looks out of sync.

                                 

                                Any encoding settings I should try from media encoder to prevent this from happening?

                                • 13. Re: Audio out of sync
                                  JSS1138 Community Member

                                  It's not a problem with the file.  If it were, it'd play out of sync with all players.

                                   

                                  It's a problem with the player.  QuickTime sucks, on all levels.  Best not to use it for anything.

                                  • 14. Re: Audio out of sync
                                    ikander Community Member

                                    It's hard to tell a client their player is broken and they have to download a new piece of software.

                                    • 15. Re: Audio out of sync
                                      rik.mahieu Community Member

                                      Try using H.264 in an .MOV container, instead of .MP4. I used this fix for jitter problems in After Effects, whereby the export looks shaky (mixing up frames forward and backwards). Because of the different results in various media players I think the GPU accelerated video players (DXVA), or lack of, just mess up the sync with .mp4 (it might be the GPU drivers, it might be DXVA in media player, it might be adobe update), I think there are too many factors to really get to the cause. But after a clean install of OS and Adobe CS and updating to 4.2.1 and updating my GPU drivers I didn't have this problem with .mp4 anymore.

                                      • 16. Re: Audio out of sync
                                        ikander Community Member

                                        Thanks! This is helpful.  In my old FCP workflow, I'd provide an h.264 in a .mov container via compressor, so this might do the trick.

                                        • 17. Re: Audio out of sync
                                          JSS1138 Community Member

                                          It's hard to tell a client their player is broken and they have to download a new piece of software.

                                           

                                          Maybe, but that's the same situation a director or DP would face when a client watches his movie on an uncalibrated monitor and the colors look off.

                                           

                                          You can't control what the client does once you're finished.  All you can do is your job right.  And you've done that.  If clients complain about bad colors, you suggest they calibrate their TVs.  If they complain about sync, you tell them to use a better player.

                                          • 18. Re: Audio out of sync
                                            rik.mahieu Community Member

                                            To bypass client-software issues, you could load your renders onto Vimeo (pro) and send your client a direct link (vimeo basic takes too long to transcode, so you should buy a premium account), this way you know that everyone is watching from the same source. But the fastest way is to make your own http-staging environment (JWplayer) and put your .mp4 on your own server via ftp (if you have one), then your clients can watch it in their browser and even on their mobile device. Their browser need to be up-to-date. If not, they will be notified by their browser that they should install a plugin, or update their software. This way you avoid the perception that things might be your fault. It takes a few steps to set this up, but it's neat. You could also embed it through vimeo on your own staging environment.

                                            • 19. Re: Audio out of sync
                                              ShackyC Community Member

                                              Having the same issue when exporting from Pr CS5. Only one of the 7 audio tracks seems to be out of sync by about half a second in the exported mpeg file. I have to export in mpeg2-DVD format is the file is to be authored to DVD using Encore.

                                               

                                              just installing the Pr update as we speak, but from the looks of some of the responces I don't think this will fix the issue.

                                               

                                              I've tried changing the audio clips to a different audio track, but this doesn't help. It's specific to the actual audio clips, which were recorded in the same format on Soundbooth as all of the other clips.

                                              • 20. Re: Audio out of sync
                                                ShackyC Community Member

                                                I found that Rendering and Replacing the audio files will give a more accurate project representation of what the exported files are.

                                                 

                                                simply select all your audio tracks, then go to Clip>Audio Options>Render and Replace.

                                                 

                                                My project appeared to be completely in sync before doing this, but after I did it, the audio files were out of sync (the same as the original export file). Once Render and Replace was done, I adjusted the position/syncing of the problem clips so that there were in the correct place, then exported and found that there was no longer any syncing issues with the exported file.