6 Replies Latest reply: Sep 21, 2012 9:36 AM by katdavis1 RSS

    Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND

    Margiiie Community Member

      Hi,

       

      I'm having trouble with the hotspot links in Fireworks CS5. When I've added the links I want and click F12 to preview in Chrome, it loads the page without problems. But when I click on one of the links I get the following message:

       

      Webpage cannot be found

      There was no webpage at the adress: file:///C:/Users/Margiiie/AppData/Local/Temp/FWTemp/LinkedPage.htm

      Error 6 (net::ERR_FILE_NOT_FOUND): Could not find file or catalogue.

       

      (translated by me from Swedish to English, so it might not be 100% correctly translated).

       

      A few days ago I used Revo Uninstaller Pro to remove some files from my computer, and I remember clicking "Remove temporary Internet Files" on all of the web browsers. This might have something to do with the problem, but I can't seem to able to recover the files I removed..

       

      So, I really need som help here! Do you think that the removal of the temp files is the problem? What can I do about it?

       

      Regards,

      Margiiie

        • 1. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
          groove25 Community Member

          So when you click on the link in Chrome, it looks for a page entitled "LinkedPage.htm" at the indicated file path... Did you create this page in FW (or another application)? If you did, then I might try previewing that page in Chrome, on the assumption that FW would re-generate a preview for it.

           

          However, I don't think that the "Remove temporary Internet Files" command would have affected your FW files, as "FW Temp" is probably a folder for Fireworks, not the web browser itself. That's just a guess, though. I'm more inclined to think that the link is incorrect (i.e., it doesn't match the current file name of that page) or that the page itself was never created. Are either of those scenarios possible?

          • 2. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
            Margiiie Community Member

            Hi,

             

            Thank you for your answer!

             

            Yes, I created the LinkedPage.htm-page in FW. I just tried previewing it in Chrome, but the problem still remains.

             

            When I export the file to PDF the links work just fine. They also work if I send the file to someone else and they click F12 to preview it.

             

            I can't find any "...AppData/Local/Temp/FWTemp"-folder, so that makes me think that the folder might have been thrown away by the Revo uninstaller-program. I didn't think it would matter to throw away temp files (I still think it seems strange). Is there any way to change the settings (or something) so that the FW temp files will be re-generated again and in a new folder? Or is there any other possible solution?

             

            Best regards,

            Margiiie

            • 3. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
              groove25 Community Member

              Have you tried previewing in another browser, like Firefox?

               

              A quick idea: Refresh the page in Chrome the next time you preview it. Maybe it's holding onto a cache of some sort.

               

              If refreshing the page in Chrome doesn't help, I'd delete the contents of the FWTemp folder. It's just a folder to which Fireworks exports HTML files, images, etc. for the purpose of previewing in browsers. Anything in this folder is just meant to be temporary and likely gets rewritten every time you run a Preview in Browser command anyway.

              • 4. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
                Margiiie Community Member

                Yes, I've tried to preview in Firefox and the same problem occurs :/

                 

                I also just tried to refresh the page (and all the other pages in preview mode) before clicking the links, but it just doesn't work. This just dosen't make sense, I've never had this problem before. I've created pages in FW before and previewed them in Chrome without any problems. I also just opened another project I worked on in FW a few months ago (without any problems back then) and now that file has the same problems as the one I'm currently working with!

                 

                There's just got to be something I'm missing here.. Any other ideas? So grateful for your help!

                 

                /Margiiie

                • 5. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
                  groove25 Community Member

                  If you tried a) refreshing/reloading the page within the browser and b) emptying the contents of the FWTemp folder, and neither of those worked, then I'd take another look at the link itself. Assuming there are other links on the page you've created, compare the links within Fireworks: Are there any differences between them? Would it be possible to re-enter or re-establish the problem link's URL?

                   

                  One thing I notice in your intial post is that "LinkedPage.htm" seems all by itself within the FWTemp folder, instead of being placed in a subfolder. When I generate a preview in FW, it places the contents in a folder (named with a random number), like this:

                   

                  file:///Users/doug/Library/Application%20Support/Macromedia/Fireworks%208/FWTemp/24327926/ 00000002.htm

                   

                  Generally, a website observes a folder hierarchy. I'd kind of expect "LinkedPage.htm" to be in the same folder as the "index.htm" or whatever your problem page is called.

                   

                  I have to admit, I don't use Fireworks to create and preview web pages, so I'm not completely versed in how it works for a full website. I'm not 100% certain that previewing an individual page should result in a functional preview of an entire site. In other words, I'm not certain that links are supposed to work if they lead to another page within the same site (assuming you're previewing one page at a time). If this remains a problem, I'd suggest letting it go for now. Try File > Export instead, and make sure you're exporting all the pages in the site. If that works, then you're in good shape.

                  • 6. Re: Link problem with Fireworks CS5 - net::ERR_FILE_NOT_FOUND
                    katdavis1 Community Member

                    I got this same error but fixed it by renaming my pages. I had used # in the page name and fireworks would not properly output the file. Once I removed the hashtag from the page name, the prototype worked perfectly.