26 Replies Latest reply: Apr 22, 2012 10:53 PM by Ayetti957 RSS

    Having trouble using the slideshow widgets out of the widget exchange

    Ayetti957 Community Member

      I am having a problem with the site I am building right now, for some reason every time I drag and drop any of the slideshow widgets from the exchange they won't work. I get the message that the JS files are missing.  I have never had this problem with any of my other sites, and was wondering if anyone had any insight? Do I have to somehow define the folder that holds the js? I doubt I have ever done that before, but who knows.

        • 1. Re: Having trouble using the slideshow widgets out of the widget exchange
          Ayetti957 Community Member

          Should add that when I look the spry js files are there in the same folder they would normally be in, it just seems like for whatever reason it doesn't want to reference them?

          • 3. Re: Having trouble using the slideshow widgets out of the widget exchange
            Ayetti957 Community Member

            I don't actually have it up on my page right now, but I added it too a template I was working on.  I am sure this would give me the same error if I were to put it on the server.

             

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

            <html xmlns="http://www.w3.org/1999/xhtml">

            <head>

            <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

            <title>Untitled Document</title>

            <style type="text/css">

            <!--

            body {

                      font: 100%/1.4 Verdana, Arial, Helvetica, sans-serif;

                      margin: 0;

                      padding: 0;

                      color: #000;

                      background-attachment: fixed;

                      background-image: url(Images/waterbackgroundv2.jpg);

                      background-repeat: no-repeat;

            }

             

             

            /* ~~ Element/tag selectors ~~ */

            ul, ol, dl { /* Due to variations between browsers, it's best practices to zero padding and margin on lists. For consistency, you can either specify the amounts you want here, or on the list items (LI, DT, DD) they contain. Remember that what you do here will cascade to the .nav list unless you write a more specific selector. */

                      padding: 0;

                      margin: 0;

            }

            h1, h2, h3, h4, h5, h6, p {

                      margin-top: 0;           /* removing the top margin gets around an issue where margins can escape from their containing div. The remaining bottom margin will hold it away from any elements that follow. */

                      padding-right: 15px;

                      padding-left: 15px; /* adding the padding to the sides of the elements within the divs, instead of the divs themselves, gets rid of any box model math. A nested div with side padding can also be used as an alternate method. */

            }

            a img { /* this selector removes the default blue border displayed in some browsers around an image when it is surrounded by a link */

                      border: none;

            }

             

             

            /* ~~ Styling for your site's links must remain in this order - including the group of selectors that create the hover effect. ~~ */

            a:link {

                      color: #42413C;

                      text-decoration: underline; /* unless you style your links to look extremely unique, it's best to provide underlines for quick visual identification */

            }

            a:visited {

                      color: #6E6C64;

                      text-decoration: underline;

            }

            a:hover, a:active, a:focus { /* this group of selectors will give a keyboard navigator the same hover experience as the person using a mouse. */

                      text-decoration: none;

            }

             

             

            /* ~~this fixed width container surrounds the other divs~~ */

            .container {

                      width: 1000px;

                      background: #FFF; /* the auto value on the sides, coupled with the width, centers the layout */

                      margin-top: 0;

                      margin-right: auto;

                      margin-bottom: 0;

                      margin-left: auto;

            }

             

             

            /* ~~ the header is not given a width. It will extend the full width of your layout. It contains an image placeholder that should be replaced with your own linked logo ~~ */

            .header {

            }

             

             

            /* ~~ These are the columns for the layout. ~~

             

             

            1) Padding is only placed on the top and/or bottom of the divs. The elements within these divs have padding on their sides. This saves you from any "box model math". Keep in mind, if you add any side padding or border to the div itself, it will be added to the width you define to create the *total* width. You may also choose to remove the padding on the element in the div and place a second div within it with no width and the padding necessary for your design.

             

             

            2) No margin has been given to the columns since they are all floated. If you must add margin, avoid placing it on the side you're floating toward (for example: a right margin on a div set to float right). Many times, padding can be used instead. For divs where this rule must be broken, you should add a "display:inline" declaration to the div's rule to tame a bug where some versions of Internet Explorer double the margin.

             

             

            3) Since classes can be used multiple times in a document (and an element can also have multiple classes applied), the columns have been assigned class names instead of IDs. For example, two sidebar divs could be stacked if necessary. These can very easily be changed to IDs if that's your preference, as long as you'll only be using them once per document.

             

             

            4) If you prefer your nav on the left instead of the right, simply float these columns the opposite direction (all left instead of all right) and they'll render in reverse order. There's no need to move the divs around in the HTML source.

             

             

            */

            .sidebar1 {

                      float: right;

                      width: 300px;

                      padding-bottom: 10px;

            }

            .container .sidebar1 table tr .conact {

                      background-image: url(Images/contact-form-image.jpg);

                      background-repeat: no-repeat;

            }

            .content {

                      width: 700px;

                      float: right;

                      padding-top: 10px;

                      padding-right: 0;

                      padding-bottom: 10px;

                      padding-left: 0;

            }

             

             

            /* ~~ This grouped selector gives the lists in the .content area space ~~ */

            .content ul, .content ol {

                      padding: 0 15px 15px 40px; /* this padding mirrors the right padding in the headings and paragraph rule above. Padding was placed on the bottom for space between other elements on the lists and on the left to create the indention. These may be adjusted as you wish. */

            }

             

             

            /* ~~ The navigation list styles (can be removed if you choose to use a premade flyout menu like Spry) ~~ */

            ul.nav {

                      list-style: none; /* this removes the list marker */

                      border-top: 1px solid #666; /* this creates the top border for the links - all others are placed using a bottom border on the LI */

                      margin-bottom: 15px; /* this creates the space between the navigation on the content below */

            }

            ul.nav li {

                      border-bottom: 1px solid #666; /* this creates the button separation */

            }

            ul.nav a, ul.nav a:visited { /* grouping these selectors makes sure that your links retain their button look even after being visited */

                      padding: 5px 5px 5px 15px;

                      display: block; /* this gives the link block properties causing it to fill the whole LI containing it. This causes the entire area to react to a mouse click. */

                      width: 160px;  /*this width makes the entire button clickable for IE6. If you don't need to support IE6, it can be removed. Calculate the proper width by subtracting the padding on this link from the width of your sidebar container. */

                      text-decoration: none;

                      background: #C6D580;

            }

            ul.nav a:hover, ul.nav a:active, ul.nav a:focus { /* this changes the background and text color for both mouse and keyboard navigators */

                      background: #ADB96E;

                      color: #FFF;

            }

             

             

            /* ~~ The footer ~~ */

            .footer {

                      padding: 10px 0;

                      background: #CCC49F;

                      position: relative;/* this gives IE6 hasLayout to properly clear */

                      clear: both; /* this clear property forces the .container to understand where the columns end and contain them */

            }

             

             

            /* ~~ miscellaneous float/clear classes ~~ */

            .fltrt {  /* this class can be used to float an element right in your page. The floated element must precede the element it should be next to on the page. */

                      float: right;

                      margin-left: 8px;

            }

            .fltlft { /* this class can be used to float an element left in your page. The floated element must precede the element it should be next to on the page. */

                      float: left;

                      margin-right: 8px;

            }

            .clearfloat { /* this class can be placed on a <br /> or empty div as the final element following the last floated div (within the #container) if the #footer is removed or taken out of the #container */

                      clear:both;

                      height:0;

                      font-size: 1px;

                      line-height: 0px;

            }

            -->

            </style>

            <script src="Spry-UI-1.7/includes/SpryDOMUtils.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryDOMEffects.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryWidget.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryPanelSet.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryFadingPanels.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryImageLoader.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/SpryImageSlideShow.js" type="text/javascript"></script>

            <script src="Spry-UI-1.7/includes/plugins/ImageSlideShow/SpryPanAndZoomPlugin.js" type="text/javascript"></script>

            <link href="Spry-UI-1.7/css/SpryImageSlideShow.css" rel="stylesheet" type="text/css" />

            <style type="text/css">

            /* BeginOAWidget_Instance_2141542: #ImageSlideShow */

             

             

            #ImageSlideShow.ImageSlideShow {

                      width: 698px;

                      height: 432px;

                      border: solid 1px #000000;

            }

             

             

            #ImageSlideShow .ISSClip {

                      background-color: #000000;

            }

               

            /* EndOAWidget_Instance_2141542 */

            </style>

            <script type="text/xml">

            <!--

            <oa:widgets>

              <oa:widget wid="2141542" binding="#ImageSlideShow" />

            </oa:widgets>

            -->

            </script>

            </head>

             

             

            <body>

             

             

            <div class="container">

              <div class="header"><a href="#"><img src="Images/Banner.jpg" alt="Insert Logo Here" name="Insert_logo" width="1000" height="200" id="Insert_logo" style="background: #FFF; display:block;" /></a>

                <!-- end .header --></div>

              <div class="sidebar1">

                <p>  <table width="300" border="0" align="center">

                  <tr>

                    <td width="291" class="conact"><form id="form1" name="form1" method="post" action="FormtoEmail.php">

                       

                        <p> </p>

                        <p> </p>

                        <p> </p>

                        <p> </p>

                        <p> </p>

                        <p> </p>

                        <p> </p>

                        <p>

                          <label for="Your_Name"><strong><br />

                            Your Name

                            </strong><br />

                          </label>

                        </p>

                        <p>

                          <input name="Your_Name" type="text" id="Your Name" size="30" maxlength="50" />

                        </p>

                      <p>

                        <label for="Email"><strong>Email</strong></label>

                        <strong>            (required)

                        </strong>

                        <input name="Email" type="text" id="Email" size="30" />

                      </p>

                      <p>

                        <label for="Phone"><strong>Phone (required)</strong><br />

                        </label>

                        <input name="Phone" type="text" id="Phone" size="30" />

                  </p>

                      <p>

                        <label for="Address"><strong>Address</strong><br />

                        </label>

                        <input name="Address" type="text" id="Address" size="30" />

                      </p>

            <p>

              <label for="Schedule"><strong>Schedule</strong></label>

              <select name="Schedule" id="Schedule">

                <option>I want to schedule this week</option>

                <option>I want to schedule next week</option>

                <option>I want to schedule this month</option>

              </select>

            </p>

            <p>

              <label for="Areas_that_need_cleaning"><strong>Area's that need cleaning</strong></label>

              <textarea name="Areas_that need_cleaning" cols="23" rows="8" id="Area's that need cleaning"></textarea>

            </p>

                      <p>

                        <input type="submit" name="button" id="button" value="Submit" />

                      </p>

                    </form></td>

                  </tr>

                </table> </p>

                <!-- end .sidebar1 --></div>

              <div class="content">

                <ul id="ImageSlideShow">

                  <li><a href="http://labs.adobe.com/technologies/spry/demos/gallery/galleries/china/images/china_01.jpg"><img src="Images/iStock_000012195853XSmall.jpg" alt="" /></a></li>

                  <li><a href="http://labs.adobe.com/technologies/spry/demos/gallery/galleries/china/images/china_02.jpg"><img src="Images/iStock_000008323790XSmall.jpg" alt="" /></a></li>

                  <li><a href="http://labs.adobe.com/technologies/spry/demos/gallery/galleries/china/images/china_03.jpg"><img src="Images/iStock_000018681950XSmall.jpg" alt="" /></a></li>

                </ul>

                <script type="text/javascript">

            // BeginOAWidget_Instance_2141542: #ImageSlideShow

             

             

            var ImageSlideShow = new Spry.Widget.ImageSlideShow("#ImageSlideShow", {

                      widgetID: "ImageSlideShow",

                      injectionType: "replace",

                      autoPlay: true,

                      displayInterval: 4000,

                      transitionDuration: 2000,

                      componentOrder: ["view", "controls"],

                      plugIns: [  ]

            });

            // EndOAWidget_Instance_2141542

                </script>

            <h1> </h1>

              <!-- end .content --></div>

              <div class="footer">

                <p>This .footer contains the declaration position:relative; to give Internet Explorer 6 hasLayout for the .footer and cause it to clear correctly. If you're not required to support IE6, you may remove it.</p>

                <!-- end .footer --></div>

              <!-- end .container --></div>

            </body>

            </html>

            • 4. Re: Having trouble using the slideshow widgets out of the widget exchange
              sudarshan.t CommunityMVP

              Can you also post a screenshot of your file structure of your root folder and the folder containing Spry files?

              • 6. Re: Having trouble using the slideshow widgets out of the widget exchange
                Ayetti957 Community Member

                It will work when i add it the first time, but from there on out it just gives the error. Also I corrected something that is wrong in the code above, I added the link to the correct photo's, but that still doesn't effect the js problem.

                • 7. Re: Having trouble using the slideshow widgets out of the widget exchange
                  sudarshan.t CommunityMVP

                  I don't see any issue in your code/ your file structure.

                   

                  Could you upload your site and give us a link to your page?

                  • 8. Re: Having trouble using the slideshow widgets out of the widget exchange
                    Ayetti957 Community Member

                    here is the link http://carpetcleaningpasorobles.com/pasorobles/ I put up the widget and it is having the same issues.

                    • 9. Re: Having trouble using the slideshow widgets out of the widget exchange
                      sudarshan.t CommunityMVP

                      Try replacing

                       

                      <script src="Spry-UI-1.7/includes/SpryWidget.js" type="text/javascript"></script>

                       

                      with

                       

                      <script src="http://labs.adobe.com/technologies/spry/ui/includes/SpryWidget.js"></script>

                       

                      It seems like your SpryWidget.js file is corrupt. This link will refer to the latest version of SpryWidget.js from Adobe website.

                      • 10. Re: Having trouble using the slideshow widgets out of the widget exchange
                        Ayetti957 Community Member

                        tried it, and I still got the error, it is weird I have tried pretty much every slideshow widget in the exchange and I get the error every time.

                        • 11. Re: Having trouble using the slideshow widgets out of the widget exchange
                          sudarshan.t CommunityMVP

                          Can you replace all Spry links to labs.adobe.com sources? Then try it?

                          • 12. Re: Having trouble using the slideshow widgets out of the widget exchange
                            Ayetti957 Community Member

                            I tried to find the spry links in adobe.com but had no luck, is there a specific spot I should look? I kind of tried to work backwards from the link you gave me, but didn't find it.

                            • 13. Re: Having trouble using the slideshow widgets out of the widget exchange
                              Ayetti957 Community Member

                              Alright replaced all the links and now I don't get the errors for the missing js files but it still doesnt work? I have it up here http://carpetcleaningpasorobles.com/pasorobles

                              • 14. Re: Having trouble using the slideshow widgets out of the widget exchange
                                sudarshan.t CommunityMVP

                                I don't see any reference to the images you'd like to see in the slider present in your script.

                                • 15. Re: Having trouble using the slideshow widgets out of the widget exchange
                                  Ayetti957 Community Member

                                  Sorry I had taken it down and tried another solution.  I put it back in there with the revised labs.adobe.com links.  I still don't get the errors but it just displays the pictures as a list.

                                  • 16. Re: Having trouble using the slideshow widgets out of the widget exchange
                                    Nancy O. CommunityMVP

                                    Un-styled slides means you're missing SpryImageSlideShow.css

                                    You can't run a SlideShow without its supporting CSS file.

                                     

                                    In Widget Browser, the reference looks like this:

                                    <link type='text/css' href='Spry-UI-1.7/css/SpryImageSlideShow.css' rel='stylesheet'/>

                                    <style type="text/css">

                                     

                                     

                                     

                                     

                                    Nancy O.

                                    Alt-Web Design & Publishing

                                    Web | Graphics | Print | Media  Specialists 

                                    http://alt-web.com/

                                    http://twitter.com/altweb

                                    http://alt-web.blogspot.com/

                                    • 17. Re: Having trouble using the slideshow widgets out of the widget exchange
                                      Ayetti957 Community Member

                                      I have been looking for a spot were the style sheet is missing and can't seem to find it, I am probably making a stupid mistake (wouldn't be the first time) I have the site up at http://carpetcleaningpasorobles.com/ayetti3/testcarpet.html

                                       

                                      It works fine when I preview it locally but once I upload it, it stops recognizing the .js files, I am SOO stumped! I just can't imagine what is wrong.  I feel like maybe this section is incorrect, I just can't figure out which part.  Should i attach the style sheet to each of the images individually?

                                      }

                                      -->

                                      </style>

                                      <script src="SpryAssets/SpryMenuBar.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryDOMUtils.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryDOMEffects.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryWidget.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryPanelSet.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryFadingPanels.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryImageLoader.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/SpryImageSlideShow.js" type="text/javascript"></script>

                                      <script src="Spry-UI-1.7/includes/plugins/ImageSlideShow/SpryPanAndZoomPlugin.js" type="text/javascript"></script>

                                      <link href="SpryAssets/SpryMenuBarHorizontal.css" rel="stylesheet" type="text/css" />

                                      <link href="Spry-UI-1.7/css/SpryImageSlideShow.css" rel="stylesheet" type="text/css" />

                                      <style type="text/css">

                                      /* BeginOAWidget_Instance_2141542: #ImageSlideShow */

                                       

                                       

                                      #ImageSlideShow.ImageSlideShow {

                                                width: 662px;

                                                height: 432px;

                                                border: solid 1px #000000;

                                      }

                                       

                                       

                                      #ImageSlideShow .ISSClip {

                                                background-color: #000000;

                                      }

                                         

                                      /* EndOAWidget_Instance_2141542 */

                                      </style>

                                      <script type="text/xml">

                                      <!--

                                      <oa:widgets>

                                        <oa:widget wid="2141542" binding="#ImageSlideShow" />

                                      </oa:widgets>

                                      -->

                                      </script>

                                      • 18. Re: Having trouble using the slideshow widgets out of the widget exchange
                                        sudarshan.t CommunityMVP

                                        This comes down to one thing that may have gone wrong.

                                         

                                        What FTP are you using to upload your files onto your server?

                                         

                                        You could try doing this:

                                         

                                        In your FTP program, go to Upload Mode and check if it shows 'Auto' or 'ASCII'. If it is showing either of these, change it to 'Binary'. That may resolve the issue for you. If your FTP writes to the server on ASCII mode for .js files, that sometimes results in issues.

                                         

                                        I'd recommend FileZilla if you're not using it already.

                                        • 19. Re: Having trouble using the slideshow widgets out of the widget exchange
                                          Ayetti957 Community Member

                                          I tried binary in filezilla and no luck, I am just stumped! The js files for the spry menu work, but nothing for the slideshow.

                                          • 20. Re: Having trouble using the slideshow widgets out of the widget exchange
                                            Nancy O. CommunityMVP

                                            Might be a bad widget.  Have you tried any of these widgets from the Adobe Exchange?

                                                 * jQuery Cycle Widget

                                                  * Lightbox Gallery Widget

                                                 * Spry Content Slideshow

                                             

                                             

                                            Nancy O.

                                            Alt-Web Design & Publishing

                                            Web | Graphics | Print | Media  Specialists 

                                            http://alt-web.com/

                                            http://twitter.com/altweb

                                            http://alt-web.blogspot.com/

                                            • 21. Re: Having trouble using the slideshow widgets out of the widget exchange
                                              Ayetti957 Community Member

                                              I just tried the content slideshow, and it has the same issue (missing .js files)

                                               

                                              So far I have tried most of them.  I had limited success with the ken burns slideshow, I got that one up and working, but I am having trouble styling it.

                                              • 22. Re: Having trouble using the slideshow widgets out of the widget exchange
                                                Ayetti957 Community Member

                                                You all are awesome for sticking with me through this! It looks like it was an FTP thing! I created a new directory and then uploaded the site again and it seems to work! I am just going to go back and clear out everything from my FTP manager now and then upload everything with file zilla in binary.  I really appreciate the help guys! I guess I had just gotten lucky using the FTP in dreamweaver so far.

                                                 

                                                http://carpetcleaningpasorobles.com/ayetti5/Deposit_Back/testcarpet.html

                                                 

                                                Crazy how much work that ended up being just for such a simple slideshow.

                                                • 23. Re: Having trouble using the slideshow widgets out of the widget exchange
                                                  sudarshan.t CommunityMVP

                                                  You're welcome mate! Sometimes its the simple things in life that go unnoticed! :) but, I'm glad we were finally able to solve the issue you were facing!

                                                  • 24. Re: Having trouble using the slideshow widgets out of the widget exchange
                                                    Ayetti957 Community Member

                                                    Really appreciate your tenacity on this one! Is there any downside to binary or should I just always use it.  Never would have guessed it was ahci screwing that up.

                                                    • 25. Re: Having trouble using the slideshow widgets out of the widget exchange
                                                      sudarshan.t CommunityMVP

                                                      It's debatable.

                                                       

                                                      Usually, ASCII mode transfers also convert characters between systems (and sometimes just delete them) however, binary file transfers are just directly transferred with no modification.

                                                       

                                                      This is what made your .js files work the way they were supposed to when you used Binary.

                                                       

                                                      There are no 'defined' situations for this. It's always a case-to-case basis.

                                                      • 26. Re: Having trouble using the slideshow widgets out of the widget exchange
                                                        Ayetti957 Community Member

                                                        Thank you so much again! I was stumped.  I was going to feel stupid asking my hosting company for help, but that is what it was about to come to.  I just couldn't figure it out.  Thanks again for all your help, really appreciate you sticking with me through that.