2 Replies Latest reply: Apr 23, 2012 2:22 AM by g_w_master RSS

    FMS 4.5 recorder video bug

    g_w_master

      i record video stream and then when i play him

      i get

       

      lay time : 6.663

      play time : 6.914

      play time : 7.164

      play time : 7.413

      play time : 7.713

      play time : 7.963

      play time : 32.594  <-- WTF!!!!!!!!!!

      play time : 32.895

      play time : 33.144

       

      from 0-7 only command (          _outgoingStream.send )

      7- 32 vide + commands

      32 - .. video + audio + command

       

      if i play this video on Adobe media player he jump to 32 and play the audioi video

       

      please help!!!!!!

        • 1. Re: FMS 4.5 recorder video bug
          Amit Kumar Adobe Employee

          Can you explain more on what exactly you are recording? Is it plain server side record or recording using livepkgr app. Are you playing rtmp or http?

          • 2. Re: FMS 4.5 recorder video bug
            g_w_master Community Member

            FMS 4.5 local on PC and Amazon

            connection: rtmfp rtmp or rtrmpt

             

            _outgoingStream = new NetStream(_netConnection, NetStream.DIRECT_CONNECTIONS);


            _outgoingStream.publish(_userName,"record");

             

            _outgoingStream.attachCamera ..

            _outgoingStream.attachAudio ..

             

             

            play from http but eben Adobe media player that play local play at same vay

             

            private var recordTimer:Timer = new Timer(1000);

                                private function setarRecord():void{

                                          recordTimer.addEventListener(TimerEvent.TIMER,sendToStream);

                                          recordTimer.start();

                                          sendToStream();

                                }

             

            private function sendToStream(e:Event = null):void{

                                          //call function on Partcipiant.as

                                          _outgoingStream.send("r");

                                }

             

            record comman every 1 secound that stream will have somthing if there no audio and no video

             

            from 0-7 only command (          _outgoingStream.send )

            7- 32 vide + commands

            32 - .. video + audio + command

             

            and the problem when i play the video

            when only video is recordet it's dont showen

             

            7- 32 vide + commands

             

            when i play i print time i the reslout is

            jump from 7sec to 32sec when audio begin

             

            if its help i can record example video and send you


            thenks...