12 Replies Latest reply: Apr 28, 2012 11:19 AM by Noel Carboni RSS

    Clone Stamp Tool and smudge tool issue

    Francis Stellitano Community Member

      iMac 21.5";   new on 12/14/2011;   OS Version 10.7.3;  2.7GHz Intel Core i5;  AMD Radeon HD 6770M 512 MB.

       

      Two and Three Layer, all layers are copies of background layer, plus two adjustment layers, 8 Bit file:

       

      Clone Stamping directly on image layer with Background layer directly below and with copy of Background layer directly below.

       

      Intuos 4 tablet and pen.

       

      Clone Stamp tool Setup:

       

      Layer Adjustment parameter set to either This Layer and Below or All Layers.

      All other parameters at default.

      Using simple soft brush.

      =====================================

       

       

       

      The bug: Clone Stamp too will only affect the layer selected to do the actual cloning.

       

      Tried it in every configuation possible without adjust the tool defaults, and no layers below will get the cloning corrections or stamping.

        • 1. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
          Danny Smythe Community Member

          Do you have this box selected? It shoud be.

           

          4.jpg

          • 2. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
            Pattie F Employee Hosts

            Have you been making tons of changes? Try closing the file and reopening and see if it works.Let us know.

             

            Pattie

            • 3. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
              Francis Stellitano Community Member

              Danny, that what I was asking about: with that parameter/box switched to any of the options it does not work. Thanks for trying though.

               

              Pattle, it is consistent with new image files and after restarting.

               

              There are other bugs too, like the Smudge tool draws a black brush stroke unless the opacity is turnead down to 1%.

               

              I hope all these bugs are addressed and have to assume they are. However, it would nice to get some feedback on the forum from Adobe on the status.

               

              I see that they have announced officially the release of PS CS6 in the next 30 days.

              • 4. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                Pattie F Employee Hosts

                Francis-

                 

                I am able to use the clone stamp tool for all layers, smudge at any percentage with no black brush stroke.  Can you attach your system information here from photoshop help>system info? Can you also give me the file your are having trouble with so I can see the issue first hand?

                 

                Pattie

                • 5. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                  Francis Stellitano Community Member

                  I went to my iMac and think the problem is with my Wacom tablet and pen.

                   

                  I opened a regular image file made from my Canon .cr2 raw file and got similar behavior. At first it would only clone with the  pen lifted after each stroke and then it starting working properly again.

                   

                  However, I could not get it to pass the cloning to the layers below.

                   

                  I dropped my tablet over six months ago and lately it is starting to act flakey. Looks like a good excuse to upgrade to the Intuos 5.

                   

                  Regards and thank you,

                   

                   

                   

                   

                  BTW, here is my sys pref info. Bought new Dec/2011.

                   

                  Hardware:

                   

                  Model Name:          iMac

                  Model Identifier:          iMac12,1

                  Processor Name:          Intel Core i5

                  Processor Speed:          2.7 GHz

                  Number of Processors:          1

                  Total Number of Cores:          4

                  L2 Cache (per Core):          256 KB

                  L3 Cache:          6 MB

                  Memory:          4 GB

                  Boot ROM Version:          IM121.0047.B1F

                  SMC Version (system):          1.71f22

                   

                   

                  Software:

                   

                  System Version:          Mac OS X 10.7.3 (11D50)

                  Kernel Version:          Darwin 11.3.0

                  Boot Volume:          Macintosh HD

                  Boot Mode:          Normal

                  Computer Name:          Francis’s iMac

                  User Name:          Francis Stellitano (francisstellitano)

                  Secure Virtual Memory:          Enabled

                  64-bit Kernel and Extensions:          Yes

                  Time since boot:          13:16

                  • 6. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                    Francis Stellitano Community Member

                    OOPS!

                     

                    I made a big mistake in expecting the wrong behavior for the Clone Stamp tool. I was expecting edits on the current layer to show up on the underneath layers.

                     

                    For as long as I have been using PS, about 8 years, I am completely embarrassed. I guess this makes me a Tool, in a punny way.

                     

                    Oh well, still love this new version.

                    • 7. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                      Pattie F Employee Hosts

                      OK then. Other than the misunderstanding of the clone tool, are you still having trouble with the smudge tool at any other setting than 1%?  If you are still having issues, please copy the information from Photoshop help>system info. It will tell us more than what you pasted in the above post.

                       

                      Pattie

                      • 8. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                        Francis Stellitano Community Member

                        Reporting back: Clone Stamp Tool

                         

                        I know how to create the situation and am surprised I have not seen this before. Also, it is normal because it ocurrs with both CS5 and CS6.

                         

                        Process:

                        Open any camera image file either jpeg or raw through ACR and then jpeg.

                        Duplicate the background layer.

                        Create one or two Adjustment layers above, clipped or not.

                        Smudge tool: set to All Layers. Use any Opacity setting.

                        When you smudge on the copied layer, active layer, it can turn all white or black depending on the Adjustment layer type or the Blending mode of the layer.

                         

                        That is it in nutshell. Setting the All Layers checkbox causes strange results when there are one or more Adjustment layers above.

                         

                        This occurrs with both CS 5 & 6.

                         

                        The system info files for both versions is huge and if you can dupilcate the behavior, I see no reason at this point to copy it here.

                         

                        Let me know Pattie.

                        • 9. Re: Clone Stamp Tool and smudge tool issue
                          Noel Carboni Community Member

                          The Smudge Tool appears to be passing the pixels repeatedly up through the layer pyramid, then re-depositing them on the image layer.

                           

                          It's also very slow, as though the Brush Spacing isn't properly being done and is near zero.  I even got it to virtually lock up with a 614 pixel brush.  Definitely a bug there with the stroking of the Smudge Tool.  I've seen it reported and discussed before, so it's possible Adobe will have that fixed by the release.

                           

                          As far as what's going on with the color, though...  One has to wonder: Of what use is the [ ] Sample All Layers checkbox when there's a stack of adjustments above the layer you're working on.  What would you expect it to do?

                           

                          -Noel

                          • 10. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                            Pattie F Employee Hosts

                            Thanks for the updated information.  I will follow your steps and see if I can also reproduce this.

                            Just copy the data above the plugins from the PS help>system info into this thread for us to take a look there also.

                             

                            Pattie

                            • 11. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                              Francis Stellitano Community Member

                              Welcome back gang.

                               

                              Made a couple new discoveries while double checking.

                               

                              Again, the same four layer setup: Background-Background copy-HSB Adj layer-Levels Adj layer.

                              The problem replicates with the Adj layers clipped or not.

                               

                              The key is any tweak in the Adj layers will cause the issue.

                               

                              Any Adj layer tweak seems to get exaggerated when smudging on a layer.

                              For example, increasing the gamma or center slider in the Levels box will cause all bright pixels to go white and darker pixels to go black.

                              I do not know the threshold luminance pixel value but I would guess it is at 128/128.

                               

                              Modest tweaks to the Adj layer, for example raising the gamma slider to 1.20 will cause the smudge to posterize or turn white.

                              Tweaking the HSB Saturation slider to +12 will cause color posterization.

                               

                              Counter to what I had stated upstream, any setting of the Smudge tool will cause this to happen.

                               

                              Also, as said upstream, the performance goes down such that the spinning balls appear frequently.

                               

                              In other words, it does not appear to be a 1-to-1 relationship of tweaks made in the Adj layer to the effect of the Smudge tool.

                              My guess is that the Sample All Layers option is multiplying the color and luminance values fo the layers together.

                               

                              Plus, it was probably designed to do so but I do not think it was to be so pronounced.

                               

                              Still amazes me that the situation never occurred or did I notice it until now, and the issue exists in CS5 too.

                              When did PS add the Sample All Layers option to the Smudge tool?

                               

                              Anybody else?

                               

                               

                               

                               

                              ================================

                              Adobe Photoshop Version: 13.0 (13.0 20120305.m.415 2012/03/05:21:00:00) x64

                              Operating System: Mac OS 10.7.3

                              System architecture: Intel CPU Family:6, Model:42, Stepping:7 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2

                              Physical processor count: 4

                              Processor speed: 2700 MHz

                              Built-in memory: 4096 MB

                              Free memory: 1738 MB

                              Memory available to Photoshop: 3384 MB

                              Memory used by Photoshop: 75 %

                              Image tile size: 1024K

                              Image cache levels: 4

                              OpenGL Drawing: Enabled.

                              OpenGL Drawing Mode: Advanced

                              OpenGL Allow Normal Mode: True.

                              OpenGL Allow Advanced Mode: True.

                              OpenGL Allow Old GPUs: Not Detected.

                              OpenGL Version: 2.1 ATI-7.18.11

                              OpenCL Version: 1.1 (Dec  4 2011 16:53:18)

                              Video Card Vendor: ATI Technologies Inc.

                              Video Card Renderer: ATI Radeon HD 6770M OpenGL Engine

                              Display: 1

                              Main Display

                              Display Depth:= 32

                              Display Bounds:=  top: 0, left: 0, bottom: 1080, right: 1920

                              Video Renderer ID: 16915206

                              Video Card Memory: 500 MB

                              Video Rect Texture Size: 16384

                              Serial number: Tryout Version

                              Application folder: Macintosh HD:Applications:Adobe Photoshop CS6:

                              Photoshop scratch has async I/O enabled

                              Scratch volume(s):

                                Macintosh HD, 930.7G, 700.7G free

                              Required Plug-ins folder: Macintosh HD:Applications:Adobe Photoshop CS6:Adobe Photoshop CS6.app:Contents:Required:

                              Primary Plug-ins folder: Macintosh HD:Applications:Adobe Photoshop CS6:Plug-ins:

                              Additional Plug-ins folder: not set

                               

                               

                              Installed components:

                               

                               

                                 adbeape.framework   adbeape   3.3.8.19346   66.1025012

                                 AdbeScriptUIFlex.framework   AdbeScriptUIFlex   6.2.29.18602   66.490082

                                 adobe_caps.framework   adobe_caps   5.0.11.0   1.256674

                                 AdobeACE.framework   AdobeACE   2.19.18.19243   66.492997

                                 AdobeAGM.framework   AdobeAGM   4.26.17.19243   66.492997

                                 AdobeAXE8SharedExpat.framework   AdobeAXE8SharedExpat   3.7.101.18636   66.26830

                                 AdobeAXEDOMCore.framework   AdobeAXEDOMCore   3.7.101.18636   66.26830

                                 AdobeBIB.framework   AdobeBIB   1.2.02.19243   66.492997

                                 AdobeBIBUtils.framework   AdobeBIBUtils   1.1.01   66.492997

                                 AdobeCoolType.framework   AdobeCoolType   5.10.31.19243   66.492997

                                 AdobeCrashReporter.framework   AdobeCrashReporter   6.0.20120201  

                                 AdobeExtendScript.framework   AdobeExtendScript   4.2.12.18602   66.490082

                                 AdobeJP2K.framework   AdobeJP2K   2.0.0.18562   66.236923

                                 AdobeLinguistic.framework      17206  

                                 AdobeMPS.framework   AdobeMPS   5.8.0.19463   66.495174

                                 AdobeOwl.framework   AdobeOwl   4.0.93   66.496052

                                 AdobePDFL.framework   AdobePDFL   10.0.1.18562   66.419471

                                 AdobePDFSettings.framework   AdobePDFSettings   1.4  

                                 AdobePIP.framework   AdobePIP   6.0.0.1642  

                                 AdobeScCore.framework   AdobeScCore   4.2.12.18602   66.490082

                                 AdobeUpdater.framework   AdobeUpdater   6.0.0.1452   "52.338651"

                                 AdobeXMP.framework   AdobeXMPCore   66.145661   66.145661

                                 AdobeXMPFiles.framework   AdobeXMPFiles   66.145661   66.145661

                                 AdobeXMPScript.framework   AdobeXMPScript   66.145661   66.145661

                                 ahclient.framework   ahclient   1.7.0.56  

                                 aif_core.framework   AdobeAIF   3.0.00   62.490293

                                 aif_ocl.framework   AdobeAIF   3.0.00   62.490293

                                 aif_ogl.framework   AdobeAIF   3.0.00   62.490293

                                 AlignmentLib.framework   xcode   1.0.0.1  

                                 amtlib.framework   amtlib   6.0.0.75  

                                 boost_date_time.framework   boost_date_time   6.0.0.0  

                                 boost_signals.framework   boost_signals   6.0.0.0  

                                 boost_system.framework   boost_system   6.0.0.0  

                                 boost_threads.framework   boost_threads   6.0.0.0  

                                 Cg.framework   NVIDIA Cg     

                                 CIT.framework   CIT   2.0.5.19287   145486

                                 data_flow.framework   AdobeAIF   3.0.00   62.490293

                                 dvaaudiodevice.framework   dvaaudiodevice   6.0.0.0  

                                 dvacore.framework   dvacore   6.0.0.0  

                                 dvamarshal.framework   dvamarshal   6.0.0.0  

                                 dvamediatypes.framework   dvamediatypes   6.0.0.0  

                                 dvaplayer.framework   dvaplayer   6.0.0.0  

                                 dvatransport.framework   dvatransport   6.0.0.0  

                                 dvaunittesting.framework   dvaunittesting   6.0.0.0  

                                 dynamiclink.framework   dynamiclink   6.0.0.0  

                                 FileInfo.framework   FileInfo   66.145433   66.145433

                                 filter_graph.framework   AdobeAIF   3.0.00   62.490293

                                 hydra_filters.framework   AdobeAIF   3.0.00   62.490293

                                 ICUConverter.framework   ICUConverter   3.61   "gtlib_3.0" "." "16615"

                                 ICUData.framework   ICUData   3.61   "gtlib_3.0" "." "16615"

                                 image_compiler.framework   AdobeAIF   3.0.00   62.490293

                                 image_flow.framework   AdobeAIF   3.0.00   62.490293

                                 image_runtime.framework   AdobeAIF   3.0.00   62.490293

                                 LogSession.framework   LogSession   2.1.2.1640  

                                 mediacoreif.framework   mediacoreif   6.0.0.0  

                                 PlugPlug.framework   PlugPlug   3.0.0.383  

                                 UpdaterNotifications.framework   UpdaterNotifications   6.0.0.24   "6.0.0.24"

                                 wrservices.framework        

                               

                               

                               

                               

                              Required plug-ins:

                               

                              (removed)

                               

                              Optional and third party plug-ins:

                               

                               

                                 Perfect Effects Free 3.0.2, Copyright © 2012 onOne Software.  All rights reserved. - from the file “Perfect Effects Free.plugin”

                                 Perfect Effects Free Filter 3.0.2, Copyright © 2012 onOne Software.  All rights reserved. - from the file “Perfect Effects Free.plugin”

                                 Perfect Effects Free Smart Filter 3.0.2, Copyright © 2012 onOne Software.  All rights reserved. - from the file “Perfect Effects Free.plugin”

                              Plug-ins that failed to load: NONE

                              Flash:

                                 onOne

                                 Mini Bridge

                                 Kuler

                              Installed TWAIN devices: NONE

                              • 12. Re: Clone Stamp Tool: "All Layers/Layer and Below" is not working
                                Noel Carboni Community Member

                                Francis Stellitano wrote:

                                 

                                Plus, it was probably designed to do so but I do not think it was to be so pronounced.

                                 

                                Exactly.  It's as though the Smudge Tool is cycling through its process hundreds of times more than it should - kind of like what happens when the spacing value of a brush is set way too low.  Notably the spacing value set in the Brush panel has no effect on the operation of the Smudge Tool.

                                 

                                -Noel