1 Reply Latest reply: Apr 24, 2012 10:18 PM by areohbee RSS

    LrFtp.makeFtpPresetPopup - what should itemsBinding be set to?

    areohbee Community Member
      LrFtp.makeFtpPresetPopup( params )
      Creates and returns a pop-up menu view object for accessing FTP presets.

      First supported in version 1.3 of the Lightroom SDK.

      Parameters

      1. params
      (table) a table with these fields
      • factory: (LrViewFactory) The view factory.
      • properties: (table) The property table.
      • valueBinding: (table) The key in the property table for the preset.
      • itemsBinding: (table) The key in the property table for the preset items list.

      Return value

      (LrView) A view object of type popup_menu, created by the provided factory, with bindings set to display and change the FTP preset value.



      it says valueBinding & itemsBinding should be tables - is that correct?
      I've been passing a string for valueBinding and it seems to be doing what I want,
      I've been passing a string for itemBinding too, and the items are being preserved, but
      when a change the item selected in one plugin it changes the item selected in all other plugins - *not* what I want, no - not at all...

      ???
        • 1. Re: LrFtp.makeFtpPresetPopup - what should itemsBinding be set to?
          areohbee Community Member

          This is driving me absolutely up a wall.

           

          Whenever I select a different ftp-preset, no matter where I am, it get's changed everywhere, even if I've not saved it in a preset (e.g. export preset or publish settings).

           

          I'm talking about which ftp-preset is selected (which should never change unless you change it), not the ftp-preset settings themselves (which I expect to be shared).

           

          So, I have to constantly check ftp-preset selection before I do anything, else I end up ftp'ing to the wrong server!

           

          Help!!!

           

          Am I the only one having this problem? What could be causing it? How to fix it?

           

          It happens no matter what I set valueBinding or itemsBinding to.

           

          Arggghhh....