3 Replies Latest reply: Apr 26, 2012 8:43 AM by prairiedream RSS

    newer versions of LR


      will a newer version of lightroom LR4m seamlessly use a library from an older version of LR1?

      Can i just get the newer version, install it and everything works fine? If not what needs to be done.

      I lost my LR application in a hard drive drama but have a back up of the library luckily, can i just get the LR4 and add the backed up library