6 Replies Latest reply: May 3, 2012 8:28 AM by oluolu RSS

    Inserting Flash Quiz

    oluolu

      I have a survey (un-graded quiz) animation that I need to insert into a Captivate 5.5 slide. I tried inserting as animation but file did not play. The animation includes a ball that advances towards the goal as user answers each question correctly. Do I need to insert as a widget?

        • 1. Re: Inserting Flash Quiz
          RodWard MVP

          Unless you coded this as a widget, DO NOT insert as a widget.

          • 2. Re: Inserting Flash Quiz
            oluolu Community Member

            Thanks. It'snot coded as a widget. So that eliminates that option. Would you or anyone know why it isn't working for me when inserted as an animation?

            • 3. Re: Inserting Flash Quiz
              RodWard MVP

              How was the animation created? 

               

              Did you create a survey quiz in Captivate and then publish it as a SWF to insert?  Or did you create this interaction in Flash and publish it as a SWF?  Was it set to play automatically?

               

              Since Captivate 5.5 only supports AS3 and not AS2, did you make sure your SWF was published as AS3?

              • 4. Re: Inserting Flash Quiz
                oluolu Community Member

                It was created in Flash (AS3) and published as a SWF. It is set to play automatically. It does have an XML file though.

                • 5. Re: Inserting Flash Quiz
                  RodWard MVP

                  If you just inserted the SWF into Captivate, even if you copied the XML into the same publish folder, the SWF will probably not be able to find the XML.  You need to play around with the code in your Flash file to change the path to the XML so that it will work once the SWF is embedded.  Alternatively, you can try externalising the SWF in Preferences > Project > Publish Settings and see if that works.  But it still might require changes in the AS code.

                  • 6. Re: Inserting Flash Quiz
                    oluolu Community Member

                    Thanks RodWard. I tried externalizing, but it still didn't work. Are you able to take a look at the Flash code for me to see what needs to be changed in the path to the XML?