5 Replies Latest reply: May 7, 2012 2:33 AM by ForrestGimp RSS

    Encoding FLV using CBR doesn't work

    ForrestGimp Community Member

      Hi

       

      I'm using AfterEffects CS4 and have a problem with encoding a video as flv using the on2 VP6-codec. The video is supposed to play back as part of a flash-project on a netbook, and I noticed that the video is stuttering in two sections. Investigating this I found that in both sections the bitrate goes up to more than 5000 kbps. The encoding-bitrate was set to 3500 kbps, with undershoot set to 90%. So I tried different settings (also in combinations), like

      - reducing bitrate to 2500 kbps

      - setting undershoot to 100%

      - setting undershoot to 0%

      - using simple profile-encoding

      - using CBR at 3500 kbps

       

      None of these seem to prevent the bitrate from going over 5000kbps in those two sections. At least the CBR isn't working at all, as it should encode the video constantly at 3500 kbps. However datarate still jumps up and down, just like it were VBR.

      What am I missing?

        • 1. Re: Encoding FLV using CBR doesn't work
          Mylenium ACP/MVPs

          Well, is there any audio? If so, that would also contribute, not just the video and your metrics may simply be off.

           

          Mylenium

          • 2. Re: Encoding FLV using CBR doesn't work
            ForrestGimp Community Member

            No, there's no audio.

            Considering the metrics: I measure the playback-datarate using vlc-players statistics-info to monitor it. So far the readings seem to make sense, as I see a direct connection of rising datarate observed and the stuttering video. The rate is below 3000 for most of the file, and has only those two peaks where it goes up above 5000. Thats where the stuttering occurrs. Considering the content it makes sense, too: both scenes are having loads of fine details and a lot of movement.

            • 3. Re: Encoding FLV using CBR doesn't work
              Mylenium ACP/MVPs

              As an alternative, have you tried running this through Adobe Media Encoder? This could be an AE specific limitation/ bug due to how it handles temporal encoding. Other than that perhaps download a trial of CS5.5/ CS6 if your system can handle it and try there... Also consider alternate encoders liek Sorenson Squeeze or Pro Coder....

               

              Mylenium

              • 4. Re: Encoding FLV using CBR doesn't work
                Todd_Kopriva Adobe Employee

                As Mylenium suggests, Adobe Media Encoder is the right tool for this job.

                • 5. Re: Encoding FLV using CBR doesn't work
                  ForrestGimp Community Member

                  Thanks for the replies, but switching to Media Encoder now would be a pain. I'd have to export the movie from After Effects in ultra high quality because reeincoding is always a bad thing. And of course I would have to set all my cuepoints again. Once I'd have finished I would have to reencode the whole movie. Additionally, if the movie is changed later on I'd have to go through the whole process again. That's not what I'd call an efficient workflow. Is there a better way?

                   

                  Alternative encoders:

                  The only other option I have for encoding .flv is "sorenson sparc". I tried it, but it produces a much larger file (I could live with that) and the video is still stuttering, and even worse than before. Is there a way to update all encoders for AfterEffects CS4?