4 Replies Latest reply: May 10, 2012 2:45 PM by mrmxyz RSS

    Black frames appearing in render


      Fairly urgent. I've got an After Effects project I've been working on for a couple months now, and this week is the crunch to export it finally. The project is a grid of several videos, mostly 1080p, and so it takes about 6 hours to render out. I've exported several versions of it with no problems, as both uncompressed AVI and highest res WMV.

      However, as of last night, it was rendering out with random videos in the grid flashing black frames. I've not changed anything about export settings, have restarted my computer and tried, but no luck. Baffled. Any suggestions? Deadline is looming.


      Quadcore, 2.20GHz, 8GB RAM, Windows 64-bit, CS5.5

        • 1. Re: Black frames appearing in render
          Mylenium MVP

          Flush the Media Cache and try again. If that doesn't help, then think hard about what graphics card driver updates or configuration changes you may have done, whether or not you have updated Quicktime or Windows Media Player recently or if you generally have installed CoDecs or otehr stuff that may make things go boom. Undo those changtes then.



          • 2. Re: Black frames appearing in render
            mrmxyz Community Member

            I hadn't added any updates at all, nor installed anything new, since the last trouble-free export. That was on Friday. Today I allowed a Photoshop update, but that was several hours (and several export attempts) since the problem cropped up. I've rendered out minor bits for another project since then, with no trouble, then resumed this project last night to find this issue crop up. There are about 30 videos on the screen at the same time at two points, and I can render it out fine if I switch off most of the grid. As such, I've managed a workaround of exporting the grid in quadrants, then will look to put it together in Premiere Pro. Of course, this is not preferable, especially given that I have to produce a total of 6 of these videos, with lengths varying between 10 and 60 seconds.


            I'll try flushing the cache later today, as I'm on the way out the door to meet the client now. Will let you know how it goes.

            • 3. Re: Black frames appearing in render
              bogiesan Community Member

              Render problems are based on disk/file issues or codec issues or both. A disk or file issue always occurs in the exact same place each render. Bad media or bad access to the file. Disk/file issues are not random between renders. Codec and input processing errors can be random but they always play the same way.


              However, some issues that appear to be render problems are actually playback problems. A glitch will appear in different places when playing back.


              Since you seem to be getting good renders if you turn off some layers, you've either got some bad layers or some faulty effects on those layers of you've lost the connection to those layers' source video files.


              It's a tedious binary search.

              • 4. Re: Black frames appearing in render
                mrmxyz Community Member

                Playback was fine in After Effects, and up until today the issue still seems to be very much random, only related to rendering. Yesterday I managed to fully render out one of the longest of the videos, then today it went back to dropping frames. However I used a workaround of rendering out the grid in quarters, then stitching it together in Premiere, using Darken blend mode.

                Seems obvious now that it's a resources issue, but I still haven't figured out how to definitively address it. Nothing I've tried has looked anything better than short term. I tried the project on a friend's desktop system, with a 3+ processor and 12GB of RAM (I've only got 8) and it went through most of the render (much faster, obviously), then dropped 4 frames at the end. Blink and you miss it.

                I suppose it's just random for the moment. Maybe the project got a bit too large? Either way, my workaround has allowed me to make my deadline, thankfully. A learning experience. Thanks for the advice!