22 Replies Latest reply: Dec 18, 2012 4:20 PM by TDocMaker RSS

    Has anyone had success using SharePoint and FrameMaker 10 together using CMS?

    MHMankowski

      Has anyone had success using SharePoint and FrameMaker 10 together using CMS?

        • 1. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
          Art_Campbell Community Member

          What version of SharePoint?

           

          Art Campbell

                    art.campbell@gmail.com

            "... In my opinion, there's nothing in this world beats a '52 Vincent and

          a redheaded girl." -- Richard Thompson

                                                                No disclaimers apply.

                                                                         DoD 358

           

          I support www.TheGrotonLine.com, hyperlocal news for Groton MA.

          • 3. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
            Suzy2001 Community Member

            Do you have a specific question? We use FrameMaker 10 and SharePoint 2010 just fine; check out a book (and all dependent files, including sections, graphics, etc.), then just check the book back in and its dependent files are checked in. Works very for us.

            • 4. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
              MHMankowski Community Member

              I can check documents out through FrameMaker using the CMS connection manager and edit them. The problem is when I go to check them back in and I right click on the document in the repository manager list the option to check the document back in is "grayed out" and I can't check it back into SharePoint. I am wondering what the problem is????????

              • 5. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                Suzy2001 Community Member

                Wow. Are your permissions set properly? I have no idea. And there's no error message?

                • 6. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                  MHMankowski Community Member

                  No error message at all. The permissions are set correctly. I am the one who created the folders in SharePoint. If I look at the properties of the SharePoint directories I am the owner of the directories and I am the owner of the FrameMaker file. I actually see a little red lock in the repository manager pod in Frame which indicates I have the file checked out. But, again, as I have said if I right-click on the file name the option to check the document back in is grayed out or hollow text; which means I can't select that option. I am thinking it is something simple but I do not know what. According to Adobe's own website if you save the file it is supposed to check it back in but that doesn't work either. I watched the videos they have on this website about FrameMaker and SharePoint integration.

                  • 7. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                    Art_Campbell Community Member

                    Without knowing more about it, I'd guess that it's a permissions problem....

                    Unless you're working in a single sign on environment, I'd look for slight

                    differences between your FM and SP user profiles. For example, that you

                    don't have R and W permissions in SP, or that there's a difference in group

                    memberships.

                     

                    Art

                     

                    Art Campbell

                              art.campbell@gmail.com

                      "... In my opinion, there's nothing in this world beats a '52 Vincent and

                    a redheaded girl." -- Richard Thompson

                                                                          No disclaimers apply.

                                                                                   DoD 358

                     

                    I support www.TheGrotonLine.com, hyperlocal news for Groton MA.

                    • 8. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                      Suzy2001 Community Member

                      In our repository manager, when you check a file out, it has a little green check on the left corner of the file. I don't know what it looks like to other folks, though. It almost sounds like a different user (or account) has the file checked out, so you can't check it in. Is there any discrepancy between how you're logged into CMS vs. the account you're using to check out the files? (I'm scrabbling for ideas here...)

                      • 9. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                        MHMankowski Community Member

                        The permissions are okay. I am the one that created the folders in sharepoint with my user ID. The FrameMaker user ID is the same one I log in with into our network, into SharePoint, etc., etc., The username/account is the same everywhere. Adobe is looking at this for me too and they are stumped also....

                        • 10. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                          NakshatraB Adobe Employee

                          Hi MHMankowski,

                           

                          Most likely the problem that you describe is a server side issue. I would advise you to first check if the list or the library you are using has been configured properly.

                          Mentioned below are two links to articles that contain the necessary steps for setting proper SPS configuration for enabling document versioning.

                          http://office.microsoft.com/en-us/windows-sharepoint-services-help/enable-and-configure-ve rsioning-for-a-list-or-library-HA010021494.aspx

                          http://technet.microsoft.com/en-us/library/cc288279(office.12).aspx

                           

                          Hopefully that should solve the problem. Do let us know.

                           

                          Regards,

                          Nakshatra Bhardwaj,

                          FrameMaker Engineering

                          • 11. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                            MHMankowski Community Member

                            The problem still exists, after some changes to include the domain name when logging in through CMS, the Check In is now visible. Now, when I tell it to check in a file after checking it out through the FrameMaker Content Manager and editing it, I get "The request failed with HTTP status 401: Unauthorized." But, when I go to SharePoint and look at the file, it has all my changes and I can check it in manually. Something still isnt' quite right. So my problem ticket is still open.

                            • 12. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                              Art_Campbell Community Member

                              OK, I know I said the same thing earlier, about checking permissions every which way, and you said you had.... but then you turned up the detail of including the domain name as part of your user name.

                               

                              So I would look again at the entire set up for that tiny thing that isn't quite right.

                               

                              I know you checked SP permissions, but do that again. Is SP on a server that's used for other things? Check the server permissions for the SP install. Was your FM installed with the exact same user name and group that you're using now and which is also the same as your name in SP?

                              • 13. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                MHMankowski Community Member

                                Art,

                                 

                                Let me explain. The login in dialog let me login with just listing my user name in the CMS in Frame. It was NOT obvious that the domain name was needed. The SharePoint Server is on the same domain that I log into with my user ID. Using the SharePoint interface itself, I can check documents into and out of Word, I can check files from my hard drive into and out of the SharePoint Server. I do NOT have administrator rights to our SharePoint server and I keep going back to our corporate developers and say check this or check that base on responses I have had from Adobe. The only reason I thought about the domain name is after pouring through all of the posts on the FrameMaker board and one mentioned domain name. So I thought about it and said what the heck let me put domain name in front of my login in name in CMS in Frame. Mind you when I login to our network the domain is (example) ARXXX. Our SharePoint server is on the same domain ARXXX. So it doesn't make much sense since everything is IN the SAME domain. But, I said what the heck let me put ARXXX\Username in the CMS dialog box in Frame. I still saw the exact same file listing in the repository manager that I did before. I still saw the check out but now I could see check in which I couldn't before. So I edit my Frame document save it, tell it to check it in then I get the aforementioned error. I go to another explore window look at SharePoint, tell it to check my file in there (it still thinks I have it checked out) and it checks it in. When I look at the file in read only mode I see all of my edits are there. What I believe is that something is NOT set up correctly on our SharePoint server. I have to go through a different group in our corporation to get them to check things but they have shown me I have all the write and read permissions to the directories (since I am the one who created them). My gut, after being an computer operator for over 20 years, in a prior job, is that something is NOT right in the way our SharePoint is set up to understand the FrameMaker CMS. Our SharePoint Server is working fine with Word and just placing other files there but it isn't playing nice with FrameMaker. That is why I am on this forum. I am looking for expertise from people that have Frame and SharePoint, maybe the error I mentioned will give somebody an idea and say hey check this or, turn this on, etc., etc.

                                • 14. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                  David_Coe Community Member

                                  I have a similar problem with FM10 but not as far along MHM, I can upload the files to sharepoint 2010 and they are checked in automatically but I cannot check out or open the files in FM. I am the SP Site Collection Owner and I have the permissions set correctly, at least as I would normally set them up for other applications like Word, PDF, etc. I was using the trial version of TCS3.5 and now just using FM10 trial until we get our SW licenses later this week; is the trial version limiting my access to SP? Or is there a special configuration in FM that was not readily apparent when I setup the CMS SP connector. For what it is worth, I am another 20+ years IT veteran with a programming background.

                                  • 15. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                    Jeff_Coatsworth CommunityMVP

                                    Trial copy's only limited in duration, not functionality

                                    • 16. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                      David_Coe Community Member

                                      Well, I received my TCS3.5 license yesterday afternoon. FM still behaves the same for me in regards to the SharePoint connector, that corroborates the trial's functionality :-). Does anyone know if there are any troubleshooting procedures or other detail documentation for setting up the SharePoint connector? I would like to review those before I contact Adobe helpdesk. I have reviewed all the videos on Adobe TV and several forums to no avail. If this is not the correct forum for this request, please let me know where I should post it.

                                       

                                      Thanks.

                                      • 17. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                        Suzy2001 Community Member

                                        We started out trying to use a server and port, but ended up using the URL for our SharePoint site (in the Server field). The first way would never work properly - got part of the way there but not fully, perhaps similar to what's happening with you. So at the suggestion of the Adobe helpdesk, we tried the URL and the user name and password. And it works.

                                        • 18. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                          David_Coe Community Member

                                          I had run into that problem initially also, then I used the URL and userid (with and without the domain) and was able to connect. It will upload the files and/or folders but I get an error in the upload status that says,” The following files could not be uploaded due to some error.” And then it lists all the files I was trying to upload. Does anyone know where the error log file is located. I was unable to find it yet.

                                           

                                          The files do show up in the repository manager and I can delete them there but I cannot check out, open in read mode or open for edit in FM. I can fully interact with the files in SharePoint. It is strange and frustrating. Since SharePoint is our repository, I will keep plugging away at it until resolved.

                                           

                                          David Coe

                                          Sr. Technical Editor

                                           

                                          Documentation and Training

                                          407.514.2332 office

                                          407.508.9959 mobile

                                          david.coe@gdit.com<mailto:david.coe@gdit.com>

                                          www.gdit.com<http://www.gdit.com/>

                                           

                                          General Dynamics Information Technology

                                          National and Homeland Security Division

                                          Integrated Security & Instrumentation Solutions – Live Training Ranges

                                          12249 Science Drive, Suite 130

                                          Orlando, Florida  32826

                                          • 19. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                            David_Coe Community Member

                                            I now am able to successfully upload, checkout, edit and save files via FM, but I cannot check in or anything else unless I do it directly in SharePoint outside of FM. So is there a resolution for this problem yet. I have seen several posts on this problem and I have not seen a resolution posted yet. I even posted to TCS support too.

                                             

                                             

                                            Update: The save features appears to work but in reality it does not save the changes. I've had one session with Adobe TCS support and so far they say I have everything set up correctly and they will have to do further research to find the resolution while I double-check with my SharePoint IT department to make sure there is not any issue at a higher permission level than my own Site-Owner/full-control permission level.

                                             

                                            Update2: Adobe stilll has not found a resoultion yet for connecting SP2010. We recently converted from SP2007 in February, so I still had access to it. I set up FM10 SP connector to SP2007 and it works as advertised, check out, edit, check in, read only, etc. I was so pleased but it does not solve my SP2010 issue which is the company's production server (SP2007 will be shut down eventually).

                                             

                                            The error seems to be that SP2010 cannot use the C:\user\AppData\Adobe\Framemaker\<sp connector folder>, either the file is locked in Framemaker, when Check Out and Edit is selected, before the file is copied there for editing or SP2010 does not work well with local draft folder. SP2007 had no problem with this and works from the local draft folder easily. BTW, I had not realized Framemaker did this, I thought it worked directly on the SP server. Anyway, I've submitted all this info with screenshots and everything to Adobe Support, hopefully they can figure it out.

                                             

                                            My company tech support said I can work with the FM file in SharePoint outside Framemaker with no issues, then it is not a permission or SP2010 issue, that it must be a FM issue. So I continue to work through this.

                                             

                                            Update 3: SP2010 has the configuration option to use the (new) claims-based authentication or classic authentication. My company elected to use claims-based authentication with SP2010. SP2007 uses classic authentication. FrameMaker 10 does not seem to support claims-based authentication but the verdict is still out until I get a confirmation or resoultion from Adobe.

                                             

                                            Message was edited by: David_Coe

                                            • 20. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                              TDocMaker

                                              David,

                                              Did you ever get a confirmation or resolution described in your Update 3? I have tried several configurations of the Frame CMS connector to get it to work with SharePoint Online. From what I have seen on the Microsoft site, SharePoint Online uses claims-based authentication. If Frame doesn't support this type of authentication, it might explain why I haven't been able to make it work.

                                              • 21. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                                David_Coe Community Member

                                                Thanks for reminding to at least update the results thus far.

                                                 

                                                Update 4:

                                                I did get quite a bit of support initially although slowly over a period of a month or so. After Adobe FM support and my SharePoint systems engineer reviewed how FM10 was setup on my computer (which I am the admin for our department’s SP site) and how it interfaces with our SharePoint 2010 Enterprise Edition, there was two conclusions:

                                                 

                                                • Basically Adobe FM Support said that FM10 did not support claims-based authentication and they can no longer help me. They said it will work with FM11 when it comes out.

                                                 

                                                • My SP Systems Engineer, said that FM10 is connecting to SP 2010 just fine but that the FM10 has a software glitch that causes FM10 lose control when executing checkout procedure within FM10. I can checkout and edit that same file in SP with no problems.

                                                 

                                                About a month later, I upgraded to FM11 and ran into the same problem. I attempted to get Adobe FM Support to help and they said they will look into and get back to me. That was in July and I have not heard anything more from them, and to be honest, my schedule has been extremely busy the last 5 months that I have not had time to pursue it any further.

                                                 

                                                Needless to say, I was very disappointed with the SP interface and, overall, the lackluster support I received from Adobe. Having a working SP interface was one of the criteria for purchasing TCS3.5 (and subsequent upgrade) in the first place.

                                                 

                                                One thing of note, we migrated from SP 2007 to SP 2010 in February 2011 and, at the time of Adobe support, I still had access to my SP 2007 site. FM10 and FM11 had to no issues working with SP2007. Unfortunately, SP 2007 is not an option for me anymore.

                                                 

                                                Also, another observation of FM10/11 not working with SP 2010, it seems that FM10/11 is automatically configured to work with SharePoint Drafts folder locally when connecting to the SharePoint library. This worked just fine with SP 2007 but SP 2010 does not use SharePoint Drafts folder locally the same way (the programming changed, don’t recall where I saw it, probably when searching this issue online)  and I suspect that is one of the main issues why it does not work correctly.

                                                 

                                                So at this time, I have not found a working solution to this problem.

                                                • 22. Re: Has anyone had success using SharePoint and FrameMaker 10 together using CMS?
                                                  TDocMaker Community Member

                                                  This was a helpful update...not encouraging, but helpful. I have been trying to get Frame 10 CMS connected to SharePoint Online 2010 with Office 365 off and on for the past six months...nothing worked. I've resorted to using SharePoint like a server. If anyone has been successful connecting this configuration, I'd appreciate learning how you did it. I had contacted two different Adobe support people long ago and neither could tell me how to make it work. They were to get back to me and didn't. I, too, got busy (and frustrated). Later my case was listed in the case history as "Withdrawn," yet I didn't withdraw it.