6 Replies Latest reply: May 17, 2012 3:29 AM by Paul-ny RSS

    motion blur is disabled

    Paul-ny

      I've been making changes to someone else's AE file with a lot of layers that have motion blur. I've changed positions of many of the objects, and now there isn't motion blur in many places where there was before, A great many layers have a hyphen in the timeline's Motion Blur box instead of the Motion Blur icon. And there doesn't seem to be any motion blur in those layers.

       

      When I click in a box with the hyphen, nothing happens. In the Layers menu, Switches>Motion Blur also doesn't do anything.

       

      Please-- what is happening? Is AE telling me I don't have the resources to do this, maybe?

       

      I'm using a MacBook Pro  2.8 G with 4 G of RAM, OS 10.6.8, and After Effects CS 5.5

        • 1. Re: motion blur is disabled
          caseyinhd

          Are they hyphens on pre-comps?

           

          That hyphen usually means that you have a pre-comp with transformations collapsed.  That's the switch with the little sun-lookin' thing on the pre-comp layer.  Don't mess with that unless you're familiar with how the layers are set up or you might mess something up.

           

          Enter the pre-comps and enable motion blur on the individual layers.

           

          Making any sense?

           

          Casey

          • 2. Re: motion blur is disabled
            Mylenium MVP

            This has nothing to do with resources. You have pre-composed stuff or used combinations of blending/ matte modes. All the hyphen tells you is that any pertinent switches will have to bbe set in the pre-comps and/or you may need to restructure your project to get motionblur.

             

            Mylenium

            • 3. Re: motion blur is disabled
              Paul-ny

              Thank you for this. It's true: the hyphens are all on comps and not on straight footage layers. And most but not all of them have the transformation collapse icon showing. But I have gone into a number of these comps and enabled motion blur on every layer (except for an audio layer) but the hyphen is still there. In each case there's also a hyphen on the "Wire, Draft, Best" switch. I tried quitting and relaunching AE but that didn't help.

               

              These are comps that had working motion blur in the AfterEffects (PC CS5.0) file I received; I went in and added some keyframes (with Mac CS 5.5) but didn't do anything else that I am aware of, and now have these hyphens and no blur. Just putting in some Hold keyframes wouldn't have this effect, would it?

              • 4. Re: motion blur is disabled
                Mylenium MVP

                Just putting in some Hold keyframes wouldn't have this effect, would it?

                 

                Exactly the opposite: Hold does what it says - it does not interpolate, hence no motion blur. And again, those hyphens mean that switches/ settings are inherited. Fix the pre-comps and the motionblur wil lrender just fine. If that's not possible, try things like CC force Motionblur or comemrcial tools like RSMB to introduce artificial/ forced motionblur.

                 

                Mylenium

                • 5. Re: motion blur is disabled
                  Paul-ny

                  Thank you, I guess I might have to go way in and change each hold keyframe I've made to two regular ones one frame apart.

                   

                  If I prerendered a composition that has hold keyframes in it, would that prerendered object then be able to have motion blur applied?

                  • 6. Re: motion blur is disabled
                    Paul-ny

                    Thank you! I couldn't get rid of the hyphens but I enabled m.b. in all the underlying comps and blur works fine.

                     

                    HOWEVER a big unrelated problem has occurred: I can't render past a certain point, but get an internal error something like "worldviewspotter has reported a worldview of the wrong size.". Mylenium, your website according to Google seems to be the only place on the Internet with an explanation, but your site is changing and it seems the posting isn't there now.

                     

                    Can you help me again?

                     

                    Hopefully...

                    Paul